LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   starting awesome window manager (http://www.linuxquestions.org/questions/slackware-14/starting-awesome-window-manager-690286/)

zoran119 12-13-2008 06:25 AM

starting awesome window manager
 
hi guys,

i want to try awesome window manager but i cannot get it to start when i log in. i'm using kdm and there is no awesome to choose in the session type list.

i have tried xwmconfig and selected awesome but it looks like kdm is not respecting it.

i have also tried xdm and i cannot specify any manager apart from kde.

here are my .xinitrc
Code:

$ cat .xinitrc
#!/bin/sh
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    /usr/bin/xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    /usr/bin/xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    /usr/bin/xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    /usr/bin/xmodmap $usermodmap
fi

exec awesome

and .xsession
Code:

$ cat .xsession
# This program, based on code found in the gpg-agent man page, is
# presumably licensed under the GPL.
#
# As the effects of this default .xsession on an account using
# (t)csh are not yet known, feedback and/or suggestions are welcomed.

if [ -x "$(which gpg-agent)" ]; then
  if test -f $HOME/.gpg-agent-info &&    kill -0 $(cut -d: -f 2 $HOME/.gpg-agent-info) 2>/dev/null; then
    GPG_AGENT_INFO=$(cat $HOME/.gpg-agent-info)
    export GPG_AGENT_INFO
  else
    eval $(gpg-agent --daemon)
    echo $GPG_AGENT_INFO >$HOME/.gpg-agent-info
  fi
fi

# Note that the new option --write-env-file may be used instead.

# You should always add the following lines to your .bashrc or whatever
# initialization file is used for all shell invocations:
 
GPG_TTY=$(tty)
export GPG_TTY

can someone help?

Tuttle 12-13-2008 07:49 AM

awesome.

Don't use KDM, go to the appropriate runlevel for console mode (stop the X server) then run startx.
Alternatively, make a new *.desktop file in /usr/share/xsessions

gnashley 12-13-2008 08:31 AM

You can take one of the xinitrc files in /etc/X11/init and use it as a starting point. Copy and rename it and then edit it to run awesome. You'll then need to start by running from runlevel 3. Run xwmconfig and choose the entry for awesome. Then 'startx'.
Usually you'll have a couple of entries in the xintrc file -since these minimal window managers don't alway have a desktop menu, you'll probably want to start at least an xterm to run at startup. So something like this should work at the bottom of the xintrc file:
xterm &
exec awesome

zoran119 12-13-2008 09:15 AM

i changed /etc/X11/xinit/xinitrc to be a symlink to /etc/X11/xinit/xinitrc.awesome rather than /etc/X11/xinit/xinitrc.kde. i also changed from kdm to xdm and it seems to be working now. thanks for your help

how i have to check this window manager out... it's different... does anyone know how to:
1. use key codes (revealed by xev) to make keyboard shortcuts
2. close a window (no little x button in the top right corner)
3. configure awesome so that the screens are not separate, ie so that each doesn't have it's own set of tags (dual screens)
4. related to 3, is there a keyboard shortcut that jumps between the two screens when they are separate

chess 12-13-2008 01:42 PM

Zoran, I use awesome quite a bit. Which version of awesome are you using and where did you get it from?

The key is reading and customizing your configuration file. You should spend some time reading the awesome wiki. The entire window manager is keyboard driven, so you don't click a button to close a window.

I actually maintain the awesome SlackBuild from SlackBuilds.org in case that is what you used to install awesome. If that's what you used, then make sure you are reading about awesome2 and not awesome3 since my slackbuild script is for awesome2. Awesome3 is completely different than awesome2. I believe the default configuration setting for awesome2 is to use Mod4-Shift-c (see the sample config file in the docs directory /usr/share/doc/awesome-2.3.4 if you used the SlackBuild script from SlackBuilds.org).

Good luck!

zoran119 12-13-2008 09:25 PM

yep, i used your build script. thank you!!!

i have been looking at the awesome wiki, but it's all about version 3... any plans for a build script for version 3?

chess 12-13-2008 10:51 PM

No, I don't plan on it. I mentioned this on the SlackBuilds.org mailing list awhile back. Personally, I am happy with awesome2 and I am not crazy about all the changes in awesome3 and how it's now all lua-based. It seems you basically need to learn lua in order to write a config file now. If someone comes along and submits a separate SlackBuild for awesome3 to SlackBuilds.org that would be great, but it ain't gonna be me. :-)

And if the wiki dropped all the information about awesome2, that is unfortunate. It was my understanding it was going to be kept up there because so many users are remaining with awesome2. There are plenty of sample configs out there -- just google for "awesome2 awesomerc" or something like that.

Here are a couple things I found:
http://urukrama.wordpress.com/2008/0...indow-manager/
http://wiki.archlinux.org/index.php/Awesome2
http://dotfiles.org/~psycho_one/.awesomerc
http://dotfiles.org/~urukrama/.awesomerc
http://ardoris.wordpress.com/2008/07/01/my-awesomerc/
http://ubuntuforums.org/showthread.php?t=755960

zoran119 12-20-2008 08:23 AM

ok, i've been playing with awesome and it is pretty awesome, but can someone tell me how can i start firefox on screen 0 and 3 terminals on screen 1 upon login?

i have ~/.awesome/start_awesome.sh from which i can start these apps, but how do i tell awesome which app goes on which screen?

sahko 12-20-2008 10:36 AM

this is not an "awesome" help forum you know.. im sure you will get more help if you ask in some "awesome" related resource


All times are GMT -5. The time now is 08:03 AM.