LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-01-2014, 01:23 AM   #1
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 382

Rep: Reputation: 30
start x server without window manager?


hello!
i see around for subj.
want to get to work boinc computions on my server, using ATI videocard gpu, but there is a problem - boinc not see the GPU unless X is started. on server i not neet GUI, as so, a naked X server without window manager be ok for me in that situation, i think, but i never do that problem previous - in past i start x server only when i need a GUI....
 
Old 02-01-2014, 03:00 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,497

Rep: Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570
Hide /etc/X11/(xinit/)xinitrc which can possibly live in /usr/X11R6/lib64/X11/xinit/

The window manager is set there.
 
Old 02-01-2014, 03:42 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
Alternatively, start X with a self written WM that does nothing.
An example for a simple dummy WM, written in Ruby:
Code:
#!/usr/bin/ruby
sleep
This "WM" will after starting just put itself into sleep, using no CPU time, and sleep indefinitely.
To start X with that dummy WM, just run
Code:
xinit /path/to/dummy-WM-script
 
Old 02-01-2014, 05:39 AM   #4
whizje
Member
 
Registered: Sep 2008
Location: The Netherlands
Distribution: Slackware64 current
Posts: 583

Rep: Reputation: 129Reputation: 129
What might work is start kdm in rc.local and change in kdmrc
Quote:
StaticServers=:0
# List of on-demand displays. See StaticServers for syntax.
# Default is ""
ReserveServers=:1,:2,:3
to
Quote:
#StaticServers=:0
# List of on-demand displays. See StaticServers for syntax.
# Default is ""
ReserveServers=:0,:1,:2,:3
so that if you want a gui you can just use startx.
 
Old 02-01-2014, 06:40 AM   #5
genss
Member
 
Registered: Nov 2013
Posts: 239

Rep: Reputation: Disabled
try
/usr/bin/X
 
Old 02-01-2014, 11:55 AM   #6
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 2,237

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
You can always use "startx application".

I believe that bypasses the default startup script used when there are no applications specified.
 
1 members found this post helpful.
Old 02-01-2014, 12:52 PM   #7
qweasd
Member
 
Registered: May 2010
Posts: 446

Rep: Reputation: Disabled
If you go to runlevel 4 and kdm starts, you can simply log into "failsafe" session.
 
Old 02-01-2014, 01:31 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
Quote:
Originally Posted by qweasd View Post
If you go to runlevel 4 and kdm starts, you can simply log into "failsafe" session.
You don't even need to. If the whole goal is to start X you have reached that goal already when a display manager like KDM is running. Though in this case I would choose a more lightweight option, like XDM.
 
Old 02-02-2014, 10:14 AM   #9
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 382

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by TobiSGD View Post
Alternatively, start X with a self written WM that does nothing.
An example for a simple dummy WM, written in Ruby:
Code:
#!/usr/bin/ruby
sleep
This "WM" will after starting just put itself into sleep, using no CPU time, and sleep indefinitely.
To start X with that dummy WM, just run
Code:
xinit /path/to/dummy-WM-script

sorry, that not works. i try, and it looks like to initialized videocard ( you know, that thing, when vcard switching to graphics mode) and then got out with error message - something like "use sleep --help" at the end. sadly, i cannot paste full error output, but i think, you can easy replicate that
 
Old 02-02-2014, 10:16 AM   #10
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 382

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by genss View Post
try
/usr/bin/X

try. on that, my coputer lock up. cannot switch to another terminals ( ctrl+alt+Fx), not also numlock reaction on keyboard...
 
Old 02-02-2014, 10:17 AM   #11
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 382

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by qweasd View Post
If you go to runlevel 4 and kdm starts, you can simply log into "failsafe" session.
i plan to do that on my small server. i do not need runlevel 4 on server, nor also any GUI. x server i need because boinc cannot see ATI GPU until X is running...
 
Old 02-02-2014, 10:54 AM   #12
lems
Member
 
Registered: May 2004
Posts: 144

Rep: Reputation: 44
Quote:
Originally Posted by WiseDraco View Post
sorry, that not works. i try, and it looks like to initialized videocard ( you know, that thing, when vcard switching to graphics mode) and then got out with error message - something like "use sleep --help" at the end. sadly, i cannot paste full error output, but i think, you can easy replicate that
Make sure you use the right shebang:
Code:
#!/usr/bin/ruby
sleep in this case is a ruby function/method, not sleep(1).
 
Old 02-02-2014, 11:14 AM   #13
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 382

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by lems View Post
Make sure you use the right shebang:
Code:
#!/usr/bin/ruby
sleep in this case is a ruby function/method, not sleep(1).


bash-4.2$ /usr/bin/ruby -v
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]


you test that solution, and it work for you?
 
Old 02-02-2014, 11:22 AM   #14
lems
Member
 
Registered: May 2004
Posts: 144

Rep: Reputation: 44
Hi,

yes, the code TobiSGD posted worked for me.

Code:
cat << EOF > $HOME/dummy.rb
#! /usr/bin/env ruby
sleep
EOF

chmod +x $HOME/dummy.rb
xinit $HOME/dummy.rb
and then I get a black screen (make sure the script is executable).

lems
 
Old 02-02-2014, 11:36 AM   #15
genss
Member
 
Registered: Nov 2013
Posts: 239

Rep: Reputation: Disabled
Quote:
Originally Posted by WiseDraco View Post
try. on that, my computer lock up. cannot switch to another terminals ( ctrl+alt+Fx), not also numlock reaction on keyboard...
probably doesn't have permission to get input
my bad

bdw you can use "sleep 100d" to sleep for a 100 days, if you don't want to load ruby
 
  


Reply

Tags
ati, boinc, x server


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to start window-manager with beryl lord_didger Linux - Desktop 3 01-26-2008 11:01 PM
PROBLEM: window manager won't start linux4real Linux - Newbie 4 05-03-2006 01:17 AM
Window manager doesn't start ka7znm Fedora 1 10-03-2004 08:54 AM
How do I get the window manager to start straight away? neocookie Slackware - Installation 4 04-27-2004 02:48 AM
start X without a window manager BTseapig Programming 1 03-14-2002 04:58 AM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration