LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-17-2004, 09:36 AM   #1
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
start lisa daemon


where do i add lisa to get it to run on login or startup? i can see my xp machines shares with samba by making a shortcut to smb://xpmachine. but the lan browser in konqueror needs lisa. where do i put it to start it and whats the difference?

thanks
 
Old 04-17-2004, 09:58 AM   #2
manuelkuhs
Member
 
Registered: Apr 2004
Location: Ennis, Ireland
Distribution: SuSE9.1
Posts: 30

Rep: Reputation: 15
Hey, I run SuSE9.0, so it might be different for you; here's how I do it:

I open YAST, and go into the Runlevel Editor (come to think of it, maybe other distros have a Runlevel Editor). Then I switch to Expert Mode, and scroll along to the LISa daemon, then I set it to run for runlevel 5, which causes it to automatically be started everytime runlevel 5 is initiated (which is the GUI). You can also start it straight away.

Hope it helps,
Manuel
 
Old 04-17-2004, 10:13 AM   #3
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Original Poster
Rep: Reputation: 30
thanks for your reply. i did ind somehting like that, but i think it is kde specific, called SysV-init editor. i started it but wasnt sure of what to do, so i didnt make any changes, but i think you are right, i some how need to add lisa somewhere in a startup script file, but not sure which one or what line to add. on slackware we have a /etc/rc.d folder and in there is a file called rc.4 which i think is for runlevel 4 (slackware uses 4 everyone else from what i have seen uses 5), but there is no daemon line or anything like that

the search continues!

by the way i love your taglines there, very funny stuff!
 
Old 04-18-2004, 07:12 AM   #4
BlankFrank
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Suse 9.2 (AMD64) / Mandrake 10
Posts: 62

Rep: Reputation: 15
yeah - I'm looking for some help with this too.

basically from what I've found SysV-Init doesn't work because Slack uses bsd style files rather that SysV (correct me if i'm wrong)

I also found someone saying to add

#To start the lisa Daemon
if [ -x /opt/kde/bin/lisa]; then
-x /opt/kde/bin/lisa &
fi

to the rc.local file. but this doesn't seem to work for me either. plus the command 'service lisa start' doesn't work either - don't know if that is a slack thing or user error.

Any suggestions?
 
Old 04-18-2004, 04:07 PM   #5
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Original Poster
Rep: Reputation: 30
i ran that sysV-init thing and it hosed up my kdm. irebooted and had all kinds of users in the list to login, not just mine and root, but other system type accounts. and if i picked one and tried to login, it opened a command line only and i couldnt type anything. switched to tty6 and got a console logon and changed to runlevel 3 and can get in that way. i just changed the logon manager settings and will reboot to see if it takes affect (runlevel 4)
startingt he lisa daemon will have to wait
 
Old 04-18-2004, 04:58 PM   #6
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 48
I dont use this lisa, but there seems to be some setup stuff in KDE/control centre/Internet & Network/Local Network Browsing. Under lan/rlan tab - check availability.
Guess you've been there already...
 
Old 04-18-2004, 05:00 PM   #7
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Original Poster
Rep: Reputation: 30
well, whatever the sysV-init tool did hosed up kdm. runlevel 3 and using startx works fine but if i change to runlevel4 and login (even after resetting the login manager) i get nothing but a command line box but cannot type

for loading lisa, i think he file to add those lines is the /etc/rc.d/rc.inet2 file, but i havent tried it yet, it might be one of the other ones in there, but i think it is that one. one of them say this is where you load network daemons, at least on slackware
 
Old 04-18-2004, 10:26 PM   #8
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Original Poster
Rep: Reputation: 30
tobyl, thanks for your reply, didnt see it earlier.

i am running kde 3.2.1 and i konqueror there is a lan browser link that complains about lisa not runningg. i am running samba and browse my etwork that way. i make a shortcut to smb://desktop and i can see my XP shares that way, but to do it in konqueror you need lisa running. on other distros (archlinux for instance) you can add lisa to the daemons line of the rc.conf file, butt i cant seem to find anything similar in slackware.

those settings in the control center are for the lan rowser but i think you need lisa running even for those. i will double check though and let you know wat i find out.

thanks again everyone.
 
Old 04-19-2004, 03:08 AM   #9
BlankFrank
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Suse 9.2 (AMD64) / Mandrake 10
Posts: 62

Rep: Reputation: 15
Yeah the control centre settings allow you to configure Lisa but not to start it (strangely enough)

Everything else about Slack I like so far - but it seems to make this unnecessarily difficult.
 
Old 04-19-2004, 12:25 PM   #10
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 48
First I did this:

root@********:~# /opt/kde/bin/lisa --help

This is the LAN Information Server LISa 0.2.3
It is free software according the GNU General Public License
Copyright (c) 2000-2003 by Alexander Neundorf
email: neundorf@kde.org

-v, --version prints out a short version info
-u, --unix deprecated
-k, --kde1 deprecated
-K, --kde2 deprecated
lisa now looks always first for $(HOME)/.lisarc, then for /etc/lisarc
-c, --config=FILE read this and no other configuration file
-q, --quiet start quiet without the greeting message
-p, --port PORTNR start the server on this portnumber
if you use this LISa won't be able to
cooperate with other LISa's in the network
-h, --help you are currently reading it ;-)

so far so good...so I ran it from the command line, and it worked.

next I looked at your script:

#To start the lisa Daemon
if [ -x /opt/kde/bin/lisa]; then
-x /opt/kde/bin/lisa &
fi

note the positioning of the square brackets :-(

this is my version:

#To start the lisa Daemon
if [ -x /opt/kde/bin/lisa ]; then
/opt/kde/bin/lisa
fi

I think this is network stuff so I put it at the bottom of /etc/rc.d/rc.inet2

reboot - hey! it works...

Also I noticed that there is a 'Guided Lisa setup' button in the Lisa Daemon tab of Control centre, that may be worth doing too :-)

slightly smug tobyl...


oh, there maybe security implications with this app, and firewall settings may be important
too?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LiSA Daemon desertViking Slackware 4 10-21-2005 01:23 PM
Lisa Daemon KrGAce Linux - Networking 3 06-19-2005 09:43 AM
Lisa daemon Jeebizz Slackware 10 09-01-2004 12:03 PM
How to start Lisa daemon? deanwhitaker Linux - Newbie 0 03-19-2004 08:17 AM
lisa daemon huno Slackware 1 11-03-2003 08:55 AM


All times are GMT -5. The time now is 08:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration