LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   start KDE error after update to -current but interrupted by electricity problem ! (http://www.linuxquestions.org/questions/slackware-14/start-kde-error-after-update-to-current-but-interrupted-by-electricity-problem-831797/)

el_jauzaa 09-12-2010 10:20 PM

start KDE error after update to -current but interrupted by electricity problem !
 
hi !

again i have an error in my box.

i updated to -current, but in the middle of update, the electricity is down (in my country, this problem always occur very often).
i turn on my box again and run slackpkg update && slackpkg upgrade-all to finishing update that interrupt by the electricity problem.
but after i completely updated my box, i reboot but i cannot enter KDE, if i want to enter XFCE, the window decorator is missing.

FYI, my home directory space is sufficient (approx 1,5 GB)

and this is the report after i run startx in KDE WM
Code:

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.1 Slackware Linux Project
Current Operating System: Linux mybox 2.6.33.4-smp #2 SMP Wed May 12 22:47:36 CDT 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz root=/dev/sda2 ro vt.default_utf8=0 vga = normal
Build Date: 20 August 2010  01:19:01PM

Current version of pixman: 0.16.6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 13 10:00:09 2010
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "fbdev" (module does not exist, 0)
WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
kapplymousetheme: error while loading shared libraries: libdbusmenu-qt.so.2: cannot open shared object file: No such file or directory
xset:  bad font path element (#23), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
startkde: Starting up...
/usr/bin/kdeinit4: error while loading shared libraries: libdbusmenu-qt.so.2: cannot open shared object file: No such file or directory
startkde: Could not start kdeinit4. Check your installation.

please help me.

thx.

MannyNix 09-12-2010 11:01 PM

I think you missed slackpkg install-new and you're needing: l/libdbusmenu-qt-0.6.1-i486-1.txz: Added.

If not, I guess I'd take all the latest packages and one by one I'd do: upgradepkg --reinstall <package-name> and after that I'd check for *new files either by slackpkg new-config or by find /etc -name "*new".

Hope it helps, good luck

el_jauzaa 09-13-2010 12:43 AM

yes i miss slackpkg install-new...i didn't ever use that command...

thx for the assist...


All times are GMT -5. The time now is 01:10 PM.