LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2005, 10:55 PM   #1
jrbush82
Member
 
Registered: Mar 2002
Location: Hampton, VA
Posts: 86

Rep: Reputation: 15
Standard Mouse not Working After 10.1 Install


As the title says, I am unable to get my mouse working at all. During the install I used a KVM switch during the installation, but that shouldn't make any difference other than it seeing a standard PS2 mouse. Just to rule it out, I hooked a standard PS2 mouse up directly the system and still can't get it to work. I've done cat /dev/mouse & /dev/psaux and there isn't any raw data coming whenever I move it. Any ideas?
 
Old 05-07-2005, 11:21 PM   #2
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
you might try running xorgconfig again as root, to rewrite your xorg.conf file...seems like any reference to your mouse got lost somewhere...doing this will rewrite it to include your mouse.
 
Old 05-07-2005, 11:24 PM   #3
jrbush82
Member
 
Registered: Mar 2002
Location: Hampton, VA
Posts: 86

Original Poster
Rep: Reputation: 15
this has nothing to do with x.org / xfree86
 
Old 05-07-2005, 11:27 PM   #4
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
nothing to add here...

Last edited by detpenguin; 05-07-2005 at 11:39 PM.
 
Old 05-07-2005, 11:29 PM   #5
cavalier
Member
 
Registered: Feb 2005
Location: Denver, CO
Distribution: Slack 12, tweaked just so (though I'm also a fan of Ubuntu)
Posts: 198
Blog Entries: 1

Rep: Reputation: 30
Have you ruled out hardware failure? Specifically, this PS/2 mouse you plugged in works on other systems? This mouse works on this system with other OSes (Windows, or a bootable CD linux like Slax)? Have you got a USB mouse floating around somewhere you could try?
 
Old 05-08-2005, 11:03 PM   #6
m_rizvan_m
LQ Newbie
 
Registered: May 2005
Posts: 18

Rep: Reputation: 0
mouseconfig

Try reinstalling your mouse hardware driver:

do these steps in console (init 3) no X plz

1. /etc/rc.d/rc.gpm stop
2. mouseconfig
3. choose your mouse type
4. /etc/rc.d/rc.gpm start
5. move your mouse device and can you see your mouse pointer?

do steps 1-4 until you get the right configuration. And also try to get a good working mouse from your friend
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suddenly my standard PS/2 MS mouse pointer has stalled langbein Suse/Novell 22 11-09-2005 05:12 PM
Microsoft Standard Optical Wireless Mouse error ltracy Linux - Hardware 0 09-28-2005 03:02 AM
10.1 after install, mouse not working pcdebb Mandriva 10 04-01-2005 04:27 PM
Mouse and Keyboard not working on install phil_stennett Mandriva 5 11-18-2004 04:29 PM
standard vs Expert install? Standard flubs up! Frost Linux - Software 1 03-27-2002 07:55 AM


All times are GMT -5. The time now is 08:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration