LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   SSH on Slack64-13.1 no longer works - Wrong password? (http://www.linuxquestions.org/questions/slackware-14/ssh-on-slack64-13-1-no-longer-works-wrong-password-4175468724/)

lpallard 07-06-2013 05:39 PM

SSH on Slack64-13.1 no longer works - Wrong password?
 
So my slack64-13.1 box has been working fine until I upgraded packages with

slackpkg upgrade-all


Now I can no longer log thru SSH. Not working for root or standard user.

I get

Code:

bash-4.1$ ssh 192.168.0.107
lpallard@192.168.0.107's password:
Permission denied, please try again.
lpallard@192.168.0.107's password:
Permission denied, please try again.
lpallard@192.168.0.107's password:
Permission denied (publickey,password,keyboard-interactive).

Code:

bash-4.1$ ssh root@192.168.0.107
root@192.168.0.107's password:
Permission denied, please try again.
root@192.168.0.107's password:
Permission denied, please try again.
root@192.168.0.107's password:
Permission denied (publickey,password,keyboard-interactive).

How can I reset the password ????

lukkon 07-06-2013 06:11 PM

I think it's not possible to reset password through ssh, you should login to this machine locally and then run ssh in debug mode
Code:

/usr/sbin/sshd -d
try to connect and read debug messages or if you just forget password you can boot slackware installation disk, chroot into your system on harddrive and then use passwd command to change password.

WhiteWolf1776 07-06-2013 08:47 PM

If you are sure that's the right ip address... and you don't have any valid username / password pairs... there isn't a way to "reset" the password remotely. (there is a chance your /etc/rc.d/rc.sshd may have had it's +x removed ... somehow)

I'd double check that the ip address is what you think it is... upgrading packages have not changed passwords imho.

gezley 07-06-2013 09:45 PM

Quote:

Originally Posted by lpallard (Post 4985375)
So my slack64-13.1 box has been working fine until I upgraded packages with

slackpkg upgrade-all

Now I can no longer log thru SSH. Not working for root or standard user.

Two things spring to mind:

1) You inadvertently updated /etc/ssh/sshd_config, thus resetting authentication parameters for which you had custom settings in the older version.

2) Your memory is failing with old age, and you were using a public/private key pair, not a password, to log in.

:D


All times are GMT -5. The time now is 11:25 AM.