LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-30-2003, 03:53 PM   #1
slackwarefan
Member
 
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Rep: Reputation: 30
SSH not installing properly


I just downloaded nessus and ran it on my computer to see if I was vulnerable for anything, well it turns out I've got five security holes. I have the ssh and sendmail vulnerabilities the proftp the apache server and the php vulnerability. Nessus recomonded upgradeing to the next version of each software package, so First I tried sendmail but found that installing it is not the same as installing other programs and it was very confusing. Next I decided to try openssh, I ran the program and it appeared to install correctly, so I rebooted and ran nessus again but it still reported the security hole. Does anyone know what I may be doing wrong and also does anyone know where I could find better instructions on installing sendmail than the INSTALL file that came with it?
 
Old 10-30-2003, 07:54 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,765
Blog Entries: 54

Rep: Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976
Your question is not about security. You probably confused fora/security issues with installing an app that enhances security. I'll move your post to the Slackware forum.
 
Old 10-30-2003, 08:23 PM   #3
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
Recent versions of Slackware are still maintained. So security issues will be resolved in patched packages, whichyou can find on the Slackware ftp and mirrors. The packages are in the Slackware-<version>/patches/packages directory. Download those and use upgradepkg <name of packages you want to upgrade> to update your packages. After that, there shouldn't be a known security issue on your system left.

Subscribing to the Slackware-security mailinglist is very usefull as well. It will send an email when there are new upgraded packages with location of these packages, description of the problem and how to install these packages.
There's an online archive at http://www.slackware.com/security/li...ecurity&y=2003 .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to setup rsh or configure ssh properly cheeku Linux - Software 5 03-30-2006 08:47 AM
SSH not verifying properly... Napalm Llama Linux - Software 5 02-05-2005 12:13 PM
System won't boot properly knoppix doesn't initialize properly rodewan Linux - Software 0 01-23-2005 04:35 PM
Problems installing Radeon 9800 Pro properly under Red Hat 9 Dash Rantic Linux - Hardware 1 01-23-2004 08:34 PM
Lilo not installing properly bripage Linux - General 10 07-26-2002 03:29 AM


All times are GMT -5. The time now is 01:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration