LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-21-2009, 04:10 PM   #1
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
src2pkg install error with Slackware64


I thought I would try out Slackware64 so I threw it on a spare drive and it's working fine so far except I need src2pkg since I use if for a few obscure packages that I use. Anyway I tried installing to it today but I keep getting errors related to libsentry... here is the actual output


root@slackware64:/remove/libsentry-0.6.7.5# make
cc -Wall -U_FORTIFY_SOURCE -D_GNU_SOURCE -DLIBDIR=\"/usr/lib64\" -DPIC -fPIC -D_REENTRANT -DVERSION=\"0.6.7.5\" -c libsentry.c
libsentry.c:2911: error: conflicting types for 'readlink'
/usr/include/unistd.h:787: error: previous declaration of 'readlink' was here
make: *** [libsentry.o] Error 1


Any thoughts on how to fix this are appreciated.

Thanks

Last edited by Daedra; 05-21-2009 at 04:47 PM.
 
Old 05-21-2009, 11:29 PM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,756

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
Thanks for reporting this. Unfortunately I don't have any 64-bit hardware, so fixing this will be a little harder. Thanks for reporting the full error message as this will be very helpful.

Okay, I think I see the problem.
This patch should fix it:
Code:
--- ./create-defines.01	2007-12-24 22:55:08.000000000 +0100
+++ ./create-defines	2009-05-22 06:21:51.000000000 +0200
@@ -78,6 +78,16 @@
 		7)
 			echo '#define GLIBC_MINOR 7' >> $OUTFILE
 			SUBVERSION='glibc-2.7' ;;
+		8)
+			echo '#define GLIBC_MINOR 8' >> $OUTFILE
+			SUBVERSION='glibc-2.8' ;;
+		9)
+			echo '#define GLIBC_MINOR 9' >> $OUTFILE
+			SUBVERSION='glibc-2.9' ;;
+		10)
+			echo '#define GLIBC_MINOR 10' >> $OUTFILE
+			SUBVERSION='glibc-2.10' ;;
+		
 		*)
 			echo 'Treated as glibc >= 2.1 (finger crossed)'
 			echo '#define GLIBC_MINOR 1' >> $OUTFILE
Save that as glibc-minor.diff and apply that from within the unpacked libsentry sources using:
patch -p0 < glibc-minor.diff
The run 'make'

If that fixes the compile okay, I'll send you an updated src2pkg package with the fix included. I'm just about ready to release, so it is very good that you have found and reported this so the fix gets included.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
src2pkg and post install options rpedrica Slackware 6 11-12-2008 01:35 PM
New src2pkg release available for download -Introducing the src2pkg WIKI gnashley Slackware 11 05-06-2008 11:09 AM
src2pkg fails, no install line given even though fake_install is commented out agentc0re Slackware 2 02-13-2008 05:44 PM
Trying to install slackware - dual booting wit xp SphereX Linux - Newbie 4 06-01-2007 05:33 AM
problem wit GRUB..post 6.0 install JusCrzn Linux From Scratch 6 12-24-2004 12:25 PM


All times are GMT -5. The time now is 07:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration