LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-10-2008, 02:02 PM   #1
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
src2pkg and squid installation


I'm having an issue with the installation of squid using src2pkg: if I use some of the extended configuration params ( eg. --enable-storeio="ufs, aufs" where double quotes are used ) then src2pkg breaks:

Found configure script -
Configuring sources using:
CFLAGS=-O2 -march=i486 -mtune=i686 ./configure --prefix=/opt/squid --enable-carp --enable-icmp --enable-delay-pools --enable-arp-acl --enable-htcp --enable-forw-via-db --enable-cache-digests --enable-ssl --with-openssl --enable-linux-netfilter --with-large-files --enable-large-cache-files --enable-auth="basic, digest" --enable-basic-auth-helpers="NCSA, getpwnam" --enable-digest-auth-helpers="password" --with-external-acl-helpers="unix, ip" --enable-storeio="ufs, aufs"
ERROR! Configuring sources has failed!
This usually happens because of missing libraries, or you
may need to pass extra options to configure using EXTRA_CONFIGS.
Sorry! No Dependency or Requirements information found.
src2pkg FAILURE in configure_source

If I remove any config params that use double quotes, then it is fine. I've tried the following syntax for the -e option:

-e='opt1 opt2 opt3'
and
"-e=opt1 opt2"

They both fail and I can't figure out how to proceed - perhaps this is an inherent issue with src2pkg? Any assistance appreciated.

Regards, Robby
 
Old 11-11-2008, 03:26 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
First, try using the -VV option along with those options so you can see the full output of configure -there may be some problem you are not seeing.

Try using single quotes instead of duble quotes:
-e='--enable-storeio='ufs, aufs''
To be honest, I doubt that will work, but it's worth trying. That option syntax is not found very frequently -what version of squid are you trying to build? If you tell me then I can try it out here and maybe fix that so it works if it doesn't work as above.

Also, try having src2pkg write a basic script for you, by using the -N option along with whatever else you are using. You may find that the options work when used from a script.
In the worst case, use src2pkg to create a script, then edit it by commenting out the 'configure_source' statement and replace it with:
Code:
cd $SRC_DIR
CFLAGS=-O2 -march=i486 -mtune=i686 ./configure --prefix=/opt/squid --enable-carp --enable-icmp --enable-delay-pools --enable-arp-acl --enable-htcp --enable-forw-via-db --enable-cache-digests --enable-ssl --with-openssl --enable-linux-netfilter --with-large-files --enable-large-cache-files --enable-auth="basic, digest" --enable-basic-auth-helpers="NCSA, getpwnam" --enable-digest-auth-helpers="password" --with-external-acl-helpers="unix, ip" --enable-storeio="ufs, aufs"
Thanks for reporting and let me know how it goes.
 
Old 11-11-2008, 05:43 AM   #3
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Original Poster
Rep: Reputation: 27
Thanks Gnashley for the tips:

1. the configure options work correctly for a normal configure
2. -VV shows the following:

Messages from configure:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: digest"
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: getpwnam"
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: ip"
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: aufs"
checking for a BSD-compatible install... /usr/libexec/src2pkg/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for digest"-gcc... no
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether gcc and cc understand -c and -o together... yes
checking build system type... Invalid configuration `digest"': machine `digest"' not recognized
configure: error: /bin/sh cfgaux/config.sub digest" failed
ERROR! Configuring sources has failed!
This usually happens because of missing libraries, or you
may need to pass extra options to configure using EXTRA_CONFIGS.
Sorry! No Dependency or Requirements information found.
src2pkg FAILURE in configure_source

You can see near the bottom that it has a problem with 'build system type' of digest and this is because the double quotes aren't being interpreted properly by src2pkg.

3. I've tried gen'ing a working script ( without any opts that use double quotes ) and then editing it but the problem still occurs ( see no. 5 )
4. squid version is 2.7S5 - the problem happens no matter the squid version
5. used working script, commented out extra_config + configure_src and add the 2 lines you mentioned - this works although I had to remove the "-march=i486 -mtune=i686" opts from the configure line.

Thanks for your help - will there be the possibility of using configure opts with quotes in the future in src2pkg?

Regards, Robby
 
Old 11-11-2008, 07:24 AM   #4
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
The problem is that passing quoting is hard to do. After thinking about it, you might be able to do that by escaping the quotes on the comand line:
-e="--enable-storeio=\"ufs, aufs\""
but I'm not sure that will work either.
The reason I ask about the version number was just so I could try and duplicate the same behaviour here.
I have done some(lots actually) work on this area of the src2pkg code before to make things go a little easier -it used to crap out when you used any sort of option like -e='--enable-storeio=ufs' that contained an '=' sign. That has been fixed, but your situation poses another problem.
I'll download the sources and work on it here to see if it can be fixed before next release.
Meanwhile, the workaround of commenting out offending instructions should serve you well -many times it easier or faster to do that than figure out how to get it to work with the available options.
I'll see if what can be done...
 
Old 11-12-2008, 01:26 AM   #5
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Original Poster
Rep: Reputation: 27
Thanks very much for assisting - I'll use this method for the moment if there are any unusual configure options. If you manage to find a resolution, would you mind posting it to the wiki/doc site pls?

Regards, Robby
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New src2pkg release available for download -Introducing the src2pkg WIKI gnashley Slackware 11 05-06-2008 12:09 PM
src2pkg question, what is "Reverting to Jail installation"? okos Linux - Newbie 1 02-10-2008 11:19 PM
Squid Installation help virgo Linux - Newbie 2 07-27-2004 03:24 AM
Squid Installation ham_madpk Linux - Networking 0 05-05-2001 08:58 AM
Squid Installation tina_gora Linux - Networking 0 05-03-2001 08:33 AM


All times are GMT -5. The time now is 06:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration