LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   src2pkg and OpenSRF (http://www.linuxquestions.org/questions/slackware-14/src2pkg-and-opensrf-4175452527/)

tronayne 03-03-2013 01:47 PM

src2pkg and OpenSRF
 
Trying to build OpenSRF with src2pkg.

Configure is supposed to be
Code:

./configure --prefix=/openils --sysconfdir=/openils/conf
However, I don't want it in the root, I want it in /usr/local so I did this:
Code:

src2pkg -A -C -CWD \
-p='/usr/local/openils' \
-e='--sysconfdir=/usr/local/openils/conf --libdir=/usr/local/lib64' \
opensrf-2.1.2.tar.gz

The bin directory gets created in /usr/local/openils/bin, the libraries go into /usr/local/lib64, but /usr/local/openils/conf does not get created.

Did I miss (or miss configure) something?

Thanks.

gnashley 03-04-2013 12:49 AM

Does /openils/conf get created when you configure with: --sysconfdir=/openils/conf

tronayne 03-04-2013 09:05 AM

Quote:

Originally Posted by gnashley (Post 4904060)
Does /openils/conf get created when you configure with: --sysconfdir=/openils/conf

Well, no -- generating and looking through the Makefile, it's defined but appears to never be used.

Nuts.

Thanks.

gnashley 03-04-2013 10:51 AM

If a normal make install doesn't create it then it is probably not used. Did you follow some build script/spec to see the --sysconfdir option being used?

tronayne 03-04-2013 11:15 AM

Yeah, it's used later (haven't gotten that far yet) and I just created the thing manually in any event just in case. I just initially thought I wasn't using src2pkg properly.

I'm going to mark this one solved, thanks.

gnashley 03-05-2013 01:10 AM

If you are using a opensrf.src2pkg script for the build? If so, simply place a line in there which creates the dir.
Code:

fake_install

mkdir -p $PKG_DIR/openils/conf

fix_pkg_perms


tronayne 03-05-2013 06:43 AM

Who'd-'a'-thunk it?

This one goes in my Important Notes on Stuff file -- thanks!


All times are GMT -5. The time now is 10:14 AM.