LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Spamassassin issue on slackware 9.1 (http://www.linuxquestions.org/questions/slackware-14/spamassassin-issue-on-slackware-9-1-a-4175453920/)

plisken 03-13-2013 10:26 AM

Spamassassin issue on slackware 9.1
 
I've been running with 9.1 forever and had an older version of Spamassassin running quite happly, though for some reason and I know not why I decided to upgrade it to current though I'm hitting issues, which I'll try and explain below in the hope that someone can offer some help.

I've updated through CPAN to 3.32 by using the following command:
Code:

cpan Mail::SpamAssassin
However, it wont run anymore, normally I use
Code:

spamd -c -d
This throws an error:
Code:

child process [29403] exited or timed out without signaling production of a PID file: exit 255 at /usr/bin/spamd line 2642.
sa-update wont run, showing:
Code:


Can't locate LWP/UserAgent.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.0/i486-linux /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/5.8.0/i486-linux /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl) at /usr/bin/sa-update line 81.
BEGIN failed--compilation aborted at /usr/bin/sa-update line 81.

done a bit of googling and thought about getting the LWP, tried:
Code:

perl -MCPAN -e 'install Bundle::LWP'
but this ended up telling me I needed Perl > 5.81 of which I have 5.8
So I guess part of my question is would getting a newer version work, would that through up more problems?

I'm wishing I have a "Rollback" button right now.

All help is appreciated as I sit here and watch my mailboxes fill up with offers of riches and body enhancements.

frankbell 03-14-2013 08:41 PM

You may be hard-pressed to find someone still running Slack 9.1 who can offer first-hand help. I think that version is almost a decade old; it was passe when I started with Linux in 2005.

If it were me and I wanted to stick with 9.1, I'd take a whirl at installing the version of PERL that SpamAssassin says it wants, after making the appropriate backups of my current PERL install.

plisken 03-15-2013 03:15 AM

thanks for that, I am planning on trying this.

My issue is that its too much of a step/gamble for me to upgrade distribution and/or hardware here, as this is a working machine, though I do know that in time, I will have to make the change.

Anyway, as my install of Perl was through pkgtool and I'll have to do a compile/install for the >5.81 version, any pointers of backing up current just in case. Or do I simply remove package and do a compile/install?

Thanks

plisken 03-18-2013 10:18 AM

Back working and for anyone interested, here is what I done.

I "borrowed" the perl 5.8.4 package from the Slackware 10.0 distribution and upgraded using:
Code:

upgradepkg old%new
then spent hours in Perl/CPAN hell

CPAN kept telling me that modules were fine/installed/complete, though things kept failing because of them.
Sometimes it would follow dependences, other times it wouldnt.
I basically went through the fails and installed each one but force with CPAN until eventually CPAN Mail::SpamAssassin worked.

Code:

spamassassin -V
SpamAssassin version 3.3.2
  running on Perl version 5.8.4



All times are GMT -5. The time now is 11:24 PM.