LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2005, 05:15 PM   #1
daspooky
LQ Newbie
 
Registered: Nov 2004
Posts: 23

Rep: Reputation: 15
Sound static since slack 10.1 (alsa 1.0.8)


Hello everyone,

I have a strange problem with my sound in slackware 10.1. I have been using slackware 10.0 for a few months, with the default kernel 2.4.26 it was i believe, and the default alsa drivers (1.0.5) and my sound was working fine (i also used an asoundrc file to get software mixing).

Since a few days i removed slack 10.0 and installed 10.1 from scratch. With these i use default kernel (2.4.29) and default alsa drivers 1.0.8. But now i get crackly sound. Especially noticable in the sounds of gaim and amsn. But also slightly while playing mp3's. While playing video's in mplayer the sound seems fien tho..

As a temporary solution i removed the 1.0.8 drivers and downloaded and compiled the 1.0.5 drivers in my slackware 10.1. The sound is fine now.
Anyone else experiencing this problem? I didn't have the courage to test other drivers between 1.0.5 and 1.0.8. My soundcard has a c-media 8738 chip, so alsa uses cmipci drivers.

Does anyone know what can be done to solve this? I also tried installing the latest 1.0.9rc1 alsa drivers, but the problem remains..

EDIT: the crackling only occurs after enabling software mixing using a .asoundrc file. When i don't use software mixing the sound is fine, but of course i then can't play 2 sounds at the same time..

EDIT 2: the crackling dissapears if in my .asoundrc file i put the rate at 22000 khz instead of 44100

Last edited by daspooky; 03-14-2005 at 04:58 AM.
 
Old 03-14-2005, 10:10 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
Did you try to put it to 48000 khz (the default on some cards) ?
 
Old 03-14-2005, 11:56 AM   #3
daspooky
LQ Newbie
 
Registered: Nov 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Yes i tried putting it on 48000 as i saw it solved some people's problem. But it doesn't help here.
I also played with the values for period_size and buffer_size, but that didn't help either.
 
Old 03-14-2005, 12:06 PM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
You may need optimize your sound card with setting the PCI latency level
see this link to set PCI latency for audio :
http://www-128.ibm.com/developerwork...ary/l-hw2.html
 
Old 03-14-2005, 05:58 PM   #5
Vald0r
LQ Newbie
 
Registered: Jan 2005
Location: St John's, Newfoundland
Distribution: Slackware 10
Posts: 10

Rep: Reputation: 0
Where is the .asoundrc file located in Slackware. Right now my sounds messed cause it can only play one thing at once. For instance if im in amsn.. then I play mp3's on XMMS my message sounds stop, Then finally when my songs over i get a million notifications that i missed.....
 
Old 03-14-2005, 06:07 PM   #6
daspooky
LQ Newbie
 
Registered: Nov 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Vald0r
Where is the .asoundrc file located in Slackware. Right now my sounds messed cause it can only play one thing at once. For instance if im in amsn.. then I play mp3's on XMMS my message sounds stop, Then finally when my songs over i get a million notifications that i missed.....
Actually there is no .asoundrc file by default in slackware, you'll have to make it yourself. It has to be placed in your /home/[username] directory, and the content of that file depends on your sound chip. You can find some configurations at following page, on the bottom part of the page:

http://gentoo-wiki.com/HOWTO_ALSA_sound_mixer_aka_dmix

What you're actually doing is making a software mixer (if i understand it myself ) and you have to tell your applications to use that mixer. For example, in xmms you make it use the alsa plugin, and then in the configuration of the alsa plugin you replace "default" by "dmixer" (dmixer being the name of the software mixer you made).

But take a look at the page i posted, it's very helpfull at configuring applications to use the alsa software mixer.
Good luck

Ohw and for my problem, changing the pci latency didn't make the crackling go away

Last edited by daspooky; 03-14-2005 at 06:08 PM.
 
Old 03-14-2005, 06:15 PM   #7
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
I would try to rm /etc/asound.state then run alsaconf to recreate this file.
I had success with that when sound did not work after a kernel compile
 
Old 03-15-2005, 06:44 AM   #8
daspooky
LQ Newbie
 
Registered: Nov 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by keefaz
I would try to rm /etc/asound.state then run alsaconf to recreate this file.
I had success with that when sound did not work after a kernel compile
That didn't help either I'm all out of options. Looks like i'm going to have to go back to alsa 1.0.5 again...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound in slack 10.0, just static! metcalfe Slackware 6 05-10-2005 01:18 PM
no sound quake 3 - slack 10(using alsa) spd_vhi Linux - Games 0 10-18-2004 12:54 AM
SLACK 10.0, ALSA and VIA8233a...no sound marekjs Slackware 6 10-04-2004 11:17 AM
SLACK 10.0, ALSA and VIA8233a...no sound marekjs Linux - Hardware 0 08-07-2004 04:09 PM
ALSA sound static Syncrm Linux - General 2 01-26-2002 07:36 PM


All times are GMT -5. The time now is 04:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration