LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-26-2003, 03:28 PM   #1
slurride
LQ Newbie
 
Registered: Feb 2003
Distribution: slackware 8.1
Posts: 11

Rep: Reputation: 0
Sound...so frustrating...


I have followed the instructions on: http://www.alsa-project.org/alsa-doc...module=via82xx

because this is the soundcard that I have. I rebooted, but alas, still no sound. I know there are posts about this all the time, but none of the previous posts helped me at all.

When I run lsmod I get the following output (among other things):

snd-via82xx 9484 0 (autoclean)

which would signify that the module is loaded.

When I run: modinfo soundcore it returns that I do in fact have soundcore installed, and according to the above url, if it returns that it is installed, I do not need to recompile the kernal. I just don't understand what else I have to do to get sound working...To test if it was working, I used xmms and a wav file, xmms and a mp3 file, and mplayer and a mpg file. Although no errors were returned by any of the programs, I did not recieve any sound through my speakers. And yes, my speakers are turned on and plugged in...

Thanks in advance...



EDIT:
I just realized that I do get an error with mplayer. In the middle of a movie, I will get the error: AO: [esd] esd_open_sound failed: Connection refused

Last edited by slurride; 02-26-2003 at 03:53 PM.
 
Old 02-26-2003, 04:13 PM   #2
rockdw
Member
 
Registered: Nov 2002
Location: Chicago, IL
Distribution: Gentoo, CentOS
Posts: 62

Rep: Reputation: 15
try changing XMMS to use the OSS driver instead of eSound (Options-> Preferences), maybe mucking around with different drives will result in something.

Also, What distribution are you using? Most of them have soundconfig utils that may help.
 
Old 02-26-2003, 05:01 PM   #3
slurride
LQ Newbie
 
Registered: Feb 2003
Distribution: slackware 8.1
Posts: 11

Original Poster
Rep: Reputation: 0
No avail

Changing those drivers didn't help...I am using slackware 8.1
 
Old 02-26-2003, 05:59 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
What's your permissions on /dev/dsp and /dev/mixer ? They should be read and writable.

Also, try opening up gmix or something to control your volume and make sure for some reason they aren't on mute or turned down.
 
Old 02-26-2003, 07:23 PM   #5
slurride
LQ Newbie
 
Registered: Feb 2003
Distribution: slackware 8.1
Posts: 11

Original Poster
Rep: Reputation: 0
The permissions were correct...the sound was turned down...thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound In SuSE, Frustrating f34th3r Linux - Hardware 5 07-14-2005 11:00 PM
Too frustrating Harnic Linux - Networking 6 09-04-2004 03:15 PM
this is getting frustrating thebutler4 Linux - Newbie 5 05-24-2004 06:59 PM
why linux is frustrating rosko Linux - Software 64 08-09-2003 03:03 PM
Frustrating PlanetNEO Linux - Networking 24 12-09-2002 03:56 PM


All times are GMT -5. The time now is 09:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration