LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-03-2010, 09:33 PM   #1
blacksky2
Member
 
Registered: Oct 2008
Location: bogota
Distribution: kubuntu/fedora
Posts: 42

Rep: Reputation: 15
Unhappy sound problems 64bits intel HDA azalia


i tried slackware64 a while ago and i managed to get the sound to work, it implied to edit a conf file, ive search for the answer again and, couldnt find it, ive tried alsaconf, alsa snapshot and, mobprobe.conf , no luck, its an HP pav* dv4-1212la

# lspci|grep Audio

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

$ uname -*
2.6.29.6 #3 SMP Mon Dec 7 15:01:06 CST 2009 x86_64 AMD Athlon(tm) X2 Dual-Core QL-62 AuthenticAMD GNU/Linux

it works fine with auriculars, but its rather anoying,
thanks in avance.

Last edited by blacksky2; 03-03-2010 at 09:37 PM.
 
Old 03-04-2010, 03:19 PM   #2
doomey
LQ Newbie
 
Registered: Nov 2009
Location: on orbit around the sun and around the center of the galaxy
Distribution: slackware64
Posts: 24

Rep: Reputation: 2
i have another craptop from hp, probook 4515s, it has an ITE (Sigmatel - STAC) codec (with the same integrated soundcard as yours) and i needed to install alsa-driver to make the speakers work.
i downloaded the driver from alsa's homepage, then src2pkg'ed it, then installed it.
i'm on slackware64 13.0 vanilla edition.
 
1 members found this post helpful.
Old 03-05-2010, 11:31 AM   #3
blacksky2
Member
 
Registered: Oct 2008
Location: bogota
Distribution: kubuntu/fedora
Posts: 42

Original Poster
Rep: Reputation: 15
havent tried that, lest see, thanks
 
Old 03-05-2010, 05:25 PM   #4
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
But it should work... Exactly same sound card on my laptop (HP Pavillion dv7) and it worked out of the box on Slackware64 13.0 and now on Gentoo.

Code:
#lspci | grep Audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
Please use stock Slackware alsa* packages and reconfigure with alsaconf. Then check with alsamixer volume levels and if any channel is muted (MM) - unmute it. In case it still doesn't work, post here your /etc/modprobe.d/alsa.conf.

Edit:

Also, when you set volume levels with alsamixer, don't forget to run alsactl store as root.

Last edited by kukibl; 03-05-2010 at 05:26 PM.
 
Old 03-06-2010, 09:47 PM   #5
blacksky2
Member
 
Registered: Oct 2008
Location: bogota
Distribution: kubuntu/fedora
Posts: 42

Original Poster
Rep: Reputation: 15
@kukibl i tried alsaconf and alsamixer unmutting, modprobe.d/alsa.conf, various models and nothing, the alsa driver sugested by doomey sends some message, on startup about alsactl, not working but is unabiable, on dmesg, sorry for any errors, right now i have no alsa.conf any sugestions on how to make/config, last time there where some great errors, that forced me reinstall, any new aproach is welcome
 
Old 03-06-2010, 10:05 PM   #6
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 50
It works fine for me with no modifications (Slackware 13 64-bit). This might be obvious, but is the sound muted in kmix? What happens if you do modprobe snd_hda_intel?
 
Old 03-08-2010, 11:03 AM   #7
blacksky2
Member
 
Registered: Oct 2008
Location: bogota
Distribution: kubuntu/fedora
Posts: 42

Original Poster
Rep: Reputation: 15
no it isnt, its the fist thing ive checked, nothing happens when i # modprobe snd_hda_intel but im going to reinstall the stock slackware package
 
Old 03-09-2010, 09:56 PM   #8
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 50
If modprobe doesn't return anything, that means your driver is loading fine. Odd that you had to tweak configuration files to get sound working the first time; that implies that you are doing something different. Are you trying to get sound through the default HP speakers?

Please post the output of "aplay -L", "aplay -l", and try running "mplayer /usr/share/sounds/k3b_success1.wav".

Last edited by vik; 03-10-2010 at 12:21 AM.
 
Old 03-27-2010, 01:46 PM   #9
blacksky2
Member
 
Registered: Oct 2008
Location: bogota
Distribution: kubuntu/fedora
Posts: 42

Original Poster
Rep: Reputation: 15
#first comand
default:CARD=SB
HDA ATI SB, STAC92xx Analog
Default Audio Device
front:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
Front speakers
surround40:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
HDA ATI SB, STAC92xx Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=HDMI
Default Audio Device
#second comand
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
#third comand
mplayer work but only on earphones
 
Old 03-27-2010, 02:43 PM   #10
botnet
Member
 
Registered: May 2009
Posts: 158

Rep: Reputation: 40
Code:
grep Codec /proc/asound/card0/codec#1
then find the corresponding section to that codec in: /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt

select one of the models that corresponds to your laptop, and add the following into /etc/modprobe.d/alsa-base.conf (create the file if it does not exist):

options snd-hda-intel model=$MODEL

replace $MODEL with the model you selected from HD-Audio-Models.txt that matches your laptop and is under the section for your codec

then modprobe -r snd_hda_intel ; modprobe snd_hda_intel


you might have to try more than one model before it works correctly
 
Old 03-29-2010, 07:57 AM   #11
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
The hda module is broken in 2.6.33.
You must take /usr/src/linux/sound/pci/hda/* from 2.6.32.x
 
Old 03-29-2010, 08:22 AM   #12
botnet
Member
 
Registered: May 2009
Posts: 158

Rep: Reputation: 40
the hda module is not broken in 2.6.33
 
Old 03-29-2010, 11:18 AM   #13
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Quote:
Originally Posted by botnet View Post
the hda module is not broken in 2.6.33
It is, on certain platforms like two of mine. Nforce 4 and MCP51 to be exact.
This regression was listed on kernel lists.
 
Old 03-29-2010, 11:14 PM   #14
blacksky2
Member
 
Registered: Oct 2008
Location: bogota
Distribution: kubuntu/fedora
Posts: 42

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by botnet View Post
Code:
grep Codec /proc/asound/card0/codec#1
then find the corresponding section to that codec in: /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt

select one of the models that corresponds to your laptop, and add the following into /etc/modprobe.d/alsa-base.conf (create the file if it does not exist):

options snd-hda-intel model=$MODEL

replace $MODEL with the model you selected from HD-Audio-Models.txt that matches your laptop and is under the section for your codec

then modprobe -r snd_hda_intel ; modprobe snd_hda_intel


you might have to try more than one model before it works correctly
result "Codec: LSI ID 1040" searched for it on the file couldnt find any thing like that
 
Old 03-30-2010, 12:04 AM   #15
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,399

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
maybe what alien bob's writes about debugging hda audio for his eeepc can help.

Code:
$ grep -i "hp dv" /usr/src/linux-2.6.29.6/Documentation/sound/alsa/HD-Audio-Models.txt
  hp-m4         HP dv laptops

Last edited by ponce; 03-30-2010 at 12:15 AM.
 
  


Reply

Tags
amd, athlon, azalia, hda, hp, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound with Fedora 10 on ATI Tech SBx00 Azalia (Intel HDA) linuxdawg Linux - Laptop and Netbook 5 06-07-2009 05:27 AM
Inconsistent sound functionality on reboot (SBx00 Azalia (Intel HDA)) ph73nt Suse/Novell 1 05-08-2009 02:32 PM
HDA intel Sound Card Sounds problems with intel sound card on Ubuntu zengingok Linux - Hardware 9 08-17-2007 10:52 AM
New laptop, no sound. Fedora Core 6, intel-hda-audio ("Azalia") BogusTrumper Linux - Hardware 3 04-17-2007 11:27 AM
problems in HDA Intel Sound Card in Ubuntu Dapper zengingok Linux - Hardware 2 01-19-2007 03:24 PM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration