LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-15-2017, 03:19 AM   #16
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2
Posts: 780

Original Poster
Rep: Reputation: 48

Sorry, somehow I do not manage the attachments, but here we go for the syslog:
http://text-share.com/view/0a1dfe8f
 
Old 07-15-2017, 03:38 AM   #17
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: KDE Neon (Wayland)
Posts: 5,224

Rep: Reputation: Disabled
ok thanks for that, ordinarily I would ask if you know what it means to do a snippet but I can see one error in syslog link at line 7474

but I will ignore it for the moment.

Instead re-look at doing alsamixer -c0 command pls.
arrow to channel mode

press either the up or the down arrows....you may have to press many times up and many times down
ideally they will eventually show a 6 channel

when you have it
press the escape key to exit alsamixer....do not exit the terminal

now run this command pls

Code:
sudo alsactl store -f /home/marto/mixer.levels
2) if you are on slackware is this now a systemd distro?

show the output to

Code:
ls -al /etc/rc.local
systemctl list-unit-files | grep rc.local
depending on your answer we may or may need to force a mixer level over reboot

but I want that 2 ch setting changed

3) without reboot do you now get surround sound
---only if so reboot and test again and report pls
 
Old 07-15-2017, 11:14 AM   #18
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,040

Rep: Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031Reputation: 2031
Quote:
Originally Posted by aus9 View Post
2) if you are on slackware is this now a systemd distro?
No, Slackware still uses a modified BSD/Sys-V init system. Both rc.alsa and rc.pulseaudio (found in /etc/rc.d/) should remain unexecutable for almost all situations.
 
Old 07-15-2017, 12:02 PM   #19
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: KDE Neon (Wayland)
Posts: 5,224

Rep: Reputation: Disabled
thanks bassmadrigal

that means we can just use /etc/rc.local to restore mixer levels once OP replies to say if 6 ch became avaiable
 
Old 07-15-2017, 01:07 PM   #20
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 2,612

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
If the OP stored his alsa mixer state in a different file...
Code:
sudo alsactl store -f /var/lib/alsa/asound.state
...then all the OP must do is to run...
Code:
chmod +x /etc/rc.d/rc.alsa
...and the standard Slackware init system will restore the mixer state.
 
1 members found this post helpful.
Old 07-16-2017, 02:28 AM   #21
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2
Posts: 780

Original Poster
Rep: Reputation: 48
Hello,
thank you all for your responsiveness.
Here is a snapshot of the alsamixer settings. Yes, I got the 6 ch mode:
http://imgur.com/a/KPAIq
I ran:
Code:
alsactl store -f /home/marto/mixer.levels
This is the output of:
Code:
root@marto:~# ls -al /etc/rc.d/rc.local
-rwxr-xr-x 1 root root 422 Dec 26  2016 /etc/rc.d/rc.local*
systemctl is not available on Slackware.
Unfortunately, still only Front Left and Front Right are recognised:
http://imgur.com/a/ZkfPy
After reboot, the 6 ch mode was again back to to 2 ch. In any case, no surround.
 
Old 07-16-2017, 03:36 AM   #22
elcore
Member
 
Registered: Sep 2014
Distribution: Slackware
Posts: 311

Rep: Reputation: Disabled
I've found that once alsamixer has been configured, one can easily workaround all this by writing:
Code:
# in /etc/rc.d/rc.local
alsactl restore
And additionally, if configuration is to be saved on shutdown:
Code:
# in /etc/rc.d/rc.local_shutdown
alsactl store
 
Old 07-16-2017, 03:50 AM   #23
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: KDE Neon (Wayland)
Posts: 5,224

Rep: Reputation: Disabled
ok reboot and back to 2 ch is to be expected.....the main thing is alsa now sees 6 ch

we move to the next bit which is to restore your mixer levels over reboot

DO NOT ATTEMPT TO RESTORE 6 CHANNEL, if you read this post and have already done so, do a full reboot

1) open a terminal as local user and run these commands
Code:
/usr/sbin/alsactl restore -f /home/marto/mixer.levels
alsamixer -c0
if you had no errors for first command AND
if you now see 6 ch in alsamixer
----then create a reboot command

2) open /etc/rc.local with root powers

Code:
sudo kwrite /etc/rc.local
copy and paste next line so its above the exit 0 line so the last 2 lines read as

Quote:
/usr/sbin/alsactl restore -f /home/marto/mixer.levels
exit 0
save the file and then do a full reboot

on reboot check if 6 ch is showing in alsamixer

and report

then we will work out what happened to pulseaudio
 
Old 07-16-2017, 03:57 AM   #24
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: KDE Neon (Wayland)
Posts: 5,224

Rep: Reputation: Disabled
@ elcore

OP has little English so I prefer not to distract him with too much information or alternatives all at once.

which is why I split the 6 ch config as a separate post than the persistence over reboot config

Last edited by aus9; 07-16-2017 at 03:58 AM.
 
Old 07-16-2017, 06:15 AM   #25
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2
Posts: 780

Original Poster
Rep: Reputation: 48
Hello,
I rebooted, the alsa settings were correct, and the KDE settings showed and successfully tested all the speakers and the subwoofer.
The key thing was that I again had to remove the folders ~/.config/pulse and /tmp/pulse-*. After restart everything worked.
Thank you all very much for your help, especially many thanks to aus9!

The only problem now is the "dual stereo switch" on the SONY control device.
When it is "off", all speakers and the subwoofer are successfully tested in the KDE Audio and Video Settings -> Audio Hardware Setup (produce sound when I click on them here http://imgur.com/a/8rPwr).
However, when I set the dual stereo switch to "on", Front Left and Front Right are successfully tested in the KDE Audio and video Settings -> Audio Hardware setup, whereas all the rest are silent; at the same time during real playback I checked that all speakers and the subwoofer do produce sound. The sound quality is definitely better than when the dual stereo switch is set to "off". I am not sure whether that is OK, probably this is how things should be. What do you think?



Best regards,
Martin
 
Old 07-16-2017, 07:27 AM   #26
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: KDE Neon (Wayland)
Posts: 5,224

Rep: Reputation: Disabled
Ok we will now find why pulseaudio (=PA) is not correct.

first we need to discover if you have true local configs or are using system wide configs. Yes I know you deleted some local files but when surround sound is working report the result of these commands....copy and paste into a terminal

Code:
pulseaudio -vvv

ls -al .config/pulse
ls -al /etc/pulse/
2) when surround sound is working go back into pavucontrol (the volume control manager) go to last tab
pulldown the options for your analog card.....do you now have surround sound options like this
http://imgur.com/a/HgKAo
 
Old 07-16-2017, 07:52 AM   #27
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2
Posts: 780

Original Poster
Rep: Reputation: 48
Hello,
the follwoing is the output of the command "pulseaudio -vvv" run as a regular user:
Code:
bash-4.3$ pulseaudio -vvv
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
I: [pulseaudio] core-util.c: Failed to acquire high-priority scheduling: No such file or directory
I: [pulseaudio] main.c: This is PulseAudio 9.0-rebootstrapped
D: [pulseaudio] main.c: Compilation host: x86_64-slackware-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -O2 -fPIC -g -O0 -Wall -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 4.4.75 #1 SMP Fri Jun 30 02:44:10 CDT 2017
D: [pulseaudio] main.c: Found 2 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no                                                                                                                                                                                   
D: [pulseaudio] main.c: Running in valgrind mode: no                                                                                                                                                                                         
D: [pulseaudio] main.c: Running in VM: no                                                                                                                                                                                                    
D: [pulseaudio] main.c: Optimized build: no                                                                                                                                                                                                  
D: [pulseaudio] main.c: All asserts enabled.                                                                                                                                                                                                 
I: [pulseaudio] main.c: Machine ID is 07c5ad19fe5aeee51d40cc09585bf5bb.                                                                                                                                                                      
I: [pulseaudio] main.c: Using runtime directory /home/marto/.config/pulse/07c5ad19fe5aeee51d40cc09585bf5bb-runtime.                                                                                                                          
I: [pulseaudio] main.c: Using state directory /home/marto/.config/pulse.                                                                                                                                                                     
I: [pulseaudio] main.c: Using modules directory /usr/lib64/pulse-9.0/modules.                                                                                                                                                                
I: [pulseaudio] main.c: Running in system mode: no                                                                                                                                                                                           
E: [pulseaudio] pid.c: Daemon already running.                                                                                                                                                                                               
E: [pulseaudio] main.c: pa_pid_file_create() failed.
and the output of the same command run as root is attached.
Now for the rest of the commands:
Code:
 ls -al .config/pulse
total 92
drwx------  2 marto users    64 Jul 16 13:46 .
drwxr-xr-x 15 marto users  4096 Jul 16 14:00 ..
-rw-r--r--  1 marto users 16384 Jul 16 14:25 07c5ad19fe5aeee51d40cc09585bf5bb-card-database.tdb
-rw-r--r--  1 marto users    48 Jul 16 14:25 07c5ad19fe5aeee51d40cc09585bf5bb-default-sink
-rw-r--r--  1 marto users    42 Jul 16 14:25 07c5ad19fe5aeee51d40cc09585bf5bb-default-source
-rw-r--r--  1 marto users 24576 Jul 16 13:46 07c5ad19fe5aeee51d40cc09585bf5bb-device-manager.tdb
-rw-r--r--  1 marto users 12288 Jul 16 15:41 07c5ad19fe5aeee51d40cc09585bf5bb-device-volumes.tdb
lrwxrwxrwx  1 marto users    23 Jul 16 13:18 07c5ad19fe5aeee51d40cc09585bf5bb-runtime -> /tmp/pulse-XDwuPVOdiuMp
-rw-r--r--  1 marto users 16384 Jul 16 14:48 07c5ad19fe5aeee51d40cc09585bf5bb-stream-volumes.tdb
-rw-------  1 marto users   256 Jul 16 13:46 cookie
and
Code:
bash-4.3$ ls -al /etc/pulse/
total 44
drwxr-xr-x   2 root root  4096 Jul 15 08:58 .
drwxr-xr-x 102 root root 12288 Jul 16 13:46 ..
-rw-r--r--   1 root root  1032 Jul 13 13:24 .daemon.conf.un~
-rw-r--r--   1 root root  1230 Jun 22  2016 client.conf
-rw-r--r--   1 root root  2283 Jul 13 13:24 daemon.conf
-rw-r--r--   1 root root  2284 Jun 22  2016 daemon.conf~
-rw-r--r--   1 root root  4892 Jun 22  2016 default.pa
-rw-r--r--   1 root root  2046 Jun 22  2016 system.pa
I want to make all the settings system wide and that is how I have worked so far.
The pavucontrol configuration window now looks like this:

http://imgur.com/a/pb2KP
Attached Files
File Type: txt PA.txt (241.5 KB, 2 views)
 
Old 07-16-2017, 08:54 AM   #28
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: KDE Neon (Wayland)
Posts: 5,224

Rep: Reputation: Disabled
this is going to be slow OK

first running those commands with system wide config on my system (ubuntu based) I can compare the outputs

yours deleting irrelevant stuff
#####
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
I: [pulseaudio] core-util.c: Failed to acquire high-priority scheduling: No such file or directory
D: [pulseaudio] main.c: Optimized build: no

E: [pulseaudio] pid.c: Daemon already running.

mine
#####
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
D: [pulseaudio] main.c: Optimized build: yes


^^^^^ what that means is your maintainer of PA has either missing dependency to allow PA to get more urgent priority of resources or the compile was not optimized.

Optimised build generally means that useless junk has been compiled out. It can make the executable faster.

If you experience no lag in playing sound or video we can ignore it for now.


daemon already running means we don't need to check if Slackware init system has PA active for run level 4 (the GUI boot up you have)


2) running system wide is acceptable.....don't run it as root though

3) I can see you have amended files in /etc/pulse/ and you have some junk there

clean out junk first...copy and paste....you know how

Code:
sudo su
cd /etc/pulse
rm -rf .daemon* daemon.conf~
4) I will need you to upload each remaining file in /etc/pulse but I have unpacked the slackware package and am going to link to the "raw" files so if you make a mistake
we can get you to just download the raw files and replace the "bad" ones.


https://www.dropbox.com/s/izggeergj0....conf.new?dl=0
https://www.dropbox.com/s/7qzwaiij8u....conf.new?dl=0
https://www.dropbox.com/s/vramqot9sw...lt.pa.new?dl=0
https://www.dropbox.com/s/k7n23s1kvi...em.pa.new?dl=0

The forum truncates the full file name of my downloads ....no worries....they are
client.conf.new
daemon.conf.new
default.pa.new
system.pa.new

any file that you might need when you download it....you will rename it drop the .new.....but it is convenient to have .new so you can compare them to yours
 
Old 07-16-2017, 09:37 AM   #29
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2
Posts: 780

Original Poster
Rep: Reputation: 48
Hello, aus9,
I cleaned /etc/pulse.
The files you shared are identical to mine. The only difference is:
Code:
bash-4.3$ diff daemon.conf daemon.conf.new 
78c78
<  default-sample-channels = 6
---
> ; default-sample-channels = 2
 
Old 07-16-2017, 10:26 AM   #30
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: KDE Neon (Wayland)
Posts: 5,224

Rep: Reputation: Disabled
Ok thanks for that....going to bed

will have to look at my own logs to see which command will tell me why you are having to delete some files

its a puzzle but we can eliminate the PA config files but not sure we can eliminate PA.

2) Have you tried to run your sound without PA running?
do you have surround sound.....you should do according to alsamixer?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problems (alsaconf cannot find sound modules.) vmlinuz.gz Linux - Newbie 8 11-12-2008 03:36 AM
Sound problems in Slackware 11 with Sweex sound card RicardoB Linux - Hardware 0 04-30-2007 01:34 PM
Sound problems with ubuntu 4.1 and a realtek sound card linux-novice Linux - Newbie 1 02-18-2006 11:44 PM
Sound Problems: CD works, no system/mp3/video sound tabnaka SUSE / openSUSE 5 01-13-2006 12:33 PM
Problems getting sound to play under Mandrake w/2 sound cards HGeneAnthony Linux - Hardware 1 07-02-2004 02:19 PM


All times are GMT -5. The time now is 06:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration