LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Sound problem with Slackware 11.0 (http://www.linuxquestions.org/questions/slackware-14/sound-problem-with-slackware-11-0-a-491602/)

theweehours 10-11-2006 07:22 PM

Sound problem with Slackware 11.0
 
I would appreciate a little advice on getting my sound card working with my new Slack 11 installation. It was a clean install with kernel 2.4.33.3, and I am trying to use my C-Media 8738/C3DX card. My machine also has onboard sound which seems to be the problem. Here is the output of lsmod | grep > snd:
snd-seq-oss 23104 0 (unused)
snd-seq-midi-event 3208 0 [snd-seq-oss]
snd-seq 33552 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 28928 0
snd-mixer-oss 11928 0 [snd-pcm-oss]
snd-cmipci 18208 0
snd-opl3-lib 5636 0 [snd-cmipci]
snd-hwdep 4156 0 [snd-opl3-lib]
snd-via82xx 13580 0
gameport 1388 0 [snd-cmipci snd-via82xx]
snd-ac97-codec 68160 0 [snd-via82xx]
snd-pcm 52804 0 [snd-pcm-oss snd-cmipci snd-via82xx snd-ac97-codec]
snd-timer 13168 0 [snd-seq snd-opl3-lib snd-pcm]
snd-mpu401-uart 3120 0 [snd-cmipci snd-via82xx]
snd-rawmidi 12224 0 [snd-mpu401-uart]
snd-seq-device 3716 0 [snd-seq-oss snd-seq snd-opl3-lib snd-rawmidi]
snd 34304 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-cmipci snd-opl3-lib snd-hwdep snd-via82xx snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3300 11 [snd]
snd-page-alloc 4980 0 [snd-seq-oss snd-seq snd-mixer-oss snd-hwdep snd-via82xx snd-pcm snd-timer snd-rawmidi snd-seq-device snd]

alsaconf configures the c-media card but sees the onboard via chip. alsamixer sets volumes only for the via chip. Any ideas?

thanks,
theweehours

davidwillis 10-11-2006 09:04 PM

When you boot up, see if you get an error? I have the same card, and I get an error saying I need to load the alsa module, or something like that. I have not got it fixed yet, because I am working on other things first. But you may not have the modules loaded.

dive 10-11-2006 09:32 PM

It might be easiest to disable the onboard sound via cmos setup. Otherwise you will need to specify whcih card is which card number. I do this because I currently have 2 sound cards and made a /etc/modprobe.d/sound file for this purpose:

Code:

alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
alias snd-card-1 snd-ens1371
alias sound-slot-1 snd-ens1371
options snd-emu10k1 index=0
options snd-ens1371 index=1


theweehours 10-11-2006 11:00 PM

many thanks
 
Disabling the on-board sound in BIOS worked like a charm. The output is still a bit quirky, but I'll check the book on the card for that. Thanks!


All times are GMT -5. The time now is 12:25 PM.