LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2002, 12:00 PM   #1
sqn
Member
 
Registered: Apr 2002
Distribution: Ubuntu, Arch, freeBSD, Slackware
Posts: 210

Rep: Reputation: 30
sound in slack7.1 2.2.16


I have some probplems regarding the sound in my linux box...
i've use modprobe from rc.d to install my sound card, i use it since slack 7.1 fisrs apear. the problem started when i've installed a network card, and the soundcard had change it;s irq, dma, etc...
i've changed the irqs and dms to the new values, and the card was installed.
at lsmod the modules apear, at booting it says sound card ok, but i can't hear any sound from the speakers...
pls help me...
 
Old 04-30-2002, 03:14 PM   #2
kill-hup
Member
 
Registered: Aug 2000
Location: NY - USA
Distribution: Slackware
Posts: 109

Rep: Reputation: 15
Mixer volume?

If you are certain the kernel picked up the sound card (and the speakers are powered on and connected properly ), you might want to try and check the mixer volume.

The device is usually /dev/mixer, and sometimes the volume can be set too low. You could also try 'play -v 10 <soundfile>' to test playing a sound at a higher volume.

Hope this helps... If not, does "cat /dev/sndstat" do anything for you?
 
Old 05-02-2002, 12:51 PM   #3
vfs
Member
 
Registered: Apr 2002
Location: Brazil
Distribution: Slackware
Posts: 184

Rep: Reputation: 30
Talking

Uh, looks like we're talking about PnPray?

Try this:

pnpdump --config > /etc/isapnp.conf

isapnp /etc/isapnp.conf

I'm assuming you have ISA cards. Anyway, since you're already lost, I'm not pulling you too out of the track ;-)

The commands above should return you some tips about addresses and stuff.

Edit /etc/rc.d/rc.modules and put the correct lines to load the modules. Take a look at /usr/src/Documentation (must install /slakware/k1/(forgot the name -- the kernel source .tgz). IT contains directives to modprobe.

HTH

vfs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
ALSA MIDI: Sound fonts for NVIDIA/NForce Soundstorm on-board sound vharishankar Linux - Hardware 6 09-04-2007 12:37 PM
No Sound : request_module: failed /sbin/modprobe -- sound-slot-0. error = 256 Mebuh Linux - General 0 01-26-2004 07:51 AM
2nd nic on a Slack7 system... herbleong Slackware 6 10-25-2003 09:21 PM
Slack7.1- (.bash_profile/.bashrc)? shmoo28 Linux - Newbie 4 10-28-2001 04:08 AM


All times are GMT -5. The time now is 02:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration