LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2004, 03:07 PM   #1
slackwarefan
Member
 
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Rep: Reputation: 30
Sound in KDE 3.2 ALSA, don't know what happened.


I upgraded KDE to 3.2 and the kernel to 2.6.4 only to find that I got a "CPU Overload - Aborting" error. I switched the sound hardware to alsa from autodetect and now I got no error but still no system sounds, however xmms and xine as well as other programs worked fine, so I told KDE to use an external player, this was supposed to be temporary. I was told that installing alsa drivers, oss, utils, and libs would fix this, so i installed them. It appears that they installed properly, but now I cannot uncheck "Use external player" in the sound options. How can I switch back to using the default player. I have already tried make uninstalling alsa, but that did not help.

-- Thanks in advance
 
Old 03-20-2004, 08:48 PM   #2
moonloader
Member
 
Registered: Nov 2003
Location: linuxquestions.org
Distribution: Linux and BSD
Posts: 229

Rep: Reputation: 30
command in konsole as root (alsconf)and follow the instractions.did not help then uninstall alsa and related packages then reinstall all,don't forget what you uninstall,because you will reinstall,tehn reboot your computer and in konsole command again (alsaconf)follow instarctions.
good luck
 
Old 03-20-2004, 09:12 PM   #3
tmorton
Member
 
Registered: Jan 2003
Location: In front of my computer in Oregon, USA
Distribution: Slackware
Posts: 198

Rep: Reputation: 31
Hi,
I've been having the problem to. Sound works for me when I'm root, what about you? So, I'm assuming this is a permission error.

One workaround that I found was to compile ALSA with OSS Emulation support, then tell KDE to use OSS.
HTH, Taj
 
Old 03-20-2004, 09:31 PM   #4
slackwarefan
Member
 
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Original Poster
Rep: Reputation: 30
Doesnt work as root.
 
Old 03-20-2004, 09:44 PM   #5
tmorton
Member
 
Registered: Jan 2003
Location: In front of my computer in Oregon, USA
Distribution: Slackware
Posts: 198

Rep: Reputation: 31
Did you try telling KDE to use OSS?
--Taj
 
Old 03-21-2004, 03:25 PM   #6
slackwarefan
Member
 
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Original Poster
Rep: Reputation: 30
Yeah, tried that, didnt work
 
Old 03-22-2004, 04:40 PM   #7
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
I thought I had this problem but after some investigation I discovered that I can play CDs, MP3s, and sound files(.wav) in applications but I have no system sounds in KDE 3.2.1.

Am I missing something? Which, incidentally, is my normal state of mind.

Kent
 
Old 03-22-2004, 09:03 PM   #8
nirva
Member
 
Registered: Mar 2003
Location: RI
Distribution: Slack 9.1
Posts: 35

Rep: Reputation: 15
I had this same problem, just fixed it today. In my case it had to do with aRts...probably because I had two different versions of it running. I uninstalled the previous versions and installed the latest build and then KDE loaded extremely fast and without errors. I don't know if this will really help in any way, but that's just what worked for me.
 
Old 03-24-2004, 10:45 AM   #9
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
Quote:
Originally posted by tmorton
Did you try telling KDE to use OSS?
--Taj

Where did you select this option? I've looked all over KDE controls and can't find any reference to OSS.

Kent
 
Old 03-24-2004, 11:52 AM   #10
tmorton
Member
 
Registered: Jan 2003
Location: In front of my computer in Oregon, USA
Distribution: Slackware
Posts: 198

Rep: Reputation: 31
Hi,
Quote:
Where did you select this option? I've looked all over KDE controls and can't find any reference to OSS.
It's in the Control Center.
K>Settings>Control Center.

Select Sound & Multimedia. Select Sound System from the submenu.
Select the Hardware Tab.

Select Open Sound System from the Audio Device dropdown.
Hit Apply.

--Taj
 
Old 03-24-2004, 12:02 PM   #11
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
Quote:
Originally posted by tmorton
Hi,


It's in the Control Center.
K>Settings>Control Center.

Select Sound & Multimedia. Select Sound System from the submenu.
Select the Hardware Tab.

Select Open Sound System from the Audio Device dropdown.
Hit Apply.

--Taj

hmmm...I only have "Autodetect" in that pulldown.
 
Old 03-26-2004, 10:13 PM   #12
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
After many hours of research and trail-sniffing I finally found what was causing my system sounds problem. Artsshell was wanting libesd.so.0 which is part of the esound package. I suspect esound had been pillaged when I uninstalled Dropline Gnome (see this thread http://www.linuxquestions.org/questi...hreadid=112865). Once I realized that esound was on the Slackware CD, I reinstalled it and now the system sound works normally. However, now xmms doesn't work. Back to the drawing board.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slak10 alsa and what happened to /dev/dsp? spooge Slackware 4 04-19-2005 08:57 PM
Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE. damien Linux - Software 7 02-02-2005 01:05 AM
No sound after KDE 3.2 upgrade (and not using alsa) thegeekster Linux - Software 9 07-31-2004 12:51 PM
S.10 + K 2.6.7 -> SOUND: ALSA OK, KDE ARTs - NO GO. Where to look? suslik Slackware 2 07-10-2004 01:15 PM
Cannot select ALSA sound in kde paulicat Slackware 1 09-30-2003 02:18 PM


All times are GMT -5. The time now is 07:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration