LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-03-2012, 02:52 AM   #1
emgee_1
Member
 
Registered: Aug 2009
Location: Nijmegen, The Netherlands
Distribution: Slackware 14
Posts: 39

Rep: Reputation: 6
sound in flash not working for me Slackware 64 14.0


Dear slackers,

Sound in flash is not working for me.
I installed full slackware64 14.0
I installed flash plugin from SBo git current.

Sound in kde phonon (test) works.
Ted videos in chromium (installed using Slackwiki) start playing with sound but stop after some 10 -20 seconds.

I did a # alsactl init
All flash video have no sound
A cd plays ok with sound

Using xfce and installed mixer plugin showing 3 cards(?)
Code:
lsmod | grep snd  
snd_seq_dummy           1455  0 
snd_seq_oss            29048  0 
snd_seq_midi_event      5620  1 snd_seq_oss
snd_seq                51265  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          5228  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            39183  1 
snd_mixer_oss          15404  4 snd_pcm_oss
snd_hda_codec_realtek   195474  1 
snd_hda_codec_hdmi     24057  1 
snd_hda_intel          23267  10 
snd_hda_codec          81925  3 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_realtek
snd_hwdep               6324  1 snd_hda_codec
snd_pcm                72864  4 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_pcm_oss
snd_page_alloc          7081  2 snd_pcm,snd_hda_intel
snd_timer              18798  2 snd_pcm,snd_seq
snd                    57796  24 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore               5474  5 snd
#alsacntl init

Code:
alsactl init
Found hardware: "HDA-Intel" "ATI R6xx HDMI" "HDA:1002aa01,00aa0100,00100200" "0x1025" "0x059f"
Hardware is initialized using a generic method
Any idea I could try otherwise?

I made also a file in /etc/modprobe.d named sound.conf containing
Code:
options snd-hda-intel model=auto
to no avail.

Any ideas are welcome!

Thank you

Marcel Geijsberts

Last edited by emgee_1; 10-05-2012 at 06:31 AM. Reason: solved
 
Old 10-03-2012, 04:05 AM   #2
fsauer
Member
 
Registered: Jul 2012
Posts: 38

Rep: Reputation: Disabled
Check device and subdevice

I had a similar problem. Run "aplay -l" which should give you a list of available devices and subdevices.

I found a file /etc/asound.conf (of which I do not know who created it...) and there the entries defaults.pcm.ctl.card and defaults.pcm.card are followed by defaults.pcm.device and defaults.pcm.subdevice. Checking these with the output of aplay -l showed that the device and subdevice numbers were not the correct ones, which leads to a failure of "pure alsa". (I hope to remember these thing correctly. In the present machine which is always updated to current, I have no /etc/asound.conf. So, this is from memory...)

Phonon in KDE chooses the devices directly, and therefore does not rely on that mechanism. Which is why the KDE apps work alright.

Obviously, this is just a possibility. But in the fresh install we had exactly these problems...

Good luck
Franz
 
Old 10-03-2012, 05:45 AM   #3
grave_violin
LQ Newbie
 
Registered: Jan 2012
Posts: 10

Rep: Reputation: Disabled
This is what I experienced with 13.37 and found a solution, I do not remember where

Create a text file .asoundrc in your account and copy-paste following in it:

pcm.!default {
type hw
card 0
}

ctl.!default {
type hw
card 0
}
 
Old 10-03-2012, 06:12 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,435

Rep: Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867
If it's a laptop, can it be the speakers don't work, but if you plug in a pair of headphones those work?

I'm saying this because there's a kernel bug around that mute internal speakers that seems fixed in yesterday kernel updates...
And I say "seems" because I'm affected too by this bug but I've not yet time to try the new kernel releases.

EDIT: just FYI, I have the speakers muted on this laptop also with the latest kernels
the bug is described here

Last edited by ponce; 10-03-2012 at 01:14 PM.
 
Old 10-04-2012, 03:29 AM   #5
emgee_1
Member
 
Registered: Aug 2009
Location: Nijmegen, The Netherlands
Distribution: Slackware 14
Posts: 39

Original Poster
Rep: Reputation: 6
@ponce : It is indeed a laptop but your suggestions did not change a thing unfortunately
@grave_violin : I created the file .asoundrc in my home dir /home/mg but no sound either unfortunately
@ fsauer : your suggestion looks promising but I do no know how to exactly to implement it:

aplay -l gives
Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
I did not have an asound.conf in /etc

I found :
Code:
bash-4.2# cd /etc
bash-4.2# ls -R | grep asound
asound.state
which contains
Code:
state.Generic {
    control.1 {
        iface MIXER
        name 'IEC958 Playback Con Mask'
        value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
        comment {
            access read
            type IEC958
            count 1
        }
    }
    control.2 {
        iface MIXER
        name 'IEC958 Playback Pro Mask'
        value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
        comment {
            access read
            type IEC958
            count 1
        }
    }
    control.3 {
        iface MIXER
        name 'IEC958 Playback Default'
        value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
        comment {
            access 'read write'
            type IEC958
            count 1
        }
    }
    control.4 {
        iface MIXER
        name 'IEC958 Playback Switch'
        value false
        comment {
            access 'read write'
            type BOOLEAN
            count 1
        }
    }
    control.5 {
        iface PCM
        device 3
        name ELD
        value ''
        comment {
            access read
            type BYTES
            count 0
        }
    }
}
state.Generic_1 {
    control.1 {
        iface MIXER
        name 'Headphone Playback Volume'
        value.0 87
        value.1 87
        comment {
            access 'read write'
            type INTEGER
            count 2
            range '0 - 87'
            dbmin -6525
            dbmax 0
            dbvalue.0 0
            dbvalue.1 0
        }
    }
    control.2 {
        iface MIXER
        name 'Headphone Playback Switch'
        value.0 true
        value.1 true
        comment {
            access 'read write'
            type BOOLEAN
            count 2
        }
    }
    control.3 {
        iface MIXER
        name 'Speaker Playback Volume'
        value.0 87
        value.1 87
        comment {
            access 'read write'
            type INTEGER
            count 2
            range '0 - 87'
            dbmin -6525
            dbmax 0
            dbvalue.0 0
            dbvalue.1 0
        }
    }
    control.4 {
        iface MIXER
        name 'Speaker Playback Switch'
        value.0 true
        value.1 true
        comment {
            access 'read write'
            type BOOLEAN
            count 2
        }
    }
    control.5 {
        iface MIXER
        name 'Mic Playback Volume'
        value.0 0
        value.1 0
        comment {
            access 'read write'
            type INTEGER
            count 2
            range '0 - 31'
            dbmin -3450
            dbmax 1200
            dbvalue.0 -3450
            dbvalue.1 -3450
        }
    }
    control.6 {
        iface MIXER
        name 'Mic Playback Switch'
        value.0 false
        value.1 false
        comment {
            access 'read write'
            type BOOLEAN
            count 2
        }
    }
    control.7 {
        iface MIXER
        name 'Internal Mic Playback Volume'
        value.0 0
        value.1 0
        comment {
            access 'read write'
            type INTEGER
            count 2
            range '0 - 31'
            dbmin -3450
            dbmax 1200
            dbvalue.0 -3450
            dbvalue.1 -3450
        }
    }
    control.8 {
        iface MIXER
        name 'Internal Mic Playback Switch'
        value.0 false
        value.1 false
        comment {
            access 'read write'
            type BOOLEAN
            count 2
        }
    }
    control.9 {
        iface MIXER
        name 'Auto-Mute Mode'
        value Enabled
        comment {
            access 'read write'
            type ENUMERATED
            count 1
            item.0 Disabled
            item.1 Enabled
        }
    }
    control.10 {
        iface MIXER
        name 'Mic Boost Volume'
        value.0 0
        value.1 0
        comment {
            access 'read write'
            type INTEGER
            count 2
            range '0 - 3'
            dbmin 0
            dbmax 3600
            dbvalue.0 0
            dbvalue.1 0
        }
    }
    control.11 {
        iface MIXER
        name 'Internal Mic Boost Volume'
        value.0 0
        value.1 0
        comment {
            access 'read write'
            type INTEGER
            count 2
            range '0 - 3'
            dbmin 0
            dbmax 3600
            dbvalue.0 0
            dbvalue.1 0
        }
    }
    control.12 {
        iface MIXER
        name 'Capture Switch'
        value.0 true
        value.1 true
        comment {
            access 'read write'
            type BOOLEAN
            count 2
        }
    }
    control.13 {
        iface MIXER
        name 'Capture Volume'
        value.0 19
        value.1 19
        comment {
            access 'read write'
            type INTEGER
            count 2
            range '0 - 31'
            dbmin -1650
            dbmax 3000
            dbvalue.0 1200
            dbvalue.1 1200
        }
    }
    control.14 {
        iface MIXER
        name 'Master Playback Volume'
        value 60
        comment {
            access 'read write'
            type INTEGER
            count 1
            range '0 - 87'
            dbmin -6525
            dbmax 0
            dbvalue.0 -2025
        }
    }
    control.15 {
        iface MIXER
        name 'Master Playback Switch'
        value true
        comment {
            access 'read write'
            type BOOLEAN
            count 1
        }
    }
}
This looks to me the settings of my mixer widget in xfce4
I guess I have to create some config file that gives the correct order of the devices but do not yet know how. I guess that it has to do with udev and the way first sound devices are recognized.

Maybe I should try another kernel?
I know that sound worked under sabayon 9 on this laptop which I exchanged gladly for slackware 14.

Any ideas suggestions are much appreciated.

Marcel
 
Old 10-05-2012, 03:40 AM   #6
fsauer
Member
 
Registered: Jul 2012
Posts: 38

Rep: Reputation: Disabled
sound in flash not working....

I found out that my son had created the /etc/asound.conf before I used it. This explains why I didn't know where it came from.

He created it after reading:
https://wiki.archlinux.org/index.php...ult_sound_card

Maybe the .asoundrc (see post by grave_violin) could be useful for you. As your card 0 is the hdmi one, you should modify the .asoundrc accordingly ("card 1" instead of "card 0").
As you use the default device 0 anyways, this should be ok.

If you want to use the HDMI sound, you have to configure card 0, device 3 subdevice 0, which is exactly what we had to do

Good luck!

Franz
 
1 members found this post helpful.
Old 10-05-2012, 06:30 AM   #7
emgee_1
Member
 
Registered: Aug 2009
Location: Nijmegen, The Netherlands
Distribution: Slackware 14
Posts: 39

Original Poster
Rep: Reputation: 6
Solved

Dear fsauer and others, who helped me. It turns indeed out that the solution provided by fsauer is indeed the correct one.

I will take some time to write down the different steps that were tried and finally lead to the solution. Then maybe an entry at the doc project. At least since rc3 or Slackware 14 rc4 we have had no sound.
This is great if your kids are playing games on your laptop but in the end quite annoying. Thank YOU
 
Old 03-21-2013, 09:33 PM   #8
alexpmcmurphy
LQ Newbie
 
Registered: Aug 2005
Distribution: Slackware 12.2 since 10.1
Posts: 4

Rep: Reputation: 0
im having an internet problem, i cant figure out how to buy grave_violin a beer for that answer, thank you a lot either way.
 
Old 03-22-2013, 09:05 PM   #9
jefro
Guru
 
Registered: Mar 2008
Posts: 11,416

Rep: Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398Reputation: 1398
I think you need to buy one for fsauer also.
 
Old 06-21-2013, 12:43 AM   #10
ahzthecat
Member
 
Registered: May 2010
Location: Japan
Distribution: Slackware 13.37, Slackware 14, Wind0z8, Ubuntu 12.10
Posts: 156

Rep: Reputation: 8
Sorry to resurrect this old thread, but I'm having a similar problem and the advice here only gets me halfway solved.

I'm using Slackware64-current KDE on an Acer aspire, trying to get HDMI to work when attached but for the system to default to analog when HDMI is not connected.

I have succeeded in setting HDMI as default with /.asoundrc, but that renders analog sound unuseable. There must be a way to have both working properly, but I can't seem to figure it out.

here's the output of aplay -l
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC271X Analog [ALC271X Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
and here's my /.asoundrc
Code:
pcm.!default {
    type hw
    card 0
    device 3
}
ctl.!default {
    type hw
    card 0
    device 0
}
As I said, this setup gives me HDMI only. How can I jigger this to use HDMI when available and analog when no HDMI is available?

Thanks for any ideas!

Last edited by ahzthecat; 06-21-2013 at 12:48 AM. Reason: kde
 
Old 06-21-2013, 02:23 AM   #11
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 181
Blog Entries: 1

Rep: Reputation: 38
you can use alsa plugin dmix, route, or multi
google combine multiple streams from multiple sound card for alsa. although, you need create dummy control device.
example multi from:
http://jackaudio.org/multiple_devices
Code:
pcm.merge {
    type multi;
    slaves.a.pcm hw:0
    slaves.a.channels 2;
    slaves.b.pcm hw:1
    slaves.b.channels 2;
    bindings.0.slave a;
    bindings.0.channel 0;
    bindings.1.slave b;
    bindings.1.channel 0;
    bindings.2.slave a;
    bindings.2.channel 1;
    bindings.3.slave b;
    bindings.3.channel 1;
}
ctl.merge {
    type hw
    card 0
}
 
Old 06-24-2013, 12:51 AM   #12
ahzthecat
Member
 
Registered: May 2010
Location: Japan
Distribution: Slackware 13.37, Slackware 14, Wind0z8, Ubuntu 12.10
Posts: 156

Rep: Reputation: 8
Looking more closely, is it odd that hdmi and analog are both listed as Card 0 in my aplay output?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound From Flash Player (Slackware) kwikness Linux - Software 7 06-04-2012 05:23 PM
[SOLVED] Flash 10 Install Not Working on Slackware doby48 Linux - Software 7 07-15-2009 01:30 PM
Sound not working with flash plugin for firefox vital_101 Linux - Software 2 08-01-2006 01:26 PM
Flash sound not working SeeMo Slackware 7 01-28-2004 08:36 PM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration