LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2003, 03:07 AM   #1
jim64
Member
 
Registered: Jun 2003
Distribution: Gentoo, Slackware
Posts: 51

Rep: Reputation: 15
Sound error in Slackware 9.0


I have a FIC mobo with nForce2 AC97 Audio Controler. I can not get sound to work and when i start kde i get this error message :
<<<Sound server informational message:
Error while initializing the sound driver:
can't set requested samplingrate (requested rate 44100, got rate 32000)
The sound server will continue, using the null output device.>>>

Need a bit of help. I have already searched and not found any info that applies to my hardware or that answered my question. I have used linux for almost a year and a half but i am still not very good at installing/compiling drivers in linux.
 
Old 07-01-2003, 05:18 PM   #2
hexbit
Member
 
Registered: Jun 2003
Location: Dallas, Tx
Distribution: Slackware
Posts: 65

Rep: Reputation: 15
Try going in to the KDE Control Center. Under Sound & Multimedia > Sound System , check the Sound I/O method. You can try changing the value then hit Apply. I normally hear some kind of static if it works. Also, try changing the value for Custom Sampling Rate in the same area to 32000. I dont normally use KDE so let us know if it doesnt work and we'll try something else. =)
 
Old 07-01-2003, 07:01 PM   #3
jim64
Member
 
Registered: Jun 2003
Distribution: Gentoo, Slackware
Posts: 51

Original Poster
Rep: Reputation: 15
Ok i tried that and it does not give me the error any more but there is still no sound. Shouldn't my sound card be able to suport a higher sampling rate then that if it was working correctly. It is also giving me an error on startup now. I will post what that error is in a min but i cant see it now bc i am in KDE typing this post. O and a quick question that i have never figured out is how do you keep every thing from going off the screen. Like when i do <ls /dev> or <lspci> Thanks for responding to my post. I will post that error in a sec.
 
Old 07-01-2003, 07:36 PM   #4
jim64
Member
 
Registered: Jun 2003
Distribution: Gentoo, Slackware
Posts: 51

Original Poster
Rep: Reputation: 15
Hey here is the part of the output of dmesg. I did not know which part of it you would need so i included most of it. Thanks again.

Nvidia + AC97 Audio, version 0.24, 19:40:02 Jun 30 2003
Nvaudio: in Funcction Nvaudio_init_module
PCI: Setting latency timer of device 00:06.0 to 64
Nvaudio: NVIDIA nForce2 Audio found at IO 0xb400 and 0xb000, IRQ 10
Nvaudio: Audio Controller supports 6 channels.
NVaudio: Defaulting to base 2 channel mode.
ac97_codec: AC97 Audio codec, id: 0x414c:0x4720 (Unknown)
Nvaudio: only 48Khz playback available.
Nvaudio: AC'97 codec 0, DAC map configured, total channels = 6
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
PCI: Setting latency timer of device 00:02.2 to 64
hcd.c: ehci-hcd @ 00:02.2, PCI device 10de:0068 (nVidia Corporation)
hcd.c: irq 11, pci mem e48de000
usb.c: new USB bus registered, assigned bus number 1
ehci-hcd.c: USB 2.0 support enabled, EHCI rev 1. 0
hub.c: USB hub found
hub.c: 6 ports detected
PCI: Setting latency timer of device 00:02.0 to 64
usb-ohci.c: USB OHCI at membase 0xe48e6000, IRQ 11
usb-ohci.c: usb-00:02.0, PCI device 10de:0067 (nVidia Corporation)
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 3 ports detected
PCI: Setting latency timer of device 00:02.1 to 64
usb-ohci.c: USB OHCI at membase 0xe48e8000, IRQ 10
usb-ohci.c: usb-00:02.1, PCI device 10de:0067 (nVidia Corporation)
usb.c: new USB bus registered, assigned bus number 3
hub.c: USB hub found
hub.c: 3 ports detected
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
 
Old 07-01-2003, 08:08 PM   #5
hexbit
Member
 
Registered: Jun 2003
Location: Dallas, Tx
Distribution: Slackware
Posts: 65

Rep: Reputation: 15
> Ok i tried that and it does not give me the error any more but there is still no sound. Shouldn't my sound card be able to suport a higher sampling rate then that if it was working correctly.

I imagine so.. dont know tho ..


> O and a quick question that i have never figured out is how do you keep every thing from going off the screen. Like when i do <ls /dev> or <lspci>

/dev is a directory that contains the special device files for all the devices attached to your system. Try doing something like this instead if you want to see everything in /dev : ls -la /dev | less


Hmm.. what modules are loaded (as root, type : /sbin/lsmod) ..

Also, the line :
ac97_codec: AC97 Audio codec, id: 0x414c:0x4720 (Unknown)
.. it doesnt look like it's associating itself w/a device. On my machine, the equivalent line is :
ac97_codec: AC97 Audio codec, id: 0x4144:0x5348 (Analog Devices AD1881A)
And the ac97_codec is being used by my Via 686a audio driver.

In essence (i think .. heh), is that the ac97_codec isnt communicating w/your nForce2 AC97 Audio Controler. If we can figure out what modules need to be loaded, we can *hopefully* have sound soon .. =)
 
Old 07-02-2003, 11:21 AM   #6
Ultimaterra2005
LQ Newbie
 
Registered: Feb 2003
Distribution: Slackware Linux 9, Redhat 9
Posts: 6

Rep: Reputation: 0
Ok, I had this problem since I started working with slackware since febuary. It used to have invailded permissions but when I had got linux back on my system with the lastest slackware distrubute, it then tells me (No such device), Im pretty certain this has nothing to do with giving permissions other their must be a problem with the kernal. Should I install a older kernal source, or is their a special way of editeding kernal source files? If so, I'd like for somebody to point out what files can I edit, or should I look back on a older kernal source if avilable?
 
Old 07-02-2003, 11:39 AM   #7
jim64
Member
 
Registered: Jun 2003
Distribution: Gentoo, Slackware
Posts: 51

Original Poster
Rep: Reputation: 15
I do not think it has to do with the actual kernel but more so with modules or configuration of the modules i have installed. I was having some other probs so i did the usual newbe thing and decided to do a fresh install. I know i know there are better ways but i had just installed any way and did not have any settings to worry about losing. So after my fresh install i do not get the error at startup any more but i still get no sound. I think its very close to working bc i have noticed that when it boots up i hear a very small pop on my speakers. When i run dmesg i also do not get all the other crap about the audio stuff any more. I asume that is bc last time i tried to install the drivers for nforce2 from nvidia and this time i have not yet. Here is all that dmesg says about audio now :
Intel 810 + AC97 Audio, version 0.21, 15:37:49 Mar 11 2003
PCI: Setting latency timer of device 00:06.0 to 64
i810: NVIDIA nForce Audio found at IO 0xb400 and 0xb000, IRQ 10
i810_audio: Audio Controller supports 6 channels.
ac97_codec: AC97 Audio codec, id: 0x414c:0x4720 (Unknown)
i810_audio: AC'97 codec 0, new EID value = 0x05c7
i810_audio: AC'97 codec 0, DAC map configured, total channels = 6
What does that (unknown) mean and how do i fix it.
 
Old 07-03-2003, 03:39 PM   #8
jim64
Member
 
Registered: Jun 2003
Distribution: Gentoo, Slackware
Posts: 51

Original Poster
Rep: Reputation: 15
Ok new plan.
I was wrong i now do think that the kernel is where i need to be looking. I made a post on nvnews.org and some one suggested that i recompile the kernel. They were very helpful but i am still stuck and need some help.
To view the post and find out what i did go here: http://www.linuxquestions.org/questi...lackware+sound
Ok so that said i tried it. No luck. The first time i compiled the kernel every thing went smoothly till i tried to boot it and it told me that it could not mount my file system. Of course i forgot to enable my type of file system. I could not remember whether i had ext3 or reiserfs so i enabled both in the program that comes up when you type "make menuconfig". I recompiled and then i took it and replaced the first kernel i compiled with the second one. I ran "/sbin/lilo -v" just in case you need to do that (i do not know if i do or not". Lilo gave me no errors. Great i double checked every thing again and rebooted. Lilo comes up i select linux (which is the second kernel i compiled) screen goes blank hd light blinks for a few seconds like its booting but nothing happens and there are no errors. So i boot my original slackware kernel. Thank god i configured lilo for that as an option to. I check every thing and try to boot it again. Same thing happens... nothing. So i start over again and try to recompile my kernel again and delete the other 2 kernels. I typed make clean. Some text prints but no errors. So i try to compile again going through carefully to check everything in menuconfig. i save my changes and try to compile it with "make dep bzImage modules modules install" it goes ok for a wile but close to the end it gives me an error and stops.
What shall i do now? Any one got any ideas? I am open for suggestions. =)
-FYI i also noticed that in the kernel there is a option for nforce sound. I wish i could know if i enable it if that will make my sound card work.
 
Old 07-03-2003, 03:51 PM   #9
jim64
Member
 
Registered: Jun 2003
Distribution: Gentoo, Slackware
Posts: 51

Original Poster
Rep: Reputation: 15
ok sorry that link that i listed above was wrong go here:http://www.nvnews.net/vbulletin/show...threadid=14264
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound server informational message: Error while initializing the sound driver... LA004 Linux - Hardware 4 08-21-2005 08:25 PM
Replaced a Sound Card (ESS) and now no sound under Slackware LeniuNYC Linux - Hardware 1 03-14-2004 05:21 PM
No Sound : request_module: failed /sbin/modprobe -- sound-slot-0. error = 256 Mebuh Linux - General 0 01-26-2004 07:51 AM
AC97 int. sound slackware 9.0 no sound TheDanLayerOSI Linux - Hardware 1 06-13-2003 04:42 AM
sound error in kde 3.1 / slackware 9 filiond Linux - Software 5 04-08-2003 08:30 AM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration