LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-19-2004, 05:50 PM   #1
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Rep: Reputation: 30
sound card installed not working


hi

i just installed some 2 year old sound card from my old computer

and i play some file like in xmms and no sound comes out of my headfones

but on the screen it shows the visual sound equalizer things (the bars dancing up and down lol)

so i think i need some help with this

thanks
 
Old 02-19-2004, 06:15 PM   #2
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
Re: sound card installed not working

Quote:
Originally posted by Longinus
hi

i just installed some 2 year old sound card from my old computer

and i play some file like in xmms and no sound comes out of my headfones

but on the screen it shows the visual sound equalizer things (the bars dancing up and down lol)

so i think i need some help with this

thanks
the sound was defaulted to mute, have you moved the vol and pcm up till say 90% by using alsamixer and then alsactl store?
 
Old 02-19-2004, 06:23 PM   #3
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
oh wow didnt know that hehe thanks man
 
Old 02-19-2004, 06:27 PM   #4
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
hope it helps you. slackware has it's perculiarity, but once you know it(i jot them down for my future reinstallation use), you will be ok.
 
Old 02-19-2004, 06:27 PM   #5
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
hrmm... when i type in
alsactl
it says command not found
 
Old 02-19-2004, 06:30 PM   #6
Kovacs
Member
 
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 30
You have to be root to run it.

To elaborate...

alsactl is in /usr/sbin, which won't be in your user's path, but it is in root's. You also have to have write permission for /etc/asound.state which requires root.

Last edited by Kovacs; 02-19-2004 at 06:31 PM.
 
Old 02-19-2004, 06:30 PM   #7
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
it should be at root:

#alsamixer (do the adjustment on vol and pcm, hit M to unmute)

#alsactl store


not sure it needs a reboot, i cannot recall now, but no harm doing it (my windoze habit is still very much with me)
 
Old 02-19-2004, 06:34 PM   #8
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
awesome thanks guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my Sound Card Installed? halfpower Debian 1 10-03-2005 09:13 AM
sound not working, sarge with alsa installed yoyoguy2 Debian 12 07-03-2005 06:19 PM
No sound with a CM8738 sound card -- alsa installed istar80 Linux - Hardware 1 06-17-2005 02:02 PM
Installed USB2.0 card - sound stopped working DJOtaku Linux - Hardware 0 02-18-2005 01:23 AM
Prowler Sound card drivers installed, but get sound errors? MDK9.2 RHLinuxGUY Mandriva 1 03-11-2004 09:26 PM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration