LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-03-2003, 02:14 AM   #1
ratbert90
Member
 
Registered: Jan 2003
Posts: 67

Rep: Reputation: 16
sound blaster pci 128 no sound


I have a soundblaster pci 128 sound card. I tried mod-probing the drivers from the kernel, and I even recompiled the kernel.

All with out luck =\
I get no sound what-so-ever. This is really upsetting because I play tribes2 and I need sound. Badly.

Can someone please help.

thank you!
 
Old 01-03-2003, 02:15 AM   #2
ratbert90
Member
 
Registered: Jan 2003
Posts: 67

Original Poster
Rep: Reputation: 16
oh, by the way. Im running slackware 8.1
 
Old 01-03-2003, 02:29 AM   #3
tunedLow
Member
 
Registered: Sep 2001
Location: Salt Lake City
Distribution: Slackware 8.1
Posts: 133

Rep: Reputation: 15
This may be stupid question, but anyway, did you check your permissions?

Here's a link too
http://www.linuxquestions.org/questi...light=creative

Last edited by tunedLow; 01-03-2003 at 02:31 AM.
 
Old 01-03-2003, 03:55 AM   #4
ratbert90
Member
 
Registered: Jan 2003
Posts: 67

Original Poster
Rep: Reputation: 16
yeah. still no dice. Im getting really agrivated. I usually dont post for anything (in fact this is my first) Ive done everything the hard way and by learning how to do it myself.

This is my 12th slackware copy from the first

But this is really bugging me. Ive tried everything I can and I still dont get any sound. Any help would be appreciated. Oh, btw, it still gives me that error at the start of kde (dont want to take it down untill this is fixed

Sound server informational message:
Error while initalizing the sound driver:
Device /dev/dsp can't be opened (no such device)
The sound server will continue, using the null output device.

So I know its not me being stupid and plugging the speaker into the wrong port.

Any help would be appreciated.

Thanks!
 
Old 01-03-2003, 07:19 AM   #5
bynaar
Member
 
Registered: Jul 2002
Posts: 141

Rep: Reputation: 15
Do you have the right module loaded ?
The first soundcard I used was called soundblaster 128 pci, but it turned out to be a 'vibra 128'.
If you are running slackware with the standard kernel, you only have to uncomment the right module in /etc/rc.d/rc.modules , save and reboot.

it looks like this:

### Sound support ###

# ES1370 support, such as Sound Blaster 128PCI:
#/sbin/modprobe es1370
# ES1371 support, such as Sound Blaster 64V PCI:
#/sbin/modprobe es1371
I don't remember which module that works. just try one at the time.

To allow all users to have sound you will have to change permissions:

chmod 666 /dev/mixer
chmod 666 /dev/sound/
chmod 666 /dev/dsp
 
Old 01-03-2003, 07:37 AM   #6
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
"lspci -vv" will tell us exactly what sound chip you have, "lsmod" will tell us what modules you have loaded and "ls -al /dev/dsp*" will tell us if the permissions are correct.
 
Old 01-03-2003, 11:24 AM   #7
ratbert90
Member
 
Registered: Jan 2003
Posts: 67

Original Poster
Rep: Reputation: 16
well, im the only user on the pc, so other user permissions dont matter (I always log on as root.)
but doing a lspci -vv shows a:

00:08:0 Multimedia audio controler: Ensoniq 5880 Audio PCI (rev02)
Subsystem: Ensoniq: UNKNOWN DEVICE 8001
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGAsnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- Fast2B2- ParErr- DEVSEL=slow > TAbort- <TAbort- < MAbort- > SERR- <PERR-
Latency: 32 (3000ns min, 32000ns max)
Interrupt: pin A routed to IRQ 10
Region 0: I/O ports at ec00 [size=64]
Capabilities: [dc] power Management version 1
Flags: PMEClK- DSI+ D1- D2+ AuxCurrent=0mA PME (D0-, D1-, D2-,D3hot-, D3colt-)
Status: D0 PME -Enable- DSel=0 DScale=0 PME-

Hope that info helps. I think the UNKNOWN device is the important thing here.

Again, any help is apreciated.
Thanks!
 
Old 01-03-2003, 11:25 AM   #8
ratbert90
Member
 
Registered: Jan 2003
Posts: 67

Original Poster
Rep: Reputation: 16
oops, I also have the soundcore modual loaded
and the permissions are only for root, but again, I only use root
 
Old 01-03-2003, 01:40 PM   #9
ratbert90
Member
 
Registered: Jan 2003
Posts: 67

Original Poster
Rep: Reputation: 16
yeah!
Got it to work.

Its using the es1371 mod
Also it was plugged into the wrong port. Im only used to 3 ports from my ac'97 card. stupid me. thanks for your help!
 
Old 01-03-2003, 02:47 PM   #10
tunedLow
Member
 
Registered: Sep 2001
Location: Salt Lake City
Distribution: Slackware 8.1
Posts: 133

Rep: Reputation: 15
You should watch out about running as root all the time. That will get you...
 
Old 07-26-2007, 05:08 AM   #11
sunils1973
Member
 
Registered: Jan 2007
Location: INDIA
Distribution: Ubuntu, Debian
Posts: 323

Rep: Reputation: 30
sound problem

Myne is the onboard sound card

and the message (like that of rabert came)
Sound server informational message:
Error while initalizing the sound driver:
Device /dev/dsp can't be opened (no such device)
The sound server will continue, using the null output device
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound blaster 128 pci alaios Linux - Hardware 1 06-02-2005 05:13 PM
Can't make the joypad work - using a Creative Sound Blaster PCI 128 tomas412 Linux - Hardware 0 02-25-2005 01:42 PM
Sound blaster PCI 128 drivers nutz Linux - Hardware 6 11-29-2003 09:54 AM
Sound Blaster 128 problem The X Linux - Hardware 3 02-04-2003 09:29 PM
Sound Blaster 128/ensoniq es1371 driver install Rodcl Linux - Hardware 8 08-19-2002 01:54 PM


All times are GMT -5. The time now is 04:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration