LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Some X problems(keyboard related) (http://www.linuxquestions.org/questions/slackware-14/some-x-problems-keyboard-related-874249/)

FeyFre 04-11-2011 02:19 AM

Some X problems(keyboard related)
 
Hello

Some times ago its appeared I have a couple of problems related X

1. Only, and only KDE reacts on magic keystroke Alt+Ctrl+Backspace. Neither xfce, fluxbox, blackbox, wmaker, fvwm2 or twm reacts. I'm personally using xfce and sometimes fluxbox, and never kde. Other my desktop PC with the same Slackware have not such problems.

2. Only, and only root user can use keyboard in X. Other users can use mouse only. Even Alt+Ctrl+Backspace unusable. And I cannot understand what wrong.

I'm quite newbie in configuring X-related stuff, and cannot remember what I could do to cause such behaviour. Shall be thankful for any help.

PS: Slackware 13.1, no patches was applied.

JokerBoy 04-11-2011 03:05 AM

1. setxkbmap -option terminate:ctrl_alt_bksp
2. are you using a custom xorg.conf? what keyboard do you have there?

FeyFre 04-11-2011 03:55 AM

Quote:

1. setxkbmap -option terminate:ctrl_alt_bksp
Added, Pressed ctrl_alt_bksp - xfce terminated. started X again. No reaction on pressing ctrl_alt_bksp until I run this command again. My xorg.conf already contains:
Code:

Section "InputDevice"
      Identifier  "Keyboard0"
      Driver      "kbd"
      Option      "XkbLayout" "en_GB,ru,uk"
      Option      "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp"
EndSection

Quote:

2. are you using a custom xorg.conf? what keyboard do you have there?
What do you mean "custom"?
It always custom, because it was generated by xorgsetup. And I did not found any installed packages which provides own xorg.conf as out-of-box configuration.
Keyboard model is Mitsumi KFK-EA4XT.

w1k0 04-11-2011 08:03 AM

1. Try to remove /etc/X11/xorg.conf. For example move it to /etc/X11/xorg.conf.old.

2. In /etc/profile.d/lang.sh comment:

Code:

#export LANG=en_US
and uncomment:

Code:

export LANG=en_US.UTF-8
3. In /home/your_user_name/.xinitrc put:

Code:

/usr/bin/X11/setxkbmap ru
(Keymap ru used above is in /etc/X11/xkb/symbols).

Maybe it'll help in your case.

FeyFre 04-11-2011 08:18 AM

Quote:

1. Try to remove /etc/X11/xorg.conf. For example move it to /etc/X11/xorg.conf.old.
No results.
Quote:

2. In /etc/profile.d/lang.sh comment:
No results.
Quote:

3. In /home/your_user_name/.xinitrc put:
I'm pretty sure it will no work either. I didn't do that on any other installation and they work perfectly.

w1k0 04-11-2011 08:26 AM

Quote:

Originally Posted by FeyFre (Post 4320958)
No results.
No results.
I'm pretty sure it will no work either. I didn't do that on any other installation and they work perfectly.

It's a pity because it works for me with Polish keyboard and UTF-8 encoding.

Try to generate xorg.conf with X -configure command -- it generates xorg.conf.new file in /root directory.

FeyFre 04-11-2011 10:48 AM

w1k0, I do not have any problems with localisation or keyboard layout. My problem is with keyboard as input device itself.

imitheos 04-12-2011 08:07 AM

Quote:

Originally Posted by FeyFre (Post 4321098)
w1k0, I do not have any problems with localisation or keyboard layout. My problem is with keyboard as input device itself.

I would suggest hashing the keyboard entries in xorg.conf and let hal config it (using evdev instead of kbd) but since you tried without xorg.conf, you have already done it. Have you read /var/log/Xorg.0.log to see if there is any error opening the device or something ?

FeyFre 04-12-2011 11:09 AM

1 Attachment(s)
The only one error when X probing fbdev is not keyboard related.
And I'm sure I did not touched any evdev-related file or stuff.


Attachment 6681

imitheos 04-12-2011 12:14 PM

Quote:

Originally Posted by FeyFre (Post 4322293)
The only one error when X probing fbdev is not keyboard related.
And I'm sure I did not touched any evdev-related file or stuff.


Attachment 6681

I am a bit confused. According to your log, hal configured the devices. If you have set them in xorg.conf, it should get first priority and not hal.
Also, unless you have added an fdi file in /etc/hal, hal shouldn't set your layouts and options.

This "Keyboard0" you have configured in xorg.conf, is it set in the "ServerLayout" section ? Is there a line InputDevice "Keyboard0" "CoreKeyboard" ?

FeyFre 04-26-2011 03:49 PM

Something definitely wrong with my slackware installation!
I have new weird log message, when starting X as root(without any xorg.conf). Do not have it now, but it says that "AllowEmptyInput is true and so all input devices will be blocked". And they actually got blocked, until I set in xorg.conf AllowEmptyInput to false. What is this was? What stupid script creates those setting?
And again, problem of keyboard absence for non-root users is still actual.

allend 04-26-2011 05:20 PM

From the Xorg.0.log that you posted:
Quote:

II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AutoAddDevices.
From CHANGES_AND_HINTS.TXT for Slackware 13.1
Quote:

Speaking of Xorg, the version of Xorg shipped with Slackware 13.1 will not
(in most cases) require an /etc/X11/xorg.conf file at all. Configuration of
input devices and such is handled by HAL, and the X server autoconfigures
everything else. You can still create an xorg.conf file if you wish, or you
can create a minimal xorg.conf with only the specific contents that you wish
to override (as an example, to use a binary-only video driver).
Due to removed drivers and other such changes, it's quite possible that your
old xorg.conf will not work correctly with this version of Xorg.

If you need to use a non-US keyboard layout, then copy the file located at
/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policy
and edit it to suit your needs. Have a look at the contents of that file
for an example and more information. If you prefer to do this the "old" way
using /etc/X11/xorg.conf, then you can use "X -configure" or "xorgsetup" to
generate an xorg.conf, then add the following lines to the "ServerFlags"
section to disable input device hotplugging via HAL:
Option "AllowEmptyInput" "false"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"
This is also relevant if you prefer to disable HAL completely for whatever
reason.
There seems to be problem with your HAL setup. Check your configuration files in /etc/hal/fdi/policy (or just delete them to use the defaults). Also check that the HAL daemon is being started at boot. Make sure that /etc/rc.d/rc.messagebus and /etc/rc.d/rc.hald are executable.

FeyFre 04-27-2011 04:57 AM

Huh! Some dumb did chmod -x /etc/rc.d/rc.messagebus
probably that was me(had some problems with it but had not time to solve it).


All times are GMT -5. The time now is 12:21 AM.