LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2005, 08:47 AM   #1
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
Lightbulb Some solutions to the blank screen


After many problems trying to fix the BlankScreen after recompile the kernel 2.6.x I saw many people with the same problem in many places, so I decided to start up this post just to post some ways to fix this problem, and I believe this are all the always you need to fix it. PLease, contribute with this post only with things related to the BlankScreen problem, if you have kernel panic, HD problems and any thing else try search or post a new question at the forum, just to avoid confusion.

First of all if you are geting the blank screen problem at boot time but you still can login in blind mode so everything is probably fine, you are getting a FrameBuffer problem, this often occurs cause of the VideoCard configured at FrameBuffer Video Graphic Device. The first solution is not to use this mode, of course if you are like me you will want to use it just because you could before and now you know you want it too. Many people are selecting the right options that should be selected at the Config file of the kernel, but they are selecting an one more option that may be not needed.

This is in menuconfig Device Drivers > Graphics Support:
You must have Support For Frame Buffer Devices selected (do not select modules here) and Enable Video Mode Handling Helpers, Enable Tile Blitting Support, VESA VGA Graphics Support

This is in menuconfig Device Drivers > Graphics Support > Console Display Drivers Support:
Enable Video Mode Selection Support , Framebuffer console support, Select Compiled-in Fonts, VGA 8x8 font, VGA 8x16 font

This is in menuconfg Device Drivers > Graphics Support > Logo Configuration:
All selected

If these options aren't visible, go to 'Code Maturity level Options' and check 'Prompt for development...'

Now I will give you some advices, first try only fill with this option in you configuration, if all goes fine you can always change and recompile to see if everything still stays fine. Many people (including me) try selecting the right Video Card Adapter in the Graphics Support section, but I recommend you to not select other thing that arent in the fields above. My problem was solved when I deselected the ATi Radeon Display Support. Even having an ATi Radeon video card the problem was here. So just enable the VESA VGA Graphics Support options, in most cases this will be more then enought.

If after recompiling and booting you get no problem with the Framebuffer console so you can try selecting other options and see if everything thing goes fine. Believe, its a good tip.

What I heard about some possible solution
You must be aware that even working for me maybe will not work for you, so Im placing here some solution that I see in this forum.
One people reported that have the problem fixed after deselecting all Logo Configuration options. The recipes above doesnt work why not try this too?

Cheking if everything its ok
This are the option that must be set in the .config file, try #cat /usr/src/linux/.config | grep -i <the option here> or #cat /usr/src/linux/.config | grep -in -A 65 'graphics support' to check if its the way is must be.
Code:
# Graphics support
#
CONFIG_FB=y
CONFIG_FB_VESA=y
CONFIG_VIDEO_SELECT=y
#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_PCI_CONSOLE=y
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y

#
# Logo configuration
#
CONFIG_LOGO=y
CONFIG_LOGO_LINUX_MONO=y
CONFIG_LOGO_LINUX_VGA16=y
CONFIG_LOGO_LINUX_CLUT224=y
I hope you realise that there are no other selected option in Graphics Support than the 3 above... so try keep this way.

Try using vga=773 or vga=771 at /etc/lilo.conf or at boot time adding it in the boot parameters: Linux vga=773 (where linux is the label to the boot option of your linux)

Okay, the rest Im supposing you know how to do ... if you dont you can find at the topic Kernel Compile Guide for 2.6.0

I hope to help someone... any suggestions are welcome

Regards [ ]'s
 
Old 07-01-2005, 08:11 PM   #2
frandalla
Member
 
Registered: Oct 2003
Location: Tokyo - Japan
Distribution: Slackware
Posts: 348
Blog Entries: 1

Rep: Reputation: 37
Hey man! Thanks for your work. I had this problem around the releasing of 2.6.0 and there weren't many written down solutions so I had to spend a lot of sweat to make it work. I guess people won't have the many problems I had having your post around =)
 
Old 07-02-2005, 11:52 AM   #3
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
Yes! Thanks
This was what I saw after looking for some answer, was very messy, but now I hope keep everything in just one place so everyone with our problem, in special the newbies, could find the solution easy and fast without losing many hair...




ps: eu falo portugues tb hehe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.0 Blank screen instead of login in screen damoncf Linux - Distributions 4 02-24-2007 08:49 PM
Blank screen even before BIOS screen on boot josce Linux - Laptop and Netbook 3 01-04-2005 08:27 AM
Blank screen after initial install screen? CRCool75 Linux - Newbie 2 11-16-2004 09:32 PM
blank screen - help please snoop24 Linux - Hardware 1 09-16-2003 12:27 PM
Blank screen - screen saver ??? cstehle Linux - Newbie 8 03-13-2002 09:44 PM


All times are GMT -5. The time now is 03:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration