LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-11-2012, 05:20 PM   #1
longus
LQ Newbie
 
Registered: Dec 2008
Posts: 28

Rep: Reputation: 0
Some issues with RC1 and old ones.


Hello all! Congratulations for the good job and i am waiting the new Slack soon and sane!
With respect to all of the problem-solving people i want to share some issues, which i am not able to dissolve alone.
The system is Slackware64-current, up to date - RC1.
1) when the system boot, there is a message in the console:
"Starting udev events: /sbin/udevadm trigger --action=add
udevd[1071]: could not find module by name -"rtc_cmos"
udevd[....] worker [....] timeout, kill it
udevd: seq 1211 '/devices/ pc i0000:00/0000:00:1c.0/0000:02.0' killed"
This takes long time, may be about 5-6 seconds, then the boot process continue normally. Later i can see in dmesg this line:
5.195579] rtc_cmos 00:04: setting system clock to 2012-08-10 22:39:39 UTC (1344638379)
When i boot custom kernel this appear immedeately after the system start and with the generic kernel - later, a second or 2 befor the grafic login screen appears. I saw that for first time with 3.2.21 kernel, may be the time udev was upgrated. So i think it is somehow related to udev.
2) I use Xfce-4.10 from the official tree and i have some problems mounting devices.
I have a 3g usb modem, HUAWEY E173, wich has 2 slots - for sim card, which is used for internet connection, and a microSD slot which is used as a storage device. I use that slot to connect the microSD card from my telefon. The device seems to be mounted and can be opened with Dolphyn or accessed in console terminal, but trying open it with Thunar gives an error: Device is not accessible" even when i try with Thunar started with root privilages.
No problems hire to mount a usb memory stick and access it with Thunar.
3)Clipboard. When i copy something with the mouse i am not able to place it with a key-combination (Ctrl+V); this appears betwean any two program windows.
4)network-manager-applet. After login in the system there is a boring dialog window asking me to write my wallet password. Can i stop this?
5)Multilib, compiling a program in 32 bit mode. I am trying to cimpile freetype and the other font related programs in compat32 packages having nice fonts in skype. I fallow Erik Hameleer's instructions: 1) ". /etc/profile.d/32.dev.sh" and 2) remove the "64" from LIBDIRSUFFIX in the SlackBuild. When the process reaches the moment searching for gcc, something fell the RAM and slap memory, and in a minute or two the system is going out of control - no reaction to keyboard or mouse, even sysrq key combination is not able to place the keyboard under control and to restart the system. Htop is showing a lot of gcc processes each eating 1% of the cpu. Do i miss something or mess where is not my place?
If more information is needed i should be happy to receive an instruction how to obtain it. Thanks to all in advance!
 
Old 08-11-2012, 05:58 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,355

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
1. Did you compile your custom kernel with RTC support?
 
Old 08-11-2012, 06:21 PM   #3
longus
LQ Newbie
 
Registered: Dec 2008
Posts: 28

Original Poster
Rep: Reputation: 0
I think so. I use the official config and only remove some hardware drivers, which are redundant on my system.
But as i said, it occur also with the generic kernel.
 
Old 08-11-2012, 06:35 PM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,355

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
you can test it by using
Code:
cat /boot/config | grep -i rtc
 
Old 08-11-2012, 06:50 PM   #5
longus
LQ Newbie
 
Registered: Dec 2008
Posts: 28

Original Poster
Rep: Reputation: 0
It's long:

CONFIG_HPET_EMULATE_RTC=y
CONFIG_RTC_LIB=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_HCTOSYS=y
CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
# CONFIG_RTC_DEBUG is not set
# RTC interfaces
CONFIG_RTC_INTF_SYSFS=y
CONFIG_RTC_INTF_PROC=y
CONFIG_RTC_INTF_DEV=y
CONFIG_RTC_INTF_DEV_UIE_EMUL=y
CONFIG_RTC_DRV_TEST=m
# I2C RTC drivers
CONFIG_RTC_DRV_DS1307=m
CONFIG_RTC_DRV_DS1374=m
CONFIG_RTC_DRV_DS1672=m
CONFIG_RTC_DRV_DS3232=m
CONFIG_RTC_DRV_MAX6900=m
CONFIG_RTC_DRV_RS5C372=m
CONFIG_RTC_DRV_ISL1208=m
CONFIG_RTC_DRV_ISL12022=m
CONFIG_RTC_DRV_X1205=m
CONFIG_RTC_DRV_PCF8563=m
CONFIG_RTC_DRV_PCF8583=m
CONFIG_RTC_DRV_M41T80=m
CONFIG_RTC_DRV_M41T80_WDT=y
CONFIG_RTC_DRV_BQ32K=m
CONFIG_RTC_DRV_S35390A=m
CONFIG_RTC_DRV_FM3130=m
CONFIG_RTC_DRV_RX8581=m
CONFIG_RTC_DRV_RX8025=m
CONFIG_RTC_DRV_EM3027=m
CONFIG_RTC_DRV_RV3029C2=m
# SPI RTC drivers
# Platform RTC drivers
CONFIG_RTC_DRV_CMOS=y
CONFIG_RTC_DRV_DS1286=m
CONFIG_RTC_DRV_DS1511=m
CONFIG_RTC_DRV_DS1553=m
CONFIG_RTC_DRV_DS1742=m
CONFIG_RTC_DRV_STK17TA8=m
CONFIG_RTC_DRV_M48T86=m
CONFIG_RTC_DRV_M48T35=m
CONFIG_RTC_DRV_M48T59=m
CONFIG_RTC_DRV_MSM6242=m
CONFIG_RTC_DRV_BQ4802=m
CONFIG_RTC_DRV_RP5C01=m
CONFIG_RTC_DRV_V3020=m
CONFIG_RTC_DRV_PCF50633=m
# on-CPU RTC drivers
 
Old 08-12-2012, 09:26 AM   #6
foobarz
Member
 
Registered: Aug 2010
Distribution: slackware64-current
Posts: 48

Rep: Reputation: 10
cd /boot/initrd-tree/lib/udev/
file *

You can see udev-add-printer it needs python

Another script wants tcl. Some parts of udev fail from inside the initrd without dependencies added to the initrd-tree. I had to add the whole bash packages to my initrd-tree to make one of the udev rules IMPORT{program} lines work.

udev is a little messy in this way where different rules want to use different shells and script languages

I'm not sure why udevd is wanting to load module rtc-cmos, but it is listed in /lib/modules/$(uname -r)/modules.builtin

Last edited by foobarz; 08-12-2012 at 09:31 AM. Reason: i goofed
 
Old 08-12-2012, 08:53 PM   #7
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
If you don't need rtc_cmos just blacklist it. I had the same message show up and I know I don't need it, so I added the following to the top of /etc/modprobe.d/blacklist.conf
Code:
blacklist rtc_cmos
You shouldn't see the message on the next boot.
 
Old 08-13-2012, 01:30 AM   #8
sorinm
Member
 
Registered: Jul 2012
Location: RO
Distribution: Slackware64-14.0
Posts: 65

Rep: Reputation: Disabled
Same issue with rtc_cmos here. I have three boxes, all running 64-current and stock kernel.

1st box uses an initrd and gives me the rtc_cmos error. FUJITSU SIEMENS ESPRIMO EDITION P2540
2nd box uses an initrd and doesn`t give me the rtc_cmos error. FUJITSU ESPRIMO P2550
3rd box uses the huge kernel without an initrd and gives me the rtc_cmos error. FUJITSU PRIMERGY TX100 S1

Last edited by sorinm; 08-13-2012 at 01:32 AM.
 
Old 08-16-2012, 05:48 AM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 3,231

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
This error message is a result of the module alias definitions in /lib/modprobe.d/isapnp.conf. I've sent a query to Pat asking whether these still have any value, but in the meantime, if you copy /lib/modprobe.d/isapnp.conf into directory /etc/modprobe.d and then remove the aliases relating to the rtc it should stop the error message.
 
2 members found this post helpful.
Old 08-16-2012, 07:48 PM   #10
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
Quote:
Originally Posted by GazL View Post
This error message is a result of the module alias definitions in /lib/modprobe.d/isapnp.conf. I've sent a query to Pat asking whether these still have any value, but in the meantime, if you copy /lib/modprobe.d/isapnp.conf into directory /etc/modprobe.d and then remove the aliases relating to the rtc it should stop the error message.
Good catch! Apparently with 14.0 isapnp.conf is under /lib/modprobe.d, but in 13.37 it is under /etc/modprobe.d. Since I did an upgrade I had it in both places and the default file was being used. Taking out the rtc_cmos entries and any others should make it so I don't need to blacklist them. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 10 aircrack-ng 1.0-rc1 instalation issues edw00rd Linux - Newbie 2 03-27-2009 12:30 AM
Rc1/rc2?? gamfa Grafpup 2 05-31-2007 03:20 PM
RC1 vs OSS R¬dical_úD Suse/Novell 3 10-07-2005 10:31 AM
evolution on 10.0 rc1 jsheffie Suse/Novell 1 10-06-2005 10:11 AM
10 RC1 is out colnago Conectiva 0 04-24-2004 01:10 AM


All times are GMT -5. The time now is 12:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration