LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-10-2003, 02:06 AM   #1
sehris
LQ Newbie
 
Registered: May 2003
Posts: 21

Rep: Reputation: 15
some help with x and mounts


first issue i'm having:
i finally got fluxbox working nice and smooth under root. unfortunatley X is not starting flux for the one user that i have. i've change the .xinitrc file in the user's ~/ directory to read:
exec /usr/local/bin/fluxbox

at the end with exex fwm2 commented out. i've done the same to the /etc/X11/xinit/xinitrc file. i've even chmod'ed the ~/xinitrc file to 700.

when i run startx it starts fwm2 for that user isntead of flux, though root works just fine.

could it be because i went through the whole install procedure of fluxbox as root?

second question:
i think i asked this before, but i couldn't find it with the search in any forums.

i have a 2nd drive that is fat32 formatted that i use for archives. when i boot linux, it automatically mounts that drive as /archive in the root directory. my users don't have the ability to read and write to the /archive directory. any clue how to mount it so all of the default users group gets full access to the drive? are there any options i can configure the inettab file with so that those permissions are granted on boot?

thanks
 
Old 08-10-2003, 02:23 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Re: some help with x and mounts

Quote:
Originally posted by sehris
when i run startx it starts fwm2 for that user isntead of flux, though root works just fine.

could it be because i went through the whole install procedure of fluxbox as root?
certainly not ... I'd suggest you look at your
~/.xsession-errors ... maybe the executable
has wrong permissions by some accident?

Quote:
second question:
i think i asked this before, but i couldn't find it with the search in any forums.

i have a 2nd drive that is fat32 formatted that i use for archives. when i boot linux, it automatically mounts that drive as /archive in the root directory. my users don't have the ability to read and write to the /archive directory. any clue how to mount it so all of the default users group gets full access to the drive? are there any options i can configure the inettab file with so that those permissions are granted on boot?
Try adding "umask=022" and "user" to the options
in fstab ...
/dev/hda8 / vfat auto,user,umask=022 0 0

The thread you're after is http://www.linuxquestions.org/questi...t+user+windows

Cheers,
Tink
 
Old 08-10-2003, 03:21 AM   #3
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
For problem #1, try logging in as that user and doing 'xwmconfig' and choosing 'fluxbox' if it's present rather than editing the ~/.xinitrc file directly. You *can* do it all directly but, under some cirumstances, it doesn't always work with a simple exec change and xwmconfig makes it easier.
 
Old 08-10-2003, 01:49 PM   #4
sehris
LQ Newbie
 
Registered: May 2003
Posts: 21

Original Poster
Rep: Reputation: 15
thanks for the help on setting up the mount. and i'll check those errors later tonight when i have a chance.

** edit **

xwmconfig still doesn't show fluxbox, but i have it running for my user. its wierd how it runs though, when i run startx it starts fwm2, but if i quit out of fwm2 using the menu instead of killing the server, it quits out and fluxbox is there running!? lol.

my mounts are up how i wanted them though .now if only i could get fluxbox to keep my background as the pic i have instead of constantly comming up with the default bg...

Last edited by sehris; 08-11-2003 at 09:49 AM.
 
Old 08-12-2003, 02:45 AM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Just put the command you use to set-up
your background in your .xsession file,
before the exec fluxbox

Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cd mounts Murph00009 Linux - Hardware 1 01-07-2005 10:57 PM
About /proc/mounts A-Liang Programming 3 11-27-2004 09:52 PM
My / directory only mounts ro cruxx Linux - General 5 08-17-2004 02:33 AM
The mounts don't stay! ch4s3r Linux - Software 25 05-21-2004 09:07 AM
Cd mounts auto ch4s3r Linux - Software 1 02-26-2004 06:35 PM


All times are GMT -5. The time now is 09:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration