LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-19-2004, 12:26 PM   #1
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Rep: Reputation: 0
Some hard questions I believe -Channel Bindings(soundcard), ntfs-capture and apm??


1. How do I configure alsa to send sound to both my headphones and my speaker output? (Now I only got sound in my headphones, and nothing is muted in alsamixer). I use Soundblaster Live 5.1
My .asoundrc look like this.
pcm.!default {
type hw
card 1
}

ctl.!default {
type hw
card 1
}

I will include my alsaconf file in the end.

2. I have installed ntfs-capture and this program changed my fstab to
/dev/hda7 swap swap defaults 0 0
/dev/hda6 / ext3 defaults 1 1
/dev/hdb6 /g vfat defaults 0 0
/dev/cdrom /mnt/cdrw iso9660 noauto,owner,rw 0 0
/dev/hde /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
/dev/hdb5 /mnt/f captive-ntfs defaults,noauto 0 0
/dev/hda5 /mnt/d captive-ntfs defaults,noauto 0 0
/dev/hdb1 /mnt/e captive-ntfs defaults,noauto 0 0
/dev/hda1 /mnt/c captive-ntfs defaults,noauto 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

But the ntfs partitions are not mounted at boot time (not even when I log in as root)??...do I need to load some modules??....I haven't find any information about that...please help me!!
(and it would be fine if users were able to mount and umount the drivers too)

3. When I shut down my system I would like Linux to Power down(turn of the power), not only halt and say "Power Down". I have tryed to uncomment
/sbin/modprobe apm
and then also run modprobe apm
but that has not solved the problem. (It worked fine in XP so I have the right hardware =P )

4. Since I installed the NVIDIA driver the prompt got totally insane after starting KDE.
I Only see pixels in a lot of colors all over the screen. Although KDE is working well with Open GL and everything. I have a Geforce 4 MX 440. I believe this has something to do with the resolution or HSYNC or something like that, but how do I find out what to do and how to do it??


I welcome every solution
/Nihongoga

The alsaconf file (if that would be to any help):
#
# ALSA library configuration file
#

# pre-load the configuration files

@hooks [
{
func load
files [
"/etc/asound.conf"
"~/.asoundrc"
]
errors false
}
]

# load card-specific configuration files (on request)

cards.@hooks [
{
func load
files [
{
@func concat
strings [
{ @func datadir }
"/cards/aliases.conf"
]
}
]
}
{
func load_for_all_cards
files [
{
@func concat
strings [
{ @func datadir }
"/cards/"
{ @func private_string }
".conf"
]
}
]
errors false
}
]

# defaults
#
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.pcm.subdevice -1
defaults.pcm.front.card defaults.pcm.card
defaults.pcm.front.device defaults.pcm.device
defaults.pcm.rear.card defaults.pcm.card
defaults.pcm.rear.device defaults.pcm.device
defaults.pcm.center_lfe.card defaults.pcm.card
defaults.pcm.center_lfe.device defaults.pcm.device
defaults.pcm.surround40.card defaults.pcm.card
defaults.pcm.surround40.device defaults.pcm.device
defaults.pcm.surround41.card defaults.pcm.card
defaults.pcm.surround41.device defaults.pcm.device
defaults.pcm.surround50.card defaults.pcm.card
defaults.pcm.surround50.device defaults.pcm.device
defaults.pcm.surround51.card defaults.pcm.card
defaults.pcm.surround51.device defaults.pcm.device
defaults.pcm.iec958.card defaults.pcm.card
defaults.pcm.iec958.device defaults.pcm.device
defaults.rawmidi.card 0
defaults.rawmidi.device 0
defaults.rawmidi.subdevice -1
defaults.hwdep.card 0
defaults.hwdep.device 0
defaults.timer.class 2
defaults.timer.sclass 0
defaults.timer.card 0
defaults.timer.device 0
defaults.timer.subdevice 0


#
# PCM interface
#

pcm.hw {
@args [ CARD DEV SUBDEV ]
@args.CARD {
type string
default {
@func getenv
vars [
ALSA_PCM_CARD
ALSA_CARD
]
default {
@func refer
name defaults.pcm.card
}
}
}
@args.DEV {
type integer
default {
@func igetenv
vars [
ALSA_PCM_DEVICE
]
default {
@func refer
name defaults.pcm.device
}
}
}
@args.SUBDEV {
type integer
default {
@func refer
name defaults.pcm.subdevice
}
}
type hw
card $CARD
device $DEV
subdevice $SUBDEV
}

pcm.plughw {
@args [ CARD DEV SUBDEV ]
@args.CARD {
type string
default {
@func getenv
vars [
ALSA_PCM_CARD
ALSA_CARD
]
default {
@func refer
name defaults.pcm.card
}
}
}
@args.DEV {
type integer
default {
@func igetenv
vars [
ALSA_PCM_DEVICE
]
default {
@func refer
name defaults.pcm.device
}
}
}
@args.SUBDEV {
type integer
default {
@func refer
name defaults.pcm.subdevice
}
}
type plug
slave.pcm {
type hw
card $CARD
device $DEV
subdevice $SUBDEV
}
}

pcm.plug {
@args [ SLAVE ]
@args.SLAVE {
type string
}
type plug
slave.pcm $SLAVE
}

pcm.dmix {
@args [ SLAVE FORMAT RATE ]
@args.SLAVE {
type string
default "hw:0,0"
}
@args.FORMAT {
type string
default S16_LE
}
@args.RATE {
type integer
default 48000
}
type dmix
ipc_key 5678293
ipc_key_add_uid yes
slave {
pcm $SLAVE
format $FORMAT
rate $RATE
}
}

pcm.dsnoop {
@args [ SLAVE FORMAT RATE ]
@args.SLAVE {
type string
default "hw:0,0"
}
@args.FORMAT {
type string
default S16_LE
}
@args.RATE {
type integer
default 48000
}
type dsnoop
ipc_key 5778293
ipc_key_add_uid yes
slave {
pcm $SLAVE
format $FORMAT
rate $RATE
}
}

pcm.shm {
@args [ SOCKET PCM ]
@args.SOCKET {
type string
}
@args.PCM {
type string
}
type shm
server $SOCKET
pcm $PCM
}

pcm.tee {
@args [ SLAVE FILE FORMAT ]
@args.SLAVE {
type string
}
@args.FILE {
type string
}
@args.FORMAT {
type string
default raw
}
type file
slave.pcm $SLAVE
file $FILE
format $FORMAT
}

pcm.file {
@args [ FILE FORMAT ]
@args.FILE {
type string
}
@args.FORMAT {
type string
default raw
}
type file
slave.pcm null
file $FILE
format $FORMAT
}

pcm.null {
type null
}

pcm.default {
type plug
slave.pcm {
type hw
card {
@func getenv
vars [
ALSA_PCM_CARD
ALSA_CARD
]
default {
@func refer
name defaults.pcm.card
}
}
device {
@func igetenv
vars [
ALSA_PCM_DEVICE
]
default {
@func refer
name defaults.pcm.device
}
}
subdevice {
@func refer
name defaults.pcm.subdevice
}
}
}

# redirect to load-on-demand extended pcm definitions
pcm.cards cards.pcm
# some links for easy use
pcm.front cards.pcm.front
pcm.rear cards.pcm.rear
pcm.center_lfe cards.pcm.center_lfe
pcm.surround40 cards.pcm.surround40
pcm.surround41 cards.pcm.surround41
pcm.surround50 cards.pcm.surround50
pcm.surround51 cards.pcm.surround51
pcm.iec958 cards.pcm.iec958
pcm.spdif cards.pcm.iec958

#
# Control interface
#

ctl.hw {
@args[ CARD ]
@args.CARD {
type string
default {
@func getenv
vars [
ALSA_CTL_CARD
ALSA_CARD
]
default {
@func refer
name defaults.ctl.card
}
}
}
type hw
card $CARD
}

ctl.shm {
@args [ SOCKET CTL ]
@args.SOCKET {
type string
}
@args.CTL {
type string
}
type shm
server $SOCKET
ctl $CTL
}

ctl.default {
type hw
card {
@func getenv
vars [
ALSA_CTL_CARD
ALSA_CARD
]
default {
@func refer
name defaults.ctl.card
}
}
}

#
# RawMidi interface
#

rawmidi.hw {
@args [ CARD DEV SUBDEV ]
@args.CARD {
type string
default {
@func getenv
vars [
ALSA_RAWMIDI_CARD
ALSA_CARD
]
default {
@func refer
name defaults.rawmidi.card
}
}
}
@args.DEV {
type integer
default {
@func igetenv
vars [
ALSA_RAWMIDI_DEVICE
]
default {
@func refer
name defaults.rawmidi.device
}
}
}
@args.SUBDEV {
type integer
default -1
}
type hw
card $CARD
device $DEV
subdevice $SUBDEV
}

rawmidi.default {
type hw
card {
@func getenv
vars [
ALSA_RAWMIDI_CARD
ALSA_CARD
]
default {
@func refer
name defaults.rawmidi.card
}
}
device {
@func igetenv
vars [
ALSA_RAWMIDI_DEVICE
]
default {
@func refer
name defaults.rawmidi.device
}
}
}

rawmidi.virtual {
@args [ MERGE ]
@args.MERGE {
type string
default 1
}
type virtual
merge $MERGE
}

#
# Sequencer interface
#

seq.default {
type hw
}

seq.hw {
type hw
}

#
# HwDep interface
#

hwdep.hw {
@args [ CARD DEV ]
@args.CARD {
type string
default {
@func getenv
vars [
ALSA_HWDEP_CARD
ALSA_CARD
]
default {
@func refer
name defaults.hwdep.card
}
}
}
@args.DEV {
type integer
default {
@func igetenv
vars [
ALSA_HWDEP_DEVICE
]
default {
@func refer
name defaults.hwdep.device
}
}
}
type hw
card $CARD
device $DEV
}

hwdep.default {
type hw
card {
@func getenv
vars [
ALSA_HWDEP_CARD
ALSA_CARD
]
default {
@func refer
name defaults.hwdep.card
}
}
device {
@func igetenv
vars [
ALSA_HWDEP_DEVICE
]
default {
@func refer
name defaults.hwdep.device
}
}
}

#
# Timer interface
#

timer_query.hw {
type hw
}

timer_query.default {
type hw
}

timer.hw {
@args [ CLASS SCLASS CARD DEV SUBDEV ]
@args.CLASS {
type integer
default {
@func refer
name defaults.timer.class
}
}
@args.SCLASS {
type integer
default {
@func refer
name defaults.timer.sclass
}
}
@args.CARD {
type string
default {
@func refer
name defaults.timer.card
}
}
@args.DEV {
type integer
default {
@func refer
name defaults.timer.device
}
}
@args.SUBDEV {
type integer
default {
@func refer
name defaults.timer.subdevice
}
}
type hw
class $CLASS
sclass $SCLASS
card $CARD
device $DEV
subdevice $SUBDEV
}

timer.default {
type hw
class {
@func refer
name defaults.timer.class
}
sclass {
@func refer
name defaults.timer.sclass
}
card {
@func refer
name defaults.timer.card
}
device {
@func refer
name defaults.timer.device
}
subdevice {
@func refer
name defaults.timer.subdevice
}
}
 
Old 07-19-2004, 02:44 PM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,288

Rep: Reputation: 69
I would do :
1. rm all audio config files and /etc/asound.state too. After that run alsaconf & alsamixer to reset to defaults.
2. remove 'noauto' option in ntfs mount point lines in /etc/fstab
3. is your /etc/rc.d/rc.acpid executable ?
4. you have to be more precise concerning your nvidia pb, I did not get it all.
 
Old 07-20-2004, 01:37 PM   #3
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you!
1.The sound works fine now =) and (2) the ntfs partiotions are mounted at boot time and my users can access them =)

3.The users don't have permission to shutdown the computer =( (how do I fix that)
I haven't test if the computer power off if root run the halt command...I will try it now...
I run chmod 777 /etc/rc.d/rc.acpid ....what is that file for?


3.My nvidia problem is that when I boot up, the prompt is viewed as usual, but when I start X the nvidia driver seems to change the resolution even in the prompt to something not readable...just pixels all over the screen. When I shut down X the pixels are still there all over the screen, so everytime I exit X I can't see what I am typing in the prompt...very frustrating =P
I have tryed to install the nvidia driver again, but I suppose I maybe should delete some files first??....because just reinstall didn't help.
I hope that was a better explianation....

Thank you for all help I can get....
 
Old 07-20-2004, 02:08 PM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,288

Rep: Reputation: 69
For the video prob, try to run xorgconfig and after that, replace Driver "nv" by Driver "nvidia" in your /etc/X11/xorg.conf
 
Old 07-20-2004, 02:41 PM   #5
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Original Poster
Rep: Reputation: 0
The xorgconfig solution did not work, pixels are still there all over the screen =(
And the system does not power off at power down =(
My users are not even able to shutdown the computer, how can I change that?

Thanks for all help.
 
Old 07-20-2004, 02:49 PM   #6
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,288

Rep: Reputation: 69
What is your monitor model and manufacturer ?
try man sudo to learn how to authorize user to run commands as root
 
Old 07-20-2004, 03:31 PM   #7
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,746

Rep: Reputation: 458Reputation: 458Reputation: 458Reputation: 458Reputation: 458
run visudo to change the permissions for users in the /etc/sudoers file
 
Old 07-21-2004, 07:20 AM   #8
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Original Poster
Rep: Reputation: 0
Okay, I tried some sudo yesterday but I did not manage to let my users mount vfat and cdrom =(
I am not sitting at my linux computer now, so I can not give you my sudo file right now...

I have got a samtron 76E monitor and Geforce 4 MX 440 graphics card.
 
Old 07-21-2004, 02:39 PM   #9
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Original Poster
Rep: Reputation: 0
Okey have tryed your solutions but I can not get it to work =(

Still wrong resolution at prompt when X has been started.
No Power off att shutdown
Can not get my users to have su permissions without typing su...
I would like at least mount, umount and shutdown, reboot to work at user level.

Here is my suedo file
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the sudoers man page for the details on how to write a sudoers file.
#

# Host alias specification

# User alias specification

# Cmnd alias specification

# Defaults specification

# User privilege specification
root ALL=(ALL) ALL

# Uncomment to allow people in group wheel to run all commands
#%User ALL=(ALL) ALL

# Same thing without a password
%User ALL=(ALL) NOPASSWD: ALL

# Samples
%User ALL=/sbin/mount,/sbin/umount
%User localhost=/sbin/shutdown -h now
%User localhost=/sbin/shutdown -r now


Thanks for all help! =)
 
Old 07-21-2004, 02:45 PM   #10
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,288

Rep: Reputation: 69
Hep, not good at all

Any user seems to be able to run any command without password on your system. (like delete system files, add bad modules to kernel, configure your sendmail to send spam...) with GNU/Linux network capabilities this is not good.

At least I would do :
#for stopping system
%users localhost = NOPASSWD: /sbin/shutdown -h now
%users localhost = NOPASSWD: /sbin/poweroff

Last edited by keefaz; 07-21-2004 at 02:47 PM.
 
Old 07-22-2004, 12:41 AM   #11
troutwaxer
Member
 
Registered: Jan 2004
Location: Southern California
Distribution: Slackware
Posts: 32

Rep: Reputation: 15
APMD

Quote:
Originally posted by Nihongoga
The xorgconfig solution did not work, pixels are still there all over the screen =(
And the system does not power off at power down =(
My users are not even able to shutdown the computer, how can I change that?

Thanks for all help.
You should be able to activate the APMD (advanced power management daemon) by editing the /etc/rc.modules file. Find the section which reads:

#### APM support ###
# APM is a BIOS specification for saving power using several different
# techniques. This is mostly useful for battery powered laptops.
# /sbin/modprobe apm

and remove the # from "# /sbin/modprobe apm"

T.
 
Old 07-22-2004, 11:41 AM   #12
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Original Poster
Rep: Reputation: 0
Okay, but as you se I have created a new group User not users...so I believe it is not so dangeroes to have my sudor file look like the one I posted before?

The /etc/modprobe apm have I already tried and Yes there is a difference.When I have that line included I have to reboot the machine after power down because the power off button seems to be desable? =P so either I have to reboot or turn the power off by pulling the plug =(
However the power off button at least works when I don't include the apm argument but still I want the computer to turn off whithout me pushing any button =P

And still I have the resolution problem at the prompt... =(

However now I will

comment out %User ALL=(ALL) NOPASSWD: ALL%User ALL=(ALL) NOPASSWD: ALL
that might be a good idea?

Thanks for all help I can get
 
Old 07-22-2004, 12:25 PM   #13
Nihongoga
LQ Newbie
 
Registered: Jul 2004
Distribution: Slack 10
Posts: 18

Original Poster
Rep: Reputation: 0
Okay I found out what the graphic problem in the boot prompt was....I had set Vesa Framebuffert at console in my lilo, I changed that to VGA and graphics are working (but no cool pinguin at bootup though, but I think I survive without that) but still no turning off with the shutdown and the permission problems remains.
Thank you for all help I get, you have already been to very big help for me....I hope someone can help me with the turning off problem too =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
which dma-channel does my soundcard use ? hoernchen Fedora 0 06-10-2005 05:15 AM
C-Media CM8738 6-channel PCI soundcard, setting the number of speakers under FC3 Chutney Linux - Hardware 2 12-28-2004 10:19 AM
how to Capture NTFS with Knoppix 3.6 dagrafixman Linux - Newbie 2 10-25-2004 10:01 AM
Hard drive in primary channel showing in secondary channel Ale Linux - Hardware 2 02-20-2004 11:39 AM
multiplex(channel?) soundcard issue jmr71769 Linux - Hardware 0 12-11-2003 10:44 PM


All times are GMT -5. The time now is 08:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration