LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-26-2010, 03:43 PM   #1
jbs1136
Member
 
Registered: Dec 2008
Location: Spanaway, Wa
Distribution: Kernel Linux 3.6-4.slh.1-aptosid-amd64
Posts: 44

Rep: Reputation: 20
SOLVED - Can't get gksu to work


I have 13.0_64 installed. Found gksu on slackbuild.org. I downloaded it and followed the links to the dependencies and built and installed each one mentioned. gksu built okay and gave me a package which I installed. If I open the run command and enter "gksu thunar" I get this error

Code:
The gksu-run-helper command was not found or is not executable.
I'm lost at this point. Forgot to mention that I am running Xfce.

any help appreciated,

john

Last edited by jbs1136; 01-27-2010 at 09:29 AM. Reason: Solved problem
 
Old 01-26-2010, 04:08 PM   #2
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Have you done a slocate on gksu-run-helper or make sure it is executable if it's on your system?
 
Old 01-26-2010, 04:14 PM   #3
jbs1136
Member
 
Registered: Dec 2008
Location: Spanaway, Wa
Distribution: Kernel Linux 3.6-4.slh.1-aptosid-amd64
Posts: 44

Original Poster
Rep: Reputation: 20
Quote:
Originally Posted by manwichmakesameal View Post
Have you done a slocate on gksu-run-helper or make sure it is executable if it's on your system?
when I run that in terminal it gives no output, just pauses and gives the command line again.

thanks,

john
 
Old 01-26-2010, 06:32 PM   #4
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
So, that means it's not there or the database needs to be updated. Do you still have the package you built? If you do, try to explodepkg your compiled package and see if it's in there anywhere. How did you build the package? Do you have multi-lib compat installed? If you have it installed, you can build the package and the executables will end up in /usr/bin/32. Maybe look there?
 
1 members found this post helpful.
Old 01-26-2010, 06:47 PM   #5
jbs1136
Member
 
Registered: Dec 2008
Location: Spanaway, Wa
Distribution: Kernel Linux 3.6-4.slh.1-aptosid-amd64
Posts: 44

Original Poster
Rep: Reputation: 20
Thanks for the response. I checked in /usr/bin and found gksu only, then /usr/bin/32 and didn't find anything.

I went to slackbuild.org and downloaded gksu and libgksu and the things that were required: ORBit2, gnome-keyring, libgtop, and GConf. I downloaded the source and the slackbuild and then I built and intalled each one. libgksu required libgtop, GConf and gnome-keyring and one of those required ORBit2.

I used ark and looked at the package that was created by gksu and it doesn't contain anything named gksu-run-helper.

I might add that I have just switched to Slackware and 64 bit OS. I tried Fedora for about a week and it was too much like MS. I used Zenwalk for a couple of years and loved it so thought I would try Slackware.

thanks for your help,

john
 
Old 01-26-2010, 07:14 PM   #6
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 214

Rep: Reputation: 64
Sorry, can't help with building gksu.
But I can suggest a possible alternative: ktsuss
 
Old 01-26-2010, 08:40 PM   #7
jbs1136
Member
 
Registered: Dec 2008
Location: Spanaway, Wa
Distribution: Kernel Linux 3.6-4.slh.1-aptosid-amd64
Posts: 44

Original Poster
Rep: Reputation: 20
Thanks for your help. I tried ktsuss but prefer gksu. I did a google search and found that Arch, Mandriva, and Ubuntu are all having problems with it in the 64 bit versions. I'm going to keep trying. I did find the file gksu-run-helper. It was in /usr/lib64/gksu and it is executable. I think the problem is just where to put it. That seems to be the problem with the other distros.

Thanks again for your help.

john
 
Old 01-26-2010, 09:14 PM   #8
devwatchdog
Member
 
Registered: Jan 2010
Posts: 198

Rep: Reputation: 44
Quote:
Originally Posted by jbs1136 View Post
Thanks for your help. I tried ktsuss but prefer gksu. I did a google search and found that Arch, Mandriva, and Ubuntu are all having problems with it in the 64 bit versions. I'm going to keep trying. I did find the file gksu-run-helper. It was in /usr/lib64/gksu and it is executable. I think the problem is just where to put it. That seems to be the problem with the other distros.

Thanks again for your help.

john
I believe I had a similar issue on a 64 bit server running CentOS when I installed gksu on it. I can't check to see what I did as the servers aren't running right now, but I can have one of them booted tomorrow to check out what I did exactly. As I recall, I created a symbolic link to the lib64 directory, probably from the corresponding lib directory. My memory isn't exactly impressive, so I'll have to log into the system to verify it. On my Ubuntu system I see /usr/lib/libgksu/gksu-run-helper, which might be where your system is looking for it.

I thought I'd go through the process of setting up gksu on my 12.2 laptop. Tracked down the dependencies, and went to compiling. Everything was going well until I hit eggdbus, which isn't cooperating very well. it was complaining about glib, which is where I left it.

Oh, what the hell, I'll fire up that laptop and have at it again. What's another library to compile? heh. That one might require more effort than its worth, though.
 
Old 01-26-2010, 10:25 PM   #9
jbs1136
Member
 
Registered: Dec 2008
Location: Spanaway, Wa
Distribution: Kernel Linux 3.6-4.slh.1-aptosid-amd64
Posts: 44

Original Poster
Rep: Reputation: 20
I found references through google search that implied /libgksu/gksu-run-helper was in the wrong libs. I tried linking the app to the different libs and nothing worked. I then cp -R libgksu to both /usr/lib and /lib. I used the run command and did gksu thunar. It worked fine but once I closed thunar it would no longer work. If I used system monitor I found that there were 2 instances of gnome-keyring running. If I closed them both, I could use gksu one time and then had to close gnome-keyring again. I am not sure at this point what is causing the problem. I did find some reference to problems with gnome-keyring through search but not a solution.

Thanks for the suggestions, you were right in it not being where it should. Now I just have to fine how to solve the problem with gnome-keyring. Will work on that tomorrow. My granddaughter is insisting that I stop and play with her can't turn that down.

I'm not sure what you were talking about with eggdbus, that wasn't one of the dependencies that I ran into. I think it was post #5 where I listed the dependencies that I found that had to be installed.

john
 
Old 01-27-2010, 08:48 AM   #10
devwatchdog
Member
 
Registered: Jan 2010
Posts: 198

Rep: Reputation: 44
Quote:
Originally Posted by jbs1136 View Post
I found references through google search that implied /libgksu/gksu-run-helper was in the wrong libs. I tried linking the app to the different libs and nothing worked. I then cp -R libgksu to both /usr/lib and /lib. I used the run command and did gksu thunar. It worked fine but once I closed thunar it would no longer work. If I used system monitor I found that there were 2 instances of gnome-keyring running. If I closed them both, I could use gksu one time and then had to close gnome-keyring again. I am not sure at this point what is causing the problem. I did find some reference to problems with gnome-keyring through search but not a solution.

Thanks for the suggestions, you were right in it not being where it should. Now I just have to fine how to solve the problem with gnome-keyring. Will work on that tomorrow. My granddaughter is insisting that I stop and play with her can't turn that down.

I'm not sure what you were talking about with eggdbus, that wasn't one of the dependencies that I ran into. I think it was post #5 where I listed the dependencies that I found that had to be installed.

john
I read where gnome-keyring runs as a daemon, and apparently for whatever reason your implementation doesn't seem to recognize it is already running. I'd have made a symbolic link between the gksu-run-helper directories. That way if the software was updated, and everything is located in the same location, the symbolic link would point to the proper component. I don't know if that could be an issue regarding your duplicate gnome-keyring issues, but it might. Eh, probably not in reality now that I think about it.

As for eggdbus, I might have gone a little too close to the bleeding edge when I grabbed a version of gnome-keyring. Here's the beginning of a mailing list post I found on eggdbus:

*****************************

* From: David Zeuthen <david fubar dk>
* To: gtk-devel-list gnome org
* Subject: EggDBus
* Date: Sun, 21 Dec 2008 21:48:25 -0500

Hey,

For the past 5 weeks or so, I've been working on a new (as compared to
dbus-glib) D-Bus binding for GObject. The work on this has finally
reached a stage where the code sufficiently complete and documented so I
thought I'd send some mail describing it. The code is here

*****************************

eggdbus is pretty damn recent. I'm going to find a slightly older version of gnome-keyring.
 
1 members found this post helpful.
Old 01-27-2010, 09:00 AM   #11
jbs1136
Member
 
Registered: Dec 2008
Location: Spanaway, Wa
Distribution: Kernel Linux 3.6-4.slh.1-aptosid-amd64
Posts: 44

Original Poster
Rep: Reputation: 20
I started off using a symlink and switched to cp just to speed up the process for me. You are right though and once/if I get this straight I will go back and change to links. Much cleaner method.

I just took everything from slackbuild, figured it was tried and tested and safe to use. There must not be too many people here who use gksu, not a lot found on the forum. Most is suggestions to use ktsuss. I started using gksu with Zenwalk and liked it. I think mainly because it stored the password.

Thanks for your help, I'll post back if I find something new.

john
 
Old 01-27-2010, 09:31 AM   #12
jbs1136
Member
 
Registered: Dec 2008
Location: Spanaway, Wa
Distribution: Kernel Linux 3.6-4.slh.1-aptosid-amd64
Posts: 44

Original Poster
Rep: Reputation: 20
Finally, everything works. Decided to go to the gksu site, downloaded newest versions, uninstalled old version of libgksu and gksu. Edited slackbuild files, rebuilt and installed. No more problems. Ran run command with gksu thunar, closed it and ran again 2 more times. Password was stored and each time it opened up. Much have been a bug and the author fixed it. I marked the thread solved.

Thanks to you both for your help.

john
 
Old 09-05-2011, 09:27 PM   #13
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64 14.0
Posts: 981

Rep: Reputation: 88
Yes, I realize that this post is almost 2 years old but this is still an issue with with the latest libgksu Slackware64 13.37, here is a work around.

Code:
mkdir /usr/lib/libgksu
ln -s /usr/lib64/libgksu/gksu-run-helper /usr/lib/libgksu/gksu-run-helper
Works like a charm.
 
2 members found this post helpful.
Old 07-14-2013, 12:45 AM   #14
armandrix
Member
 
Registered: Nov 2005
Location: Brazil
Distribution: slackware64 -current
Posts: 46

Rep: Reputation: 18
It reborns once again ...

Now with Slackware64 14 -current

Tried to download from home site as suggested, tried symlinks too but nothing works.

There is a little difference in the popup window text: with a fresh install after build, it says: "The gksu-run-helper command was not found or is not executable" right after the call. With a symlink ln -s /usr/lib64/libgksu/gksu-run-helper /usr/lib/libgksu/gksu-run-helper, it first ask the password and than says the same plus -nha: -while expecting: -gksu: waiting.

As far as I know gksu and the libgksu are almost gnome independent, slackpackage maintainer says it's only dependence is libgtop.

I think as posted before that gksu supersedes its alternatives like kdesu, beesu and others with some advantages including keeping the password for a while.

If anybody knows some workaround please help.

Thanks
 
Old 12-07-2013, 08:23 AM   #15
aaditya
Member
 
Registered: Oct 2013
Location: India
Distribution: Slackware
Posts: 87

Rep: Reputation: Disabled
Reply#13 + mancha's patch https://www.linuxquestions.org/quest...ml#post5076069 worked for me on Xfce Slackware 14.1 64 bit.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I install gksu in 12.2 ? tjwoosta Slackware 9 07-28-2009 02:13 AM
gksu with c++ Loser Linux - Software 1 10-23-2008 05:22 PM
gksu not working semtex Linux - Desktop 3 02-16-2007 05:42 AM
gksu and xhost Haz2a Ubuntu 2 09-07-2006 04:35 AM
gksu or alternative? shame Slackware 4 05-09-2006 04:25 PM


All times are GMT -5. The time now is 01:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration