LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   So, I've installed Slackware64-current. Need some configuration help. (http://www.linuxquestions.org/questions/slackware-14/so-ive-installed-slackware64-current-need-some-configuration-help-749735/)

glore2002 08-23-2009 05:03 PM

So, I've installed Slackware64-current. Need some configuration help.
 
Hi back!
Well, finally I've installed Slackware64 on my second HD. I chose the option to install lilo on the first partition of the same disk where slackware is and then I did a chainload as you suggested. It worked fine.

Now, I need some help on this subjects:

a) Internet goes slow. Much slower than in Debian or WinXp. Did any of you faced the same problem?

b) How should I install nVidia driver (for my 7300gt card) and flash player?

c) Can I install software from Slackbuilds or they are just for the 32 version of Slackware?

Thank you!
Glore2002.-

samac 08-23-2009 05:22 PM

a) No, runs at the same speed for me.
b) Nvidia drivers are downloaded from the nvidia homepage, and installed from the command line, as root, in runlevel 3. Flashplayer plugins are available in the /extra directory on the cd/dvd.
c) Good question. Yes and no. As I understand it many slackbuilds will be converted and available when Slackware 13.0 comes out, so that they can compile either 32-bit or 64-bit. Some programs will only ever be 32-bit, you will then need to either have a true multi-lib Slackware 13.0 (see Alien Bob's Wiki), have 32-bit compatibility libraries installed, a chrooted 32-bit environment, an emulated 32-bit environment or a full separate 32-bit install. Or indeed make do without the 32-bit program and run pure 64-bit only. My particular choice is a true multi-lib environment, but that might not suit you.

samac

glore2002 08-23-2009 05:26 PM

Slackware64-current network setup
 
If I go to system settings / network settings and network settings again on the left panel (kde) I get the following message:

"could not parse the xml file ()"

and not available networks are shown and I can't modify any parameter.

I can surf the web but very very slow. I don't know what the problem is but network setting doesn't work.

Thanks in advance,

Bruce Hill 08-23-2009 05:44 PM

Quote:

Originally Posted by glore2002 (Post 3654825)
Hi back!
Well, finally I've installed Slackware64 on my second HD. I chose the option to install lilo on the first partition of the same disk where slackware is and then I did a chainload as you suggested. It worked fine.

Now, I need some help on this subjects:

a) Internet goes slow. Much slower than in Debian or WinXp. Did any of you faced the same problem?

What measurement are you using to determine that internet is much slower than other OSes?

Quote:

Originally Posted by glore2002 (Post 3654825)
b) How should I install nVidia driver (for my 7300gt card) and flash player?

Download the Nvidia driver, then run "sh NVIDIA-Linux-x86_64-185.18.14-pkg2.run" as root in a terminal.

For Flash Player, mnt your DVD and run
Code:

rsync -av /mnt/dvd/extra/flashplayer-plugin/ /tmp/flash/
NB: substitute /mnt/dvd/ for where your DVD is mounted.

Then cd /tmp/flash/ and run:
Code:

sh flashplayer-plugin.SlackBuild --cleanup
which will create /tmp/flashplayer-plugin-10.0.32.18-x86_64-1.txz
So now you run:
Code:

installpkg /tmp/flashplayer-plugin-10.0.32.18-x86_64-1.txz
Quote:

Originally Posted by glore2002 (Post 3654825)
c) Can I install software from Slackbuilds or they are just for the 32 version of Slackware?

Get your extra software from Alien Bob's repository ... he has a good number of 64-bit apps.

And if you want to build some package he doesn't have, use his Alien's SlackBuild Toolkit

mRgOBLIN 08-23-2009 05:44 PM

Run
Code:

netconfig
as root from a terminal.

If you want to use a GUI based config then I'd suggest installing wicd. Please do read and follow the instructions that are there.

glore2002 08-23-2009 06:13 PM

Thanks for the replies. I will now try to install nVidia driver and flashplayer.

Why do I say Internet goes much slower?

a) When I start firefox, it takes a lot to show google search page.
b) If I enter any url, it takes a lot to open that page. This happens with any page. For instance, if I want to go to linuxquestions.org, it takes much much longer than in debian or xp (same computer).

In Debian, if I type any url, It takes me there as it should: Fast.

Bruce Hill 08-23-2009 06:26 PM

Setup your internet with "netconfig" as mRgOBLIN told you in your other thread. ;)

You should not start two threads for the same problem. Report the other one and
ask a moderator to merge them.

After running "netconfig" if it's still slow, post the output of these two cmds:
Code:

egrep -v "(^#|^ *$)" /etc/rc.d/rc.inet1.conf
cat /etc/resolv.conf

and if they look right, I'll give you a script to test the response time of your
DNS servers. (DNS servers change names to IP addresses)

BrZ 08-23-2009 06:42 PM

try to disable ipv6 on Firefox: about:config -> network.dns.disableIPv6 -> true

unSpawn 08-23-2009 07:08 PM

//Merged threadid=749739 into threadid=749735.
 
Eye close to the glass,
Horrified he sees the fly:
Merger Successful.

glore2002 08-23-2009 07:28 PM

Quote:

Originally Posted by unSpawn (Post 3654896)
Eye close to the glass,
Horrified he sees the fly:
Merger Successful.

Thanks for the merging and sorry for opening two threads.

glore2002 08-23-2009 07:34 PM

I setup internet with netconfig and nothing changed. Same for setting Firefox ipv6 to true.

If I restart the computer and go into Debian, everything goes fine. In Slackware it takes too long to access web sites.

Output of egrep -v "(^#|^ *$)" /etc/rc.d/rc.inet1.conf

Quote:

IPADDR[0]="192.168.1.136"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""
GATEWAY="192.168.1.1"
DEBUG_ETH_UP="no"
Output of: cat /etc/resolv.conf

Quote:

search inicioms.com
nameserver 192.168.1.1
Thanks again,

allend 08-23-2009 07:41 PM

Quote:

nameserver 192.168.1.1
Try entering the IP address of your ISP's DNS server.

Bruce Hill 08-23-2009 08:04 PM

If you don't know the IPS's DNS server address, you can either:

check in your router
call them and ask
check in another OS
issue "mtr www.linuxquestions.org" as root and figure out which one's they are

some other easier idea I forget atm ... out the door to study Chinese :D

then take out that top line you now have in /etc/resolv.conf and put them in

colorpurple21859 08-23-2009 08:38 PM

should be able to copy the info that's in your debian resolv.conf to the slackware resolv.conf if that's the problem.

glore2002 08-23-2009 08:45 PM

Quote:

Originally Posted by allend (Post 3654915)
Try entering the IP address of your ISP's DNS server.


This is what I did:

in /etc/resolv.conf I wrote the following:

Quote:

nameserver 200.49.130.26
nameserver 200.49.130.27
nameserver 200.49.130.33
Which are the DNS for my ISP.

Now, Internet seems to run fine. Is it ok what I did?

Thank you!


All times are GMT -5. The time now is 10:53 AM.