View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 05-26-2008, 06:13 PM   #1
LQ Newbie
Registered: Aug 2007
Posts: 8

Rep: Reputation: 0
Unhappy smokeping Can't locate in @INC

I am trying to install smokeping but keep failing because of this error:

Can't locate in @INC (@INC contains: /usr/local/smokeping/lib /usr/local/rrdtool-1.2.0/lib/perl/5.8.8/i486-linux-thread-multi /usr/local/rrdtool-1.2.0/lib/perl/5.8.8 /usr/local/rrdtool-1.2.0/lib/perl /usr/lib/perl5/5.8.8/i486-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i486-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i486-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl .) at /usr/local/smokeping/lib/ line 40.
BEGIN failed--compilation aborted at /usr/local/smokeping/lib/ line 40.
Compilation failed in require at /usr/local/smokeping/lib/ line 9.
BEGIN failed--compilation aborted at /usr/local/smokeping/lib/ line 9.
Compilation failed in require at ./smokeping line 7.
BEGIN failed--compilation aborted at ./smokeping line 7.

Help would be great
Old 05-26-2008, 07:08 PM   #2
Slackware Contributor
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
looks like you don't have installed. It's a perl module.

You could install with CPAN (as root)
perl -MCPAN -e "install Convert::BER"
Be prepared to answer a few questions if you have never run CPAN before.

or you might grab and install it manually from here but you may or may not need to satisfy some dependencies with this method.

SmokePing will likely list the required Perl modules and any other dependencies in the README/INSTALL files so probably best to read those first.
Old 05-27-2008, 01:51 AM   #3
LQ Newbie
Registered: Aug 2007
Posts: 8

Original Poster
Rep: Reputation: 0
perl -MCPAN -e "install Convert::BER"
I did that and still getting the same errors.

I also install the rrdtool since that is what smokeping need and still that app won't work


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Smokeping shows latency increase with new kernel! thekillerbean Linux - Software 2 04-16-2007 03:34 AM
ASN.1 BER file decoding maheshdf Linux - Newbie 1 11-29-2006 06:49 AM
smokeping / cgi error djn3xt Linux - Networking 0 12-09-2005 08:13 AM
BER for wireless link legolas_t Programming 1 08-24-2004 09:36 PM
how to get BER legolas_t Programming 0 06-15-2004 10:59 PM

All times are GMT -5. The time now is 06:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration