LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   SMC 2662W V.2 Wireless not working, Slackware 10.2 (http://www.linuxquestions.org/questions/slackware-14/smc-2662w-v-2-wireless-not-working-slackware-10-2-a-421391/)

BloodiedMind 03-03-2006 06:29 PM

SMC 2662W V.2 Wireless not working, Slackware 10.2
 
I've just started using Slackware 10.2, and am still in the early stages of using Linux. I figured one of the best ways to learn Linux would be to dump myself in it, and Slackware seems to be a good distrubution for everything I've read.

I'm running Slackware 10.2 with the bare.i kernel that autoruns with the boot, and mostly everything is working fine. I just read the pinned thread on Slackware configuration and plan on doing most of that once I get internet.

I have a SMC 2662W V.2 USB wireless adapter
lsusb:
Bus 001 Device 003: ID 0d5c:a002 Belkin F5D6050 802.11b Adapter

Apparently this is controlled by the at76c503a module
at76c503a.berlios.de

I copied the .tar.gz file onto my desktop,
ran tar zvxf at76c503a.tar.gz
And it created the directory fine.
However, when I go in (as root) into the directory and call
"make"
It gives me the error:
at76c503a.c:6708:20: token "=" is not valid in preprocessor expressions.

And won't work. I installed the Kernel headers during the install (A full install), and I'm not entirely sure what the problem is.
Even if I get it to make, and make install I'm not entirely sure how to actually get it to work. Some of the information on that site is a bit confusing.

Any help would be appreciated,
BloodiedMind

lestoil 03-03-2006 07:46 PM

Try http://www.tuxmagazine.com/node/1000167/ Wireless Networking with ndiswrapper
for wireless install and troubleshooting guide.


All times are GMT -5. The time now is 07:15 AM.