LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-27-2012, 02:26 AM   #1
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Rep: Reputation: 17
Question Small font rendering glitch in firefox


Hello

I have this small font rendering glitch in Firefox, this happens very sporadic and is hard to
reproduce (happens on news.google.de or bitcointalk.org forum for example, but also other sites sometimes)

I am having this problem since 13.37 and have no idea what could cause it.
This only happens in Firefox, have never seen it in Thundebird or KDE applications.

Here it happened in a fresh slackware64-14.0 installation inside virtualbox (only guest addons installed everything else is vanilla)
http://i.imgur.com/fZiKU.png

If I mark the text with the mouse or scroll it fixes itself and looks normal again.
No big deal, but is annoying sometimes, so if someone has an idea... would be greatly appreciated.
 
Old 10-27-2012, 06:54 AM   #2
elesmod
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
The same happens to me with Seamonkey, but I've never encountered that in a text on a website, only in the bookmarks toolbar. And as you say, mousing over fixes the problem. I think following this: http://duganchen.ca/writings/slackware/fonts/ might help, but I'm too lazy to do it :P
 
Old 10-27-2012, 07:18 AM   #3
kabamaru
Member
 
Registered: Dec 2011
Location: Greece
Distribution: Slackware
Posts: 276

Rep: Reputation: 133Reputation: 133
Same here. As the OP said, this affects Mozilla-based apps on both 13.37 and 14.0. At first I thought there was something wrong with the freetype patches I used, but it turns out you can notice this in a new stock installation. Unfortunately, it's hard to reproduce.
 
Old 10-27-2012, 11:46 AM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,247

Rep: Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625
I've been getting this for years and I'm at a loss to fix it. Changing window focus also fixes it for me. I use the proprietary nVidia drivers but I'm not sure if that's relevant. I read somewhere that Mac users were getting this as well, though I won't search for the link now. This page suggests that site-owners can work around the problem by changing the opacity. I have just applied some custom CSS in Stylish that changes the opacity of any web page's body element, but since it is very random I have no idea if it fixes the problem or not. If you want to try, here's the CSS (you can verify that it is working by changing the opacity to .5 or something, which should make it somewhat transparent):
Code:
@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document url-prefix(http)
{
    body {
        opacity: .99 !important;
    }
}
If you don't want to use Stylish then you could try placing that code in chrome/userContent.css in your Firefox profile directory.

Here's hoping.
 
Old 10-27-2012, 02:48 PM   #5
kabamaru
Member
 
Registered: Dec 2011
Location: Greece
Distribution: Slackware
Posts: 276

Rep: Reputation: 133Reputation: 133
Actually, the bug affects the application's UI too. For instance, I've noticed this on Seamonkey's bookmarks bar. And like you, I use the nvidia blob.
 
Old 10-27-2012, 02:51 PM   #6
pataphysician
Member
 
Registered: Oct 2012
Posts: 46

Rep: Reputation: Disabled
I've seen this for awhile on my laptop with proprietary nvidia video driver on many different distros. There is only really one site that I get it on, since I read it a lot, I see it everyday on the laptop. I do not see it on my new desktop machine running the ATI Catalyst driver.

I know the OP is running in a VM, but is the host Linux? and running NVidia?

If not, maybe try changing to another video emulator in the VM?
 
Old 10-27-2012, 04:42 PM   #7
pataphysician
Member
 
Registered: Oct 2012
Posts: 46

Rep: Reputation: Disabled
Oh I forgot that when I first installed my new machine I was playing around with Firefox setting for flash performance, and I changed gfx.xrender.enabled to false and then forgot to set it back to the default true. When I changed it back to true now I see the font problem appear, have switched this setting on my Nvidia machine and so far so good, but will have to wait a few days to know for sure. Since someones posted about a problem with websites opacity setting being involved, its possible this fixes the problem because transparency is no longer possible?
 
Old 10-29-2012, 01:30 AM   #8
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Original Poster
Rep: Reputation: 17
Oh interesting, so it is not only me with this problem .

Host is slackware64-current, currently running ATI Radeon with catalyst driver, but it had the NVidia binary blob installed a few months ago...

The css thing is interesting and that it happens on Macs too, I maybe try this as workaround.

Quote:
Originally Posted by pataphysician View Post
Oh I forgot that when I first installed my new machine I was playing around with Firefox setting for flash performance, and I changed gfx.xrender.enabled to false and then forgot to set it back to the default true. When I changed it back to true now I see the font problem appear, have switched this setting on my Nvidia machine and so far so good, but will have to wait a few days to know for sure. Since someones posted about a problem with websites opacity setting being involved, its possible this fixes the problem because transparency is no longer possible?
Thanks for the info about gfx.xrender.enabled. Could really have to do with the transparency, makes sense.
 
Old 11-03-2012, 02:26 PM   #9
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,247

Rep: Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625
For the record, I haven't seen the glitch since I enabled that custom CSS. I still can't say with absolute certainty that it solved it, since it is quite random, but in my normal usage I think I would have seen it over the course of 7 or 8 days of regular browsing. Disabling XRender may have a performance impact elsewhere, though I'm not sure of the impact of setting the opacity of every web page you visit (I haven't noticed any side effects but it is not easily measurable). You should have two possible solutions anyway.

If it affects menu entries then you may be able to hack around it by creating another CSS entry in /path/to/profile/chrome/userChrome.css but I haven't seen it happen and I would have no idea what element to specify as a wrapper (window maybe? menu perhaps? You can see them all using the DOM Inspector).

Last edited by T3slider; 11-03-2012 at 02:31 PM.
 
Old 11-15-2012, 12:18 PM   #10
eoniq
LQ Newbie
 
Registered: Nov 2012
Posts: 7

Rep: Reputation: Disabled
Found on Firefox Arch wiki

Firefox uses ugly fonts for its interface

If the fonts in the menu bar look ugly to you, chances are you're missing better looking fonts for Firefox to use. As a quick remedy, just install Type 1 fonts from the xorg-fonts-type1 package, available in the official repositories.

Firefox uses ugly fonts on certain webpages

When Firefox uses bitmap fonts, it can happen that on certain webpages the fonts are very ugly (compared to Google Chrome for example):

To fix that, just disable bitmap fonts for X:

$ sudo ln -s /etc/fonts/conf.avail/70-no-bitmaps.conf /etc/fonts/conf.d/
 
Old 11-21-2012, 11:26 AM   #11
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Original Poster
Rep: Reputation: 17
Hello,

I think I have some progress here. Updated to FF 17.0, which has some font related bug fixes (http://www.mozilla.org/en-US/firefox...s/buglist.html)
with my custom PGO SlackBuild (found it somewhere here and made it work with newer versions, here if you want: http://www.bitbin.it/JNepTmlp)

The only thing I changed to my earlier builds is --enable-glitz. Now I can't reproduce the font glitch anymore,
so either the new Firefox fixed it or it's because of glitz.

Maybe I can mark this solved now, will watch it for a few days to be sure

EDIT: Have marked the thread solved now, as I can't reproduce it anymore since the update to Firefox 17.0. Thanks to the Firefox people for fixing that bug

Last edited by hotchili; 11-25-2012 at 11:54 PM.
 
Old 11-28-2012, 09:08 AM   #12
elesmod
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
Indeed, I haven't encountered this glitch since the latest update (2.14) to Seamonkey as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Strange font rendering in Firefox after latest updates vdemuth Slackware 5 11-24-2010 01:58 AM
[SOLVED] thin (not small) font on firefox dokie80 Suse/Novell 5 10-21-2010 05:57 AM
firefox 3 font rendering bug? smeezekitty General 10 12-22-2009 01:28 AM
a small glitch jayraj Linux - General 2 10-28-2002 02:32 AM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration