LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-14-2005, 12:12 AM   #1
apocolipse
Member
 
Registered: Oct 2003
Location: Mizzizzileand
Distribution: Slackware & SLAMD64
Posts: 47

Rep: Reputation: 15
Slow internet in Slack


Ok guys, im running a D-link router with a local DHCP. I also have my DSL router which i can snag my own Static IP. My problem is when i use DHCP in slack (both on my notebook PC and my Desktop PC) it runs Extremely slow, comparable to using Windows XP where i experience download rates of 250-300 kB/s (in slack its like 5-10 kB/s). Also when i set up slack to snag a direct IP it will not go out for some reason. I can ping my DNS but nothing else outside local. Any suggestions? This is completly boggeling me because it has previously worked just fine. Thanks

Last edited by apocolipse; 06-14-2005 at 12:18 AM.
 
Old 06-14-2005, 01:44 AM   #2
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
When you set the Slack box to use a static address, did you specify the router's IP address as the gateway? Something like this for /etc/rc.d/rc.inet1.conf:

Code:
# Config information for eth0:
IPADDR[0]="192.168.0.103"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

<snip>

# Default gateway IP address:
GATEWAY="192.168.0.1"
 
Old 06-14-2005, 09:46 AM   #3
apocolipse
Member
 
Registered: Oct 2003
Location: Mizzizzileand
Distribution: Slackware & SLAMD64
Posts: 47

Original Poster
Rep: Reputation: 15
My Static is a regular static, not local. However i did set it up for the gateway (my DSL router) as well as the subnet (255.255.255.248) and DNS. Doing this then rebooting gave me the IP when i did an ifconfig eth0 or regular ifconfig, and i could ping my DNS address w/ success, but no internet connection. Also still getting major lag when using my local DHCP w/ slackware compared to XP
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 05:29 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
slow internet access. too slow!!! iamstinke Linux - Networking 2 01-01-2004 10:46 PM
Slow Network w/ Slack 9.1 MrSmee Slackware 3 11-19-2003 09:30 AM
Why is Slack so slow ? martik Slackware 12 02-10-2003 03:29 PM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration