LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-22-2008, 10:31 AM   #1
Rheibio
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Rep: Reputation: 15
Slow hard disk....


Hi everyone!
Since I installed Linux Slackware my HD seems dead...
I previously used windoes xp, then tried ubuntu... but i fell in love with slackware.
When I first booted form the Slackware dvd I noticed things were going very slowly. I tried to type cfdisk to set my partitions but as soon as i pressed the ENTER button i had a "fatal error". However, i used the fdisk command and everything was ok. I Installed the OS but it took FOREVER.
I tried to copy/transfer/move files but it is really slow...incredibly slow.

Since it didn't happen with other OS and I don't think the HD is damaged, I imagined it could be the kernell. The kernell is loaded as soon as I boot from dvd right?

This only happens on my notebook..

However I'm a newbie in ht linux world... please help!

Last edited by Rheibio; 10-22-2008 at 10:32 AM.
 
Old 10-22-2008, 11:17 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 11,473
Blog Entries: 4

Rep: Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525
Hi,

Welcome to LQ & Slackware!

Which kernel did you select? Hardware specifications? Any error messages in your 'dmesg'?
 
Old 10-22-2008, 12:06 PM   #3
Rheibio
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Original Poster
Rep: Reputation: 15
The Kernel is 2.6.24.5.
Apparently there are no errors when I type dmesg, everything looks normal.
The chipset is Intel Corporation 82801FBM (ICH6M) SATA Controller.
(Obtained from lspci -v)
 
Old 10-22-2008, 12:20 PM   #4
rvo
Member
 
Registered: Sep 2008
Location: Paraguay
Distribution: Slackware
Posts: 31

Rep: Reputation: 15
Maybe you can play a little with 'hdparm' and see what happens. If DMA is off, turn it on with hdparm -d1 /dev/sda where sda is the name of your disk.
 
Old 10-22-2008, 12:27 PM   #5
Rheibio
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Original Poster
Rep: Reputation: 15
The output is
/dev/hdc:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
 
Old 10-22-2008, 12:48 PM   #6
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 930

Rep: Reputation: 96
CHANGES_AND_HINTS.TXT says

Quote:
If you notice extremely long wait times when formatting partitions in the
installer, and you're installing on a Thinkpad that has a SATA drive, it's
possible that the wrong driver is being used, which disables DMA on the drive
(and could happen on other machines). A bit more detail about it is here:
http://www.thinkwiki.org/wiki/Proble...stem_hard_disk
Try passing "hda=noprobe" to the kernel when booting the installer, and it
should use the correct libata driver.
 
Old 10-22-2008, 12:51 PM   #7
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
From CHANGES_AND_HINTS.TXT:
Code:
If you notice extremely long wait times when formatting partitions in the 
  installer, and you're installing on a Thinkpad that has a SATA drive, it's
  possible that the wrong driver is being used, which disables DMA on the drive
  (and could happen on other machines). A bit more detail about it is here:
    http://www.thinkwiki.org/wiki/Problems_with_SATA_and_Linux#No_DMA_on_system_hard_disk
  Try passing "hda=noprobe" to the kernel when booting the installer, and it
  should use the correct libata driver.
Your SATA hard drive is being detected as an IDE hard drive (/dev/hdc) instead of an SATA one (/dev/sd*). You could either reinstall Slackware passing the hda=noprobe parameter both to the kernel when booting off the installer CD/DVD AND as a kernel option for LILO (ie in liloconfig, it asks if you want to pass any extra kernel parameters).

Alternatively, if you don't want to reinstall, you should edit /etc/fstab and change the /dev/hdc lines to /dev/sda (or sdb etc. -- if it is the first and only SATA device and you have no USB devices plugges in, it should be detected as sda). Then you would also have to edit /etc/lilo.conf and add the line
Code:
append="hda=noprobe"
There may already be an append= line -- you could just add the hda=noprobe option to it if it's there. I'm not at my Slackware PC right now, so I can't verify that all information is correct, but I believe it is.
 
Old 10-22-2008, 01:05 PM   #8
Rheibio
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Original Poster
Rep: Reputation: 15
Ok thanks! but... if i type hda=noprobe when i boot from the slackware dvd i get the following error:
could not find kernel image hda=noprobe
same for hdc=noprobe
 
Old 10-22-2008, 01:14 PM   #9
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
You need to supply the kernel name first so type :

Code:
hugesmp.s hda=noprobe
When booting the install DVD.
 
Old 10-22-2008, 01:33 PM   #10
Rheibio
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Original Poster
Rep: Reputation: 15
Wow, new problem. When i boot with the hda=noprobe parameter (someon suggested hda=noprobe hdc=noprobe) it seems that my partitions don't exist anymore. cfdisk gives me a fatal errore while fdisk -l doesn't list any partitions.
fdisk /dev/hda (same thing with hdc and sda) returns me an error and i can't make any operation.
Any suggestions?
 
Old 10-22-2008, 01:59 PM   #11
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 930

Rep: Reputation: 96
It should be /dev/sda (or /dev/sdc) now... Try with those.

Edit: Also, one of hda=noprobe and hdc=noprobe should be enough.

Last edited by Ilgar; 10-22-2008 at 02:00 PM.
 
Old 10-22-2008, 02:06 PM   #12
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Well after booting with the noprobe argument you could try typing

dmesg | grep [sh]d

and looking for lines referring to your hard disk - something with sda or maybe sdc in them. That should show you what your hard disk is being detected as. You could then try applying that to cfdisk i.e. cfdisk /dev/sdc or something. What is the make and model of your machine ? It may be that your hard disk is not using the appropriate driver or something and possibly this problem has been found before.
 
Old 10-22-2008, 02:32 PM   #13
Rheibio
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Original Poster
Rep: Reputation: 15
Thank you Sooooooooooooooooo much for the help you're giving. However it's an Acer Travelmate 4150.
 
Old 10-22-2008, 02:40 PM   #14
secarr
LQ Newbie
 
Registered: Oct 2008
Distribution: Slackware 12.1
Posts: 5

Rep: Reputation: 0
The problem boils down to the kernel is using the IDE driver to communicate with your hard drives, which is why it labels them hda, hdb, etc.

There is a newer driver called libata which supports SATA disks, this is the driver you want to be using. libata however labels disks sda, sdb, sdc, etc.

By giving the boot directive hda=noprobe and hdc=noprobe you're telling the kernel not to probe your hard drives using the IDE driver.
 
Old 10-22-2008, 02:45 PM   #15
Rheibio
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Original Poster
Rep: Reputation: 15
dmesg | grep [sh]d
hda: ide_wait_not_busy() skipped
hdc: ide_wait_not_busy() skipped
hdd: Slimtype DVDRW SOSW-833S, ATAPI CD/DVD-ROM drive
hdd: ATAPI &£X DVD-Rom DVD-R CD-R/RW drive, 2048kB Cache
Driver "sd" needs updating - please use bus_type methods

What does this mean?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting linux files from another hard disk(IDE) to current hard disk(sata) the lord protector Linux - Hardware 5 05-04-2008 12:30 PM
60GB laptop hard disk & 200GB external USB hard disk linux compatibility powah Linux - Hardware 0 03-07-2006 11:55 AM
Very Slow Hard disk lm317t Linux - Hardware 5 11-02-2005 02:06 PM
hard disk tremendously slow boudewijnvweert Linux - Hardware 1 03-23-2005 03:45 AM
External hard disk = slow speed(?) Braveheart1980 Linux - Hardware 12 06-06-2004 09:42 PM


All times are GMT -5. The time now is 10:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration