LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-02-2007, 12:16 PM   #1
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Rep: Reputation: 27
slow boot on laptop


Ok, this is starting to bother me now.
Slackware 12 on Toshiba Tecra M2.
Boot hangs for a while, close to a minute at the udevtrigger.
Where do I look to troubleshoot this?

The other thing is.
When I turn off the wireless radio with the hardware switch, the Intel 2200 driver still tries to load and go about its business as usual.
Is there a way to tell it to f*** off when the radio is off?
As you can see I'm getting frustrated with this.

Also, and perhaps most importantly.
Why is Slackware's hardware detection not set up for laptop's frequency scaling?
This is really insane and I'm surprised that Slackware doesn't even attempt to set up any kind of power saving configuration.
It's actually very irresponsible not to enable the relevant modules.
Basically the Centrino CPU is COOKING at 2Gz non stop when it should be slowing down to 800Mz when there is no load on it.
I don't expect to have everything configured out of the box, and that's one nice thing about Slackware I like, that it doesn't try to micromanage every detail, but some basic hardware configuration should really be done.
Especially when it involves cooking the cpu in a rather expensive laptop.

I've already configured all the relevant bits for the power saving after googling and reading for two day so I don't need help with that any more. Always nice to read about cpu_governors and freq_scaling. I'm sure I'm a better man now. But it's really a job of the distro and not the user to configure this basic stuff.
 
Old 09-02-2007, 12:36 PM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
I've already configured all the relevant bits for the power saving after googling and reading for two day so I don't need help with that any more. Always nice to read about cpu_governors and freq_scaling. I'm sure I'm a better man now. But it's really a job of the distro and not the user to configure this basic stuff.
Nice..could you perhaps kindly provide a small "howto" on how you did this, or some notes at least. I'm sure it would be of help and use for other users..

Not sure what's up with udev. The wireless thing you mentioned is a little irritating in my opinion also, I haven't done anything about it (yet) but I guess it wouldn't be bad to edit the init scripts a little and add a quick test there to see if the wireless is powered or not, and if not, skip the loading part that's useless.
 
Old 09-02-2007, 12:36 PM   #3
ghostdancer
Member
 
Registered: Apr 2002
Distribution: Slackware
Posts: 266

Rep: Reputation: 30
Since it load wireless driver, it is very likely trying to make DHCP request. Have you disabled the DHCP in the rc.inet1.conf file? Most of the time, it is the DHCP detection that slow down the boot process.
 
Old 09-02-2007, 01:03 PM   #4
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
Since it load wireless driver, it is very likely trying to make DHCP request. Have you disabled the DHCP in the rc.inet1.conf file? Most of the time, it is the DHCP detection that slow down the boot process.
It is, but it's also a trouble if you disable it, and every time you do want to use net will have to re-enable it (or run it manually - kind of defeats the meaning of "automatic" loading when you need it). I myself prefer to have it enabled. Setting the timeout to a small value could help, but would cause trouble in case of very slow responding network..so a test to tell if the wifi card is powered or not is definitely better.

I would get into this (will later, if no answer is found), but right now I'm interested in finding a clean and short way of detecting multiple duplicates of files on a filesystem..there are some scripts already here at LQ, but they're all either long, messy, non-general or everything at once. There has to be a simpler way
 
Old 09-02-2007, 01:15 PM   #5
ghostdancer
Member
 
Registered: Apr 2002
Distribution: Slackware
Posts: 266

Rep: Reputation: 30
I disabled it.

However, I still able get it auto-detecting my network, since I am using Dropline GNOME.
 
Old 09-02-2007, 01:22 PM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 292Reputation: 292Reputation: 292
I've noticed slow DCHP detection since Slack 11 or so. I have tried playing with timeout options, but it makes little difference on my system.

I'm using a netgear NIC with cable modem/internet. If a solution to this is found I would be very interested. I've also noticed that running '/etc/rc.d/rc.inet1 restart' (or stop start) later will result in pretty much instantaneous reaction to the command. It seems only on boot that it slows down, which makes me wonder if something else in the boot is affecting it. I've also noticed that at boot my MAC and IP address are no longer printed to stdout.
 
Old 09-03-2007, 05:37 AM   #7
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by b0uncer View Post
Nice..could you perhaps kindly provide a small "howto" on how you did this, or some notes at least. I'm sure it would be of help and use for other users..

Not sure what's up with udev. The wireless thing you mentioned is a little irritating in my opinion also, I haven't done anything about it (yet) but I guess it wouldn't be bad to edit the init scripts a little and add a quick test there to see if the wireless is powered or not, and if not, skip the loading part that's useless.
Ok, I'll write up my notes and post them. The power saving config seems to work well for me now.
But I'm still lost as to the slow boot. It just hangs, sometimes for a while sometimes it seems like forever (depends if I'm in a hurry )

I was hoping that someone new about some kind of switch or option that can be passed to the ipw2200 kernel module so it doesn't do anything when the radio is turned off.
When I have time I'll try to ask the ipw2200 devs. They would be the ones with the knowledge about this.
 
Old 09-03-2007, 05:47 AM   #8
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by ghostdancer View Post
Since it load wireless driver, it is very likely trying to make DHCP request. Have you disabled the DHCP in the rc.inet1.conf file? Most of the time, it is the DHCP detection that slow down the boot process.
Nope, not in Slackware 12.
The dhcp has a 10 second timeout if no carrier is detected on the interface.

BUT, interestingly, running rc.inet1 (restart, reload, whatever) will bring up the interface but does not run dhcpd, it does not get an ip address from dhcp server!
This is very annoying!
And I think it's bug in Slackware 12 network script.
Can someone confirm this?

This is my typical scenario.
I come to a place with wifi with wpa.
So I scan with the wpasupplicant gui and connect to the access point, enter password and all is good.
Then I run ./rc.inet1 restart.
So it brings up the interface for the wireless connection but it does not run dhcp to get an ip address.
I have to run it manually and then I have a connection with an ip address.
Oh well, at least I get to impress people with "cryptic computer commands" and they think I'm some kind of computer genius
 
Old 09-03-2007, 06:45 AM   #9
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
Quote:
BUT, interestingly, running rc.inet1 (restart, reload, whatever) will bring up the interface but does not run dhcpd, it does not get an ip address from dhcp server!
This is very annoying!
And I think it's bug in Slackware 12 network script.
Can someone confirm this?
Actually no, it works fine for me.
 
Old 09-03-2007, 09:21 AM   #10
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
Yeah DHCP works fine for me too...

and to the OP, what scaling governor did you choose that made you happy? I have been playing around there for quite some time but haven't found any particular config that worked well for me...
 
Old 09-03-2007, 11:11 AM   #11
dennisk
Member
 
Registered: May 2004
Location: Southwestern USA
Distribution: CentOS
Posts: 279

Rep: Reputation: 30
Slackovado,

Take a look at KWiFiManager

Quote:
The KWiFiManager suite is a set of tools which allows you to manage your wireless LAN Network Interface card (PC-Card, PCI or miniPCI) under the K Desktop Environment. It provides information about your current connection and lets you set up up to ten independent configurations and use up to four configrations that are pre-configured by distribution-specific scripts. If you are in a place where none of your preconfigured networks is available, you can also dynamically switch to an available network with almost no configuration effort.
dennisk
 
Old 09-04-2007, 10:26 AM   #12
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
Quote:
Originally Posted by Slackovado View Post
BUT, interestingly, running rc.inet1 (restart, reload, whatever) will bring up the interface but does not run dhcpd, it does not get an ip address from dhcp server!
Do you have USE_DHCP set to yes for your interface in rc.inet1.conf?

Brian
 
Old 09-04-2007, 12:43 PM   #13
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
I have found that my laptop boots significantly longer and hangs at the udev line if I have any peripherals plugged in, eg. usb stick, external drive, usb mouse, etc. If I have everything unplugged at boot it goes faster.

Brian
 
Old 09-05-2007, 07:04 AM   #14
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by duryodhan View Post
Yeah DHCP works fine for me too...

and to the OP, what scaling governor did you choose that made you happy? I have been playing around there for quite some time but haven't found any particular config that worked well for me...
On my centrino 2Gz I'm mostly using the "ondemand" governor.
It seems to be fairly responsive to the load demands.
But often when I have the computer just sitting there for a while I switch to the "powersaving" governor, but I'm not really noticing much difference.
 
Old 09-05-2007, 07:06 AM   #15
Slackovado
Member
 
Registered: Mar 2005
Location: Burnaby, BC, Canada
Distribution: Slackware 14 32bit, Debian, Arch
Posts: 213

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by Tux-Slack View Post
Actually no, it works fine for me.
Ok, I tried it today again and it indeed seems to work fine.
I think I was running wpa_supplicant and that didn't run dhcp automatically.
Running rc.inet1 does activate everything properly though.
Sorry. My bad.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slow to boot, slow dns resolution after host name change FC5 edavis6678 Linux - Newbie 3 01-03-2007 06:26 PM
Old slow laptop scales Linux - Newbie 13 05-20-2006 12:40 PM
Laptop Too Slow? zgauthier Linux - Laptop and Netbook 13 01-08-2005 11:44 PM
A distro for a slow laptop? evilwang Linux - Distributions 5 11-19-2004 05:25 PM
My laptop is too slow for RH 9.0 dev8080 Linux - Newbie 12 10-13-2003 01:37 AM


All times are GMT -5. The time now is 09:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration