LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-05-2008, 12:27 AM   #1
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
slim login problem - anyone succeed in configuring slim?


dear friends
my machine is old and now i am running xfce4, and i just want to get rid of kdm, and think i should try slim
http://slim.berlios.de/index.php

i tried putting
Code:
x1:4:respawn:/usr/bin/slim >& /dev/null
in /etc/inittab and it is showing problem

did any one succeed in running slim in slack12?

Last edited by rkrishna; 02-05-2008 at 12:30 AM.
 
Old 02-05-2008, 01:21 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Do you haveth fox libraries compiled and installed. slim uses the fox libs.

For an easier and better alternative use wdm which just needs windowmaker installed (for the libs) which is already part of slackware. slim is a fox-libs clone of wdm anyway, so if you like slim you shoulf like wdm.

Get sources and/or package here:
http://distro.ibiblio.org/pub/linux/...inDisplay/wdm/
 
Old 02-05-2008, 01:52 AM   #3
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
slim was soo slim
let me try wdm then
and i will come back soon with the results
thank you

Note: shall i install amigo tgzs?
 
Old 02-05-2008, 03:39 AM   #4
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Yes, I think the package I have will work for you. If not, you can try re-compiling it as a first test of src2pkg once we get that working correctly(from the anyone with athlon-xp) thread.

This is not the correct thing to do:
Code:
x1:4:respawn:/usr/bin/slim >& /dev/null
Instead, you should edit /etc/rc.d/rc.4 and change the entry fro using xdm to use wdm instead. You'll have to remove the kdm first or it will continue to be used since it is searched for first. Or you can paste the code below into an empty text file and then rename it to rc.4. Save a copy of your old rc.4 file and then place this in /etc/rc.d/

Code:
#! /bin/sh
#
# rc.4		This file is executed by init(8) when the system is being
#		initialized for run level 4 (XDM)
#
# Version:	@(#)/etc/rc.d/rc.4	2.00	02/17/93
#
# Author:	Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
# At least 47% rewritten by:  Patrick J. Volkerding <volkerdi@slackware.com>
#

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."


# If you have WDM, Then great! :
if [ -x /usr/bin/wdm ]; then
  exec /usr/bin/wdm -nodaemon 1> /dev/null
fi

# Try to use GNOME's gdm session manager.  This comes first because if
# gdm is on the machine then the user probably installed it and wants
# to use it by default:
if [ -x /usr/bin/gdm ]; then
  exec /usr/bin/gdm -nodaemon
fi

# Someone thought that gdm looked prettier in /usr/sbin,
# so look there, too:
if [ -x /usr/sbin/gdm ]; then
  exec /usr/sbin/gdm -nodaemon
fi

# Not there?  OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
  exec /opt/kde/bin/kdm -nodaemon
fi

# If all you have is XDM, I guess it will have to do:
if [ -x /usr/X11R6/bin/xdm ]; then
  exec /usr/X11R6/bin/xdm -nodaemon
fi

# error
echo
echo "Hey, you don't have KDM, GDM, WDM; or XDM.  Can't use runlevel 4 without"
echo "one of those installed."
sleep 30

# All done.
 
Old 02-05-2008, 07:15 AM   #5
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
any special option specific for athlon xp ?

i simply tried src2pkg wdm-1.28.tar.gz
or shall i try
src2pkg -a i686 wdm-1.28.tar.gz
 
Old 02-05-2008, 08:49 AM   #6
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Ok, so you are using src2pkg -good.
At the moment the athlon support won't be working but we'll work on that. Still you should have no problem getting a package, but you#ll want to pass a couple of options to configure to get a better package:

src2pkg -e='--localstatedir=/var --disable-pam \
--with-wdmdir=/etc/X11/wdm --with-fake-home=/var/run/wdm \
--enable-exitlogin --enable-aafont' wdm-1.28.tar.gz

That should do the trick.
You can test the thing easily just by booting up normally in runlevel 3 and then typing 'wdm' after logging in as root. If you like what you see, then do the edit I suggested on your rc.4 file and then boot up into runlevel 4 to use it.
if you want to stcik with it, I'll try over the next few days to get together the materials I have for the way I use it which makes it really easy and slick to use. I even have it running xpenguins so you get animated penguins to go with the login screen :-) My 4-year-old son loves em! I created a really flexible system for wdm which lets you have autostart files for each window manager without having to edit the system-wide initrc. And I've written a configuration tool which lets you put all the options into just one configuration file -it's really pretty slick and versatile!
 
Old 02-06-2008, 02:54 AM   #7
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
Cool

Quote:
Still you should have no problem getting a package, but you#ll want to pass a couple of options to configure to get a better package:
tht did it
the configure option had done the job, earlier it was showing missing libraries error message(with src2pkg wdm.xxx..x.x)

this one worked, thank you for the great explanatory posts
now i dont want kdm

now the funny part is there is no xfce4 option in wdm
and no themes, looks like we are working with slackware8
later on i will beautify it

Edit : editted /etc/X11/wdm/wdm-config added Xfce and logos

regards

Last edited by rkrishna; 02-06-2008 at 04:16 AM.
 
Old 02-06-2008, 03:39 AM   #8
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
I was just looking this morning at my other source directory for the modified wdm. It does include xfce and nearly any other window manager you have installed. The yources and package contain quite many files and lots of changes that make it work really smooth. Because of this, I need to take a little time to arrange the sources so that you can work with them more easily, before I upload them. I'll let you know when they are ready. Since you like what you see, I'll try to get this done soon so you can enjoy wdm and use it more effectively.
Meanwhile, I'll include here a copy of the /etc/X11/wdm/Xclients file which should give you an entry for xfce:

Code:
#!/usr/bin/bash -login
# /etc/X11/wdm/Xclients.in

########################################################################
# This version of Xclients is intended for use with wdm.               #
########################################################################

# try to find executable in PATH
FindInPath()
{
	prog=$1
	shift
	result=
	for p in `echo $PATH|tr ':' ' '`; do
		if test -e $p/$prog; then
			result=$p/$prog
			break;
		fi
	done
}

# these files are left sitting around by TheNextLevel.
rm -f $HOME/Xrootenv.0
rm -f /tmp/fvwmrc* 2>/dev/null

# Use this to autostart applications before *any* window manager
# Most programs should be started in the background with 'progname &'
if [ -r $HOME/.Xstartup.all ] ; then
        # source the file and then come back
	source $HOME/.Xstartup.all
fi

WINMGR_NAME=
if test -z "$WINMGR_NAME"; then
	WINMGR_NAME="UserDefined"
fi

# First thing - check the user preferences
if [ -f $HOME/.wm_style ] ; then
	WMSTYLE=`cat $HOME/.wm_style`
	case "$WMSTYLE" in 
#
# first, a general purpose entry:
	$WINMGR_NAME*)
		# startup a window manager
		WINMGR_PATH=
		if test -x "$WINMGR_PATH" ; then
	        	echo Starting $WINMGR_NAME >$HOME/.xwm.msgs
			exec $WINMGR_PATH >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	wmaker*|WindowMaker*)
		# startup WindowMaker
		WMAKER_PATH=/etc/X11/xinit/xinitrc.wmaker
		if ! test -x $WMAKER_PATH ; then
			FindInPath $WMAKER_PATH
			if test -n "$result" -a -x "$result"; then
				WMAKER_PATH="$result";
			fi
		fi
		if [ -r $HOME/.Xstartup.wmaker ] ; then
			# source the file and then come back
			source $HOME/.Xstartup.wmaker
		fi
		if test -x $WMAKER_PATH ; then
			echo Starting WindowMaker >$HOME/.xwm.msgs
			env > "$HOME"/Xrootenv.0
			exec $WMAKER_PATH >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	afterstep*|Afterstep*|AfterStep*)
		# we have to start up afterstep
		AFTERSTEP_PATH=afterstep
		if ! test -x $AFTERSTEP_PATH ; then
			FindInPath $AFTERSTEP_PATH
			if test -n "$result" -a -x "$result"; then
				AFTERSTEP_PATH="$result";
			fi
		fi
		if [ -r $HOME/.Xstartup.afterstep ] ; then
			# source the file and then come back
			source $HOME/.Xstartup.afterstep
		fi
		if [ -x $AFTERSTEP_PATH -a -f /usr/share/afterstep/wmconfig.conf ] ; then
			mkdir -p $HOME/GNUstep/Library/AfterStep
			wmconfig --output=afterstep --directories /usr/share/afterstep/wmconfig.conf 2>/dev/null
			env > "$HOME"/Xrootenv.0
			# if this works, we stop here
			eval "exec $AFTERSTEP_PATH" > "$HOME"/.AfterStep-errors 2>&1
		fi
		;;

	blackbox*|BlackBox)
		# startup blackbox
		BLACKBOX_PATH=blackbox
		if ! test -x $BLACKBOX_PATH ; then
			FindInPath $BLACKBOX_PATH
			if test -n "$result" -a -x "$result"; then
				BLACKBOX_PATH="$result";
			fi
		fi
		if [ -r $HOME/.Xstartup.blackbox ] ; then
			# source the file and then come back
			source $HOME/.Xstartup.blackbox
		fi
		if [ -x $BLACKBOX_PATH ] ; then
			echo Starting BlackBox >$HOME/.xwm.msgs
			exec $BLACKBOX_PATH >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	fluxbox*|FluxBox)
		# startup fluxbox
		FLUXBOX_PATH=/etc/X11/xinit/xinitrc.fluxbox
		if ! test -x $FLUXBOX_PATH ; then
			FindInPath $FLUXBOX_PATH
			if test -n "$result" -a -x "$result"; then
				FLUXBOX_PATH="$result";
			fi
		fi
		if [ -r $HOME/.Xstartup.fluxbox ] ; then
			# source the file and then come back
			source $HOME/.Xstartup.fluxbox
		fi
		if [ -x $FLUXBOX_PATH ] ; then
			echo Starting FluxBox >$HOME/.xwm.msgs
			exec $FLUXBOX_PATH >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	icewm*|IceWM)
		ICEWM_PATH=/etc/X11/xinit/xinitrc.icewm
		if ! test -x $ICEWM_PATH ; then
			FindInPath $ICEWM_PATH
			if test -n "$result" -a -x "$result"; then
				ICEWM_PATH="$result";
			fi
		fi
		if [ -r $HOME/.Xstartup.icewm ] ; then
			# source the file and then come back
			source $HOME/.Xstartup.icewm
		fi
		if [ -x $ICEWM_PATH ] ; then
			echo Starting icewm >$HOME/.xwm.msgs
			exec $ICEWM_PATH >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	xfce*|XFCE*|XfCE)# startup XFCE
		# startup XFCE
		XFCE_PATH=xinitrc.xfce
		if ! test -x $XFCE_PATH ; then
			FindInPath $XFCE_PATH
			if test -n "$result" -a -x "$result"; then
				XFCE_PATH="$result";
			fi
		fi
		if [ -r $HOME/.Xstartup.xfce ] ; then
			# source the file and then come back
			source $HOME/.Xstartup.xfce
		fi
		if test -x $XFCE_PATH ; then
			echo Starting XFCE >$HOME/.xwm.msgs
			env > "$HOME"/Xrootenv.0
			exec $XFCE_PATH >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	xsession*)
		# startup xsession
		XSESSION_PATH=xsession
		if ! test -x $XSESSION_PATH ; then
			FindInPath $XSESSION_PATH
			if test -n "$result" -a -x "$result"; then
				XSESSION_PATH="$result";
			fi
		fi
		if [ -x $XSESSION_PATH ] ; then
			echo Starting xsession >$HOME/.xwm.msgs
			exec $XSESSION_PATH -console >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	xinitrc*|GlobalDefault*|Global-xinitrc)
		# startup xinitrc
		XINITRC_PATH=/etc/X11/xinit/xinitrc
		if ! test -x $XINITRC_PATH ; then
			FindInPath $XINITRC_PATH
			if test -n "$result" -a -x "$result"; then
				XINITRC_PATH="$result";
			fi
		fi
		if [ -x $XINITRC_PATH ] ; then
			echo Starting /etc/X11/xinit/xinitrc >$HOME/.xwm.msgs
			exec $XINITRC_PATH -console >>$HOME/.xwm.msgs 2>&1
		else
			echo No /etc/X11/xinit/xinitrc found >$HOME/.xwm.msgs
		fi
		;;

	UserDefault*|User-xinitrc)
		# startup xsession
		USER_XINITRC_PATH=$HOME/.xinitrc
		if [ -e $USER_XINITRC_PATH ] ; then
			if [ -r $HOME/.Xstartup.xinitrc ] ; then
				# source the file and then come back
				source $HOME/.Xstartup.xinitrc
			fi
			echo Starting Users .xinitrc >$HOME/.xwm.msgs
			. $USER_XINITRC_PATH -console >>$HOME/.xwm.msgs 2>&1
		fi
		;;

	startkde*|kde*|KDE*)
		# startup kde
		STARTKDE_PATH=xinitrc..kde
		if ! test -x $STARTKDE_PATH ; then
			FindInPath $STARTKDE_PATH
			if test -n "$result" -a -x "$result"; then
				STARTKDE_PATH="$result";
			fi
		fi
		if [ -r $HOME/.Xstartup.kde ] ; then
			# source the file and then come back
			source $HOME/.Xstartup.kde
		fi
		if [ -x $STARTKDE_PATH ] ; then
			echo Starting kde >$HOME/.xwm.msgs
			exec $STARTKDE_PATH -console >>$HOME/.xwm.msgs 2>&1
		fi
		;;
    esac
fi

# first, find an M4-enabled config file (such as 
# the one from AnotherLevel) for fvwm2 or fvwm95.
RCFILE=""
for tryfile in "$HOME/.fvwm2rc.m4" "/etc/X11/AnotherLevel/fvwm2rc.m4"; do
    if [ -f "$tryfile" ]; then
        RCFILE="$tryfile"
        break
    fi
done

# if it really exists, use it; if not, fvwm2 or fvwm95 will
# automagically look for a config file in the regular places.
if [ -n "$RCFILE" ]; then
    FVWMOPTIONS="-cmd 'FvwmM4 -debug $RCFILE'"
else
    FVWMOPTIONS=""
fi

# TheNextLevel is supposed to work
# with both fvwm95 and fvwm2
# (try fvwm95 first, then fvwm2).
for FVWMVER in 95 95-2 2; do
    if [ -n "$(type -path fvwm${FVWMVER})" ]; then
        env > "$HOME"/Xrootenv.0
        # if this works, we stop here
        eval "exec fvwm${FVWMVER} ${FVWMOPTIONS}" > "$HOME"/.FVWM${FVWMVER}-errors 2>&1
    fi
done

# gosh, neither fvwm95 nor fvwm2 is available;
# let's try regular fvwm (AnotherLevel doesn't work with fvwm1).
if [ -n "$(type -path fvwm)" ]; then
    # if this works, we stop here
    exec fvwm
fi

# No other window or session manager found.
# Use twm as a last resort.
xterm &
exec twm
You can replace your existing file with this one and see if that works. I can't promise that it will, though, because it is part of the modified installation that I use. But, try it if you like.
 
Old 02-06-2008, 04:20 AM   #9
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
i went for a coffee and came back i editted the /etc/X11/wdm/wdm-config and i added xfce here
Code:
DisplayManager*wdmWm:           WindowMaker:BlackBox:KDE
also i enabled the line with "Stars.jpg" and "Eagle.xpm"
Code:
! DisplayManager*wdmBg:         none
DisplayManager*wdmBg:           solid:RoyalBlue
! DisplayManager*wdmBg:         dgradient:RoyalBlue,FireBrick,Black
! DisplayManager*wdmBg:         hgradient:RoyalBlue,FireBrick,Black
! DisplayManager*wdmBg:         vgradient:RoyalBlue,FireBrick,Black
! DisplayManager*wdmBg:         pixmap:/usr/share/pixmaps/wdm/Stars.jpg
!
! optional pixmap for logo
! DisplayManager*wdmLogo:  /usr/share/pixmaps/wdm/Eagle.xpm
now i have to test

regards rkrishna
 
Old 02-06-2008, 04:42 AM   #10
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
i was being silly :-), now i added xdce part of Xclients to my Xclients file. let me check if it works or not

Edit: i should copy ur Xclients and check. because simply adding the relevent part of xfce didnt worked or i didnt copied properly
Quote:
You can replace your existing file with this one and see if that works.
not working whatever xwindow i choose it is login into Twm

no kde, no blackbox

i will try to fix it thank you

Last edited by rkrishna; 02-06-2008 at 05:04 AM.
 
Old 02-06-2008, 05:59 AM   #11
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Lets try doing it this way. I've uploaded my directory with the 'hacked' version of wdm. Dont try building it from source just yet since things need to be fixed up to make that easier.
But, there is a tgzp ackage there which should work just fine for you since you are running Slack-11.0.

You'll find that here:
http://distro.ibiblio.org/pub/linux/...jects/AFX-wdm/

Be sure to download the README there also as it will tell you more about how to use the modified version. When you install the package it will automatically configure itself to use any of the main window managers you have installed. wdm uses several configuration files for different features. But my 'hacks' have provided a configuration tool (/etc/X11/wdm/ConfigureWDM). Using this tool allows you to make most configuration changes just by editing the file /etc/wdm.conf and then running the program /etc/X11/wdm/ConfigureWDM.

I'll explain any questions you have about using it.
 
Old 02-06-2008, 06:35 AM   #12
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
Quote:
fine for you since you are running Slack-11.0.
now i am using slack 12 on an old machine in office and in the signature the machine is my home machine

thank u let me try it
 
Old 02-06-2008, 06:54 AM   #13
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
Talking worked., all those tuxes moving flying .. thank you

i just installed your package and it is working nicely without any additional configuration

i think i should change the name of the thread to be slim --> wdm
the funny part is, we started from slim and endedup configuring something else
thank you once again to your patience and help
regards rkrishna
 
Old 02-06-2008, 07:16 AM   #14
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Glad that it is working for you. I always take note of references to slim as it is a clone of wdm. wdm was originally based on xdm but no longer includes any xdm code. But the config files and names are still mostly the same as for xdm.

My AFX-wdm is one of my favorite little hacks. Since you have started using it, I'll tell you about an undocumented trick that I built in. This is mostly useful if you someitmes run different window managers.
AFX-wdm can use autostart files to start programs to run on your desktop. You can set up one file which will start the same programs for any window manager or you can set up individual files with different options for each window manager. This system allows you to autostart programs without having to edit your system-wide xintrc files.

For instance, I use WindowMaker with ROX-Filer and 'taskbar' as my main desktop. So, when I want to use Window Maker I want the Filer and taskbare panel to be started automatically. I do this by cerating a hidden file called '.Xstartup.wmaker' in my $HOME directory. Inside it has these lines:
rox -p=Default
taskbar -amx &

For icewm I have a file called '.Xstartup.icewm' witht these lines:
icewmtray &
rox -p=Default

To use one file with the same entries for all window managers just name it '.Xstartup.all'
Note that usually all entries will have an '&' at the end in order to background the process. ROX-Filer doesn't need this as it backgrounds itself.

be sure to read the /etc/wdm.conf file for tips on how you can change settings if you want to -like changing the images displayed.
 
Old 02-06-2008, 07:34 AM   #15
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Original Poster
Rep: Reputation: 32
Quote:
wdm was originally based on xdm
i found this in wdm home page
Quote:
be sure to read the /etc/wdm.conf file for tips on how you can change settings if you want to -like changing the images displayed.
sure i will, anyways i am not going to change that pengus stuff, looks good.
and let me make more changes in other places, have to do a lot of configuration in slack 12. then i wil beautify my wdm,
thank you
 
  


Reply

Tags
package, slackware, slim


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to slim Linux? veeruk101 Linux - General 14 08-28-2009 08:35 PM
Slim down Kaffeine Ashrack Linux - Software 5 04-09-2007 03:48 PM
USB Scanner Genius ColorPage-HR7X Slim problem theMagus Linux - Hardware 1 12-15-2006 02:47 PM
SLiM & WDM problem soupnazi.tar.gz Slackware 1 07-07-2006 05:28 AM
New Slim Distro's available! therion12 Linux - Distributions 5 01-15-2002 09:42 AM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration