LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-08-2010, 05:08 AM   #1
Faustphor
LQ Newbie
 
Registered: May 2010
Posts: 13

Rep: Reputation: 0
Sleep reboots/kills computer


I have been experiencing a weird problem.

It seems as though using sleep in KDE4 likes to power the system down rather than suspending to RAM. The computer gives all the signs that it is sleeping (power light turns to orange, monitor shuts off, etc). It experiences this problem regardless of what method I use to suspend to RAM (using the GUI menu, shutting the laptop lid, etc). When it "reboots" it doesn't start killing processes and the like. It seems to go to sleep and when awakened it comes back at the VAIO boot splash screen.

The weirdest part is that this problem starts when it wants. My most recent install of Slackware 13.1 was working fine (I recompiled the kernel, multilib, edited inittab, and installed the prop ATI drivers) for a week and then I was sitting in class shut the lid, tried turning resuming right away and the boot screen came up. It never did return to normal operating behavior.

Any ideas?
 
Old 09-08-2010, 10:16 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,409

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Have you updated your /etc/lilo.conf to point to the new kernel, checked the resume partition (and also rebuilt your initrd if you use one) and rerun lilo?
 
Old 09-08-2010, 11:08 PM   #3
Faustphor
LQ Newbie
 
Registered: May 2010
Posts: 13

Original Poster
Rep: Reputation: 0
I have tried the other suggestions before.

I will try checking the resume partition.

Thanks.

Last edited by Faustphor; 09-08-2010 at 11:17 PM.
 
Old 09-11-2010, 09:45 PM   #4
Faustphor
LQ Newbie
 
Registered: May 2010
Posts: 13

Original Poster
Rep: Reputation: 0
Ok. I added a resume line to lilo, recompiled the kernel to make sure I set the default resume partition, and made sure certain things were built into the kernel.

No luck. It seemed as though it was working after recompiling the kernel. It was letting the computer go to sleep and resume flawlessly until I shutdown the computer once and after that it has gone back to resume to the Vaio bootsplash and LILO.
 
Old 09-12-2010, 02:13 PM   #5
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
Have similar behaviour on 2.6.35.4 64bit. Have no idea what is going on. I also have a Sony vaio. On earlier kernels (prior to 2.6.35.x) didn't have this issue. I have ATI graphics in it. Anyone has any ideas?
 
Old 09-12-2010, 08:59 PM   #6
Faustphor
LQ Newbie
 
Registered: May 2010
Posts: 13

Original Poster
Rep: Reputation: 0
I found this in the Fedora forums.

http://fedoraforum.org/forum/showthread.php?p=1389455

That is the only solution I have found. It is either stay under 2.6.35 or use 2.6.35-rc3.

It seems to only affect Sony laptops.

Last edited by Faustphor; 09-12-2010 at 09:02 PM.
 
Old 09-13-2010, 03:53 AM   #7
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
I completely lost understanding on what is going on with my computer. I lost this failure behavior and now suspend works as it should. I tried to remember what I did, but I cannot. The only difference I see is that I installed vaiopower from http://vaio-utils.org/power/.

Code:
mkdir /usr/src/vaio
cd /usr/src/vaio
wget http://vaio-utils.org/download/vaiopower-0.4.4.tar.gz
tar xvf vaio*.tar.gz
cd vaiopower-0.4.4
mkdir /tmp/vaiopower
make prefix=/usr install DESTDIR=/tmp/vaiopower
makepkg -l y -c n /tmp/vaiopower-0.4.4-noarch-1.txz
upgradepkg --install-new /tmp/vaiopower-0.4.4-noarch-1.txz
Do not have time to test the behavior without this package. If will have time, will advise accordingly.

PS
I am on VAIO VGN-SR11MR. As per VAIOPOWER, it is a "Model lines including only SNY5001". I am running 2.6.35.4 kernel, configured with rlworkman's generic-config file.

PS2
if I removepkg vaiopower, suspending (through pm-suspend) still works. Probably it should be something else which fixed wrong behavior. No clue as for the moment. But have feeling that it has something to do with VAIO's buggy BIOS.

Last edited by dolphin77; 09-13-2010 at 04:26 AM.
 
Old 09-13-2010, 07:04 PM   #8
Faustphor
LQ Newbie
 
Registered: May 2010
Posts: 13

Original Poster
Rep: Reputation: 0
I've had the opposite happen before. Suspend will work for a few days on top of 2.6.35 but suddenly starts having these problems.

Out of curiosity, are you running the BIOS version that enabled VT?
 
Old 09-13-2010, 11:23 PM   #9
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
Yes. probably you are right. Before it started to work as it should, I switched on VT in BIOS. Could this be the reason?

Another thing, I was updating some packages, and after this update my rc.local was overwritten to the default empty one. It switched off vbox from starting.

When will have some time, will try to play with VT BIOS switch and with vbox. Probably one of this is causing suspend failure.

Last edited by dolphin77; 09-14-2010 at 04:23 AM.
 
Old 09-14-2010, 10:48 PM   #10
Faustphor
LQ Newbie
 
Registered: May 2010
Posts: 13

Original Poster
Rep: Reputation: 0
The BIOS update could have something to do with this error. I wish I knew someone that hasn't installed the upgrade.

I am going to try 2.6.36-rc4 tonight. I'll post an update after I have tested it.


EDIT: Doesn't solve problem. So far only solution I have is staying with the built-in kernel or upgrading to 3.6.35-rc3.

Last edited by Faustphor; 09-15-2010 at 02:28 AM. Reason: Update
 
Old 09-22-2010, 01:09 AM   #11
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
Just updated to 2.6.35.5.

For quite a long time with 2.6.35.4 everything worked as it should. After update, I received the same behaviour again. When computer wakes up, the noise from CR-ROM trying to rotate the disk comes two or three times and computer reboots.

What I did is following:
went to BIOS and loaded default values. Rebooted. After that suspend started to work. On next reboot I can switch on VT, disable booting from external devices and set first boot device to HDD. Everything is working.

I am not an expert, but I think, that Sony's BIOS has some kind of special memory or flags for ACPI state. I still remember, when I had Windows installed I choose to keep Batery Care from Sony utility. Battery was only charging to 80% of it's capacity. Then I removed Windows. And in Linux the same behaviour remained. I didn't know how to clean this flag. But simple Load defaults in Bios removed this behaviour. So if you are unlucky owner of a Sony VAIO, do the system defaults in BIOS.

PS would appreciate if anyone has additional information on handlins VAIO's bios from linux.
 
Old 10-05-2010, 11:53 AM   #12
pulmro
LQ Newbie
 
Registered: Oct 2010
Posts: 3

Rep: Reputation: 1
I have a Sony Vaio VPCEB1Z1E and passing the option acpi_sleep=nonvs to the kernel solved the issue of rebooting instead of resuming from suspend. As you can read here problems started when was introduced (in 2.6.35-rc4) saving NVS area during suspend:
http://www.spinics.net/lists/linux-acpi/msg29521.html

And quoting also this patch:
Quote:
To keep track of the systems that require
this workaround and to make the life of their users slightly easier
blacklist them in acpisleep_dmi_table[].
So if this is your problem we could also help kernel developers and other users.
 
1 members found this post helpful.
Old 10-05-2010, 06:26 PM   #13
Faustphor
LQ Newbie
 
Registered: May 2010
Posts: 13

Original Poster
Rep: Reputation: 0
A fglrx driver patch fixed this problem (for me) in 3.6.35.7.

Info is contained in this thread:
http://www.linuxquestions.org/questi...13-1-a-834017/

EDIT: Nevermind. It started this problem again not 2 hours after I posted this.

Last edited by Faustphor; 10-06-2010 at 01:13 AM.
 
Old 10-09-2010, 02:27 PM   #14
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
Thumbs up

Quote:
Originally Posted by pulmro View Post
I have a Sony Vaio VPCEB1Z1E and passing the option acpi_sleep=nonvs to the kernel solved the issue of rebooting instead of resuming from suspend. As you can read here problems started when was introduced (in 2.6.35-rc4) saving NVS area during suspend:
http://www.spinics.net/lists/linux-acpi/msg29521.html

And quoting also this patch:
So if this is your problem we could also help kernel developers and other users.
thanks a lot. you hit the target. after few days of testing, i am 99% sure that this solves the problem. at least i do not see it anymore. would appreciate if you share the information where and how do i have to report this. unfortunately i never submitted bug reports except of posting to forums and etc.
 
Old 10-21-2010, 08:39 AM   #15
pulmro
LQ Newbie
 
Registered: Oct 2010
Posts: 3

Rep: Reputation: 1
Sincerly I just sent an email to Rafael J. Wysocki (who worked on this bug) saying that my laptop needed to be blacklisted and I attached my dmidecode output, so he patched the kernel: https://patchwork.kernel.org/patch/260501/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+Alt+Backspace kills computer nomicon Slackware 7 02-16-2005 08:24 AM
acpi sleep reboots computer... djib Linux - Software 2 12-12-2004 10:17 AM
cups kills my computer! BrianNJ Linux - Software 2 12-04-2003 02:17 PM
samba 2.2.7 Kills my computer Zvezda Linux - Networking 1 11-24-2002 11:23 AM
computer reboots Robert0380 Linux - General 6 04-25-2002 02:25 AM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration