LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slave hd and Slackware install prob (http://www.linuxquestions.org/questions/slackware-14/slave-hd-and-slackware-install-prob-69878/)

pine0279 07-03-2003 03:13 PM

slave hd and Slackware install prob
 
I want to install Slackware 9.0 on a second (primary slave) hard drive on my machine. The first hard drive (primary master - /dev/hda) is 6 gig. and has Windows 98 on it. The second (primary slave - /dev/hdb) hard drive is 3.0 gig. I repartitioned and formated (FAT32) the second (primary slave) hard drive. I am installing Slackware from the CD drive. I reset the BIOS to read the CD drive first instead of the floppy drive. When I reboot the machine with the Slackware disk in the CD drive, it runs the boot disk (bare.i), then the root disk (color.gz), just fine. But when I run cfdisk or fdisk from the Slackware cd it does not see the second (primary slave) hard drive. It only recognizes the first (primary master) hard drive. Am I doing something wrong? Or is it not seeing the second hard drive because it is not a bootable and/or active drive? Can I install Slakware on a second hard drive? Or does Slackware have to live on a hard drive that is bootable and set as active? Thank you for you help. Feel free to ask me any questions that might help you to help me. Thanks again.

Locura 07-03-2003 03:26 PM

Running fdisk without an argument will make it look at /dev/hda (primary master). You need to specify the device if you want to use fdisk on another device. Try fdisk /dev/hdb

pine0279 07-03-2003 03:51 PM

Thanks Locura!

Locura 07-03-2003 03:52 PM

No problem.


All times are GMT -5. The time now is 06:45 PM.