LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slapt-get - Failed to download: Incomplete download (http://www.linuxquestions.org/questions/slackware-14/slapt-get-failed-to-download-incomplete-download-722987/)

mattydee 05-01-2009 01:22 PM

slapt-get - Failed to download: Incomplete download
 
I've been getting this error when trying to upgrade packages with slapt-get:

Failed to download: Incomplete download

Not sure what's going on. I tried to use --clean and tried to use a different mirror, but still getting the error.

mattydee 05-01-2009 05:18 PM

Solved:

removed slapt-get
rm -rf /var/slapt-get/*
re-installed slapt-get

dumdadum 05-15-2009 08:00 AM

Not solved
 
Quote:

Originally Posted by mattydee (Post 3527227)
Solved:

removed slapt-get
rm -rf /var/slapt-get/*
re-installed slapt-get


Hello hello,

I've tried this, didnt work for me. Edited the source, points at the right place, still, getting the incomplete message again and again.

Heres what I did.
installpkg slapt-get-0.9.12d-i586-7gsb.tgz

So, is there anything more I should do? Is there another way of doing? After editing the slapt-get file for the sources, is there anything more to do? Its not like if the downloads wont start. They start, they just dont finish. This happens when I try to do my upgrades, with the mozilla-firefox package. Can the source be the problem?

Thanks for the reply, if you can help, that would be great.

uppman 05-15-2009 08:15 AM

Maybe you can try using the latest version of slapt-get..

http://software.jaos.org/

dumdadum 05-15-2009 09:07 AM

Fixed fixed fixed
 
Quote:

Originally Posted by uppman (Post 3541769)
Maybe you can try using the latest version of slapt-get..

http://software.jaos.org/


Thanks. Fixed it.

feistyfeline 05-31-2009 10:51 PM

I've had trouble upgrading with slapt-get on slackware 12.0. I'll try the upgrade solution. Meanwhile Vector linux was throwing this specific error so I tried re-installing including cleaning up the /etc and /var directories of slapt get. Don't know if this was entirely necessary but it worked.
sudo su
removepkg slapt-get
rm -rf /etc/slapt-get
rm -rf /etc/slapt-get
installpkg slapt-get*
cp /etc/slapt-get/slapt-getrc.new /etc/slapt-get/slapt-getrc
slapt-get -u
slapt-get -upgrade

Redemption for systems that continue to show the error because for obvious reasons "Failed to download: Incomplete download" indicates a blank package name, where it should be "Failed to download <package name>: Incomplete download". Try this fix which helps things:
(Make sure that there is only one slapt-get package in the current directory before entering this commands)

sudo su
removepkg slapt-get
installpkg slapt-get*
cp /etc/slapt-get/slapt-getrc.new /etc/slapt-get/slapt-getrc
slapt-get --update && slapt-get --install slapt-get gslapt
slapt-get --upgrade

Rollo69 10-11-2009 10:45 PM

wanted to say thanks to uppman. I went to the link earlier but didnt notice gslapt so updated both my slapt-get and gslapt packages and works now.

rajan_juniku 09-27-2010 01:32 AM

Quote:

Originally Posted by uppman (Post 3541769)
Maybe you can try using the latest version of slapt-get..

http://software.jaos.org/

THis worked in my box. Thanks a lot.


All times are GMT -5. The time now is 06:46 AM.