LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-27-2003, 02:34 PM   #1
Schizo265
Member
 
Registered: Nov 2002
Distribution: Slackware 8.1, 9.0
Posts: 44

Rep: Reputation: 15
Slacware 9.0 problems...


1. at startup I recieve some messages insmod /usr/kernel/ ... about some missing drivers. I dont know what this is all about and I can't catch the messages. If someone would tell me where are the exact logs from startup in /var/logs i would apreciate it a lot.
2. xmms. When I'm logged in as root i can play any files and perfectly acces the cdrom and play cds. On the other hand, when I'm as a user, I cannot access my windows c drive... acces denied and I don't see the tracks in the /mnt/cdrom folder. I'm guessing this is all about permissions. Can anyone help me out?
3. This is more related to BlackBox in X windows. When I change the theme, usign the default BlackBox menu choices, X exits. And when I start them up again, the new theme is loaded.
blackbox: signal 11 caught
shutting down
aborting ... dumping core


thats about it for now. Thanks in advance.
 
Old 03-27-2003, 03:34 PM   #2
tellezj
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware
Posts: 26

Rep: Reputation: 15
1. The log file you are looking for is /var/log/system. However you should be able to find the appropriate file and line using:

grep insmod /var/log/*

2. Check your poermission on your cd drive and windows partition. These are in the /dev directory. If they are ide drives then they would be something like /dev/hda1 for the first partition on the primaty master or /dev/hdd for the whole secondary slave. Check permissions using:

ls -l /dev/hd*

and/or

ls -l /dev/cdrom

The /dev/cdrom is likely a symbolic link to the actual device, make sure the permissions on both are correct. To change permissions use:

chmod 755 /dev/hdb

obviously replacing /dev/hdb with the appropriate device.

3. Don't know about BlackBox.
 
Old 03-27-2003, 10:13 PM   #3
Schizo265
Member
 
Registered: Nov 2002
Distribution: Slackware 8.1, 9.0
Posts: 44

Original Poster
Rep: Reputation: 15
Unhappy

bah... ok
1. i cant find any file which holds these messages about insmod, but i copied some of them down.

insmod /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz
insmod /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz: no such device
insmod /lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz: insmod 8139cp failed
8139cp : 10/100 PCI Ethernet driver v0.3.0 (sept 29, 2002)

this obviously looks like some problem with drivers for my network card. but, its working fine... although my ISP is making me mad these past days. should i go to the hardware forum with this one?

2. i have setup the permission accordingly. I can read the tracks from the cdrom drive, but cant play them yet. I know what the problem with that is though.
But, i still can't read my hda and hdb drives. You were right. One was hda and the other hdb. I did
chmod 755 hda* && chmod755 hda
without taking into consideration hdb at the moment, but i still get permission denied.
brwxr-xr-x 1 root disk 3, 1 Jun 9 2002 /dev/hda1
brwxr-xr-x 1 root disk 3, 0 Jun 9 2002 /dev/hda
drwxr--r-- 26 root root 16384 Dec 31 1969 c/
drwxr--r-- 44 root root 16384 Dec 31 1969 d/

the last two lines are were hda and hdb are mounted.
/windows/c and /windows/d... i can only access them trough root.
whats up with this...?
 
Old 03-27-2003, 10:58 PM   #4
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
1) Your NIC card may be a RTL8139 based card and the system is attempting to load the driver. However, there are two drivers available. 8139cp and 8139too The first is usually the 8139cp and it appears to be failing, however, the 8139too may be loading. You can check this by using the lsmod command to list the loaded modules. If 8139too is loaded then you can fairly safely assume the errors can be ignored.

2) If you are logged in as a normal user and want to mount a data CD then you need to add the "user" or "users" option in the /etc/fstab file to allow a user to mount the CD. The line should look like;

/dev/cdrom /mnt/cdrom iso9660 users,noauto,ro 0 0

Also, an audio CD cannot be mounted like a data CD. So you will not be able to "see or view" the tracks in the directory tree of any mount point. If you wish to just play an audio CD then try "kscd". If you wish to play, rip, mp3 encode, catalog, etc. then search for a program called "grip". Google should turn up a location.

3) When a FAT16(32) partition type is mounted, the mount command changes the permissions on the directory according to the default umask setting in /etc/profile which is 022. This setting equats to a 755 (rwxr-xr-x). I believe this is because the file system types do not have their own permision settings so it will inherit the mount point permision on all files. If you desire to mount the partitions to allow all users write permission then mount it with the option of umask=000. This will equate to a 777 (rwxrwxrwx). So an fstab entry would look like below;

/dev/hda1 /windows/c vfat umask=000 0 0
/dev/hdb1 /windows/d vfat umask=000 0 0

If your system has some other options then simply add them together using the comma as a separator.

4) Hard disks are identified by the hdx or sdx type device name. The partitons are the disk device name with a partition number added. So that /dev/hda is the first IDE hard disk and /dev/hda1 is the first IDE hard partition number one. The device /dev/hda cannot be directly mounted because it is not a partition. There are operations that can be done on the disk device name but they are few. For instance when you want to create partitions you always use the disk device name and never the partiton number. So the use of these device names are context sensitive as well.

5) On the /dev/cdrom link. It is just a symlink. Normally all symlinks are by default set with full permisisons allowed. It is the real device name that many times must have the permisions changed. For example; if the device /dev/cdrom points to /dev/scd0 then change the permisions on /dev/scd0. Since normally only root can mount/umount hard disk partitions, it doesn't seem to make much sense to attempt to change permissions on the device name. But then again I have never had a need to either. It would be better to just specify them in the /etc/fstab and let the system mount them when you boot. Then use the "users" option on removable media like a cdrom drive.

Sorry, I do not know anything about themes or blackbox and stuff like that. I am not one for eye candy so I just leave it the way it is unless it is obtrusive to the use of the system.

Hope the info above will at least help in the other areas that I think you were asking about.

Last edited by Excalibur; 03-27-2003 at 11:02 PM.
 
Old 03-28-2003, 02:06 PM   #5
Schizo265
Member
 
Registered: Nov 2002
Distribution: Slackware 8.1, 9.0
Posts: 44

Original Poster
Rep: Reputation: 15
wow. Thanks excalibur, man thigns are clearer now.
1) Yes, my system loads 8139too. Is there anyway to remove the errors though? Maybe remove some options of module loading in the kernel?

2) I'm still having problems with reading my drives by a user though. Whaty I want to accomplish is to read some mp3's using xmms. But, since I cannot access /windows/c (hda1) or /windows/d (hdb1) , I cannot read those mp3s. I added the umask=022 to the /etc/fstab, but it still won't read. I feel im gonna go apeshit soon.

3) As for the audio cd. Xmms has a plugin which reads audio cds. I don't mount the audio cd. i just go into /mnt/cdrom in xmms and the tracks are there. But, don't worry about this one, I got it down.
 
Old 03-28-2003, 02:25 PM   #6
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
The umask settings should be 000, not 022. 022 is the system default.
 
Old 03-29-2003, 01:49 AM   #7
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
There is a file /etc/hotplug/blacklist that states adding drivers to the list to prevent it from being loaded. So you might want to try adding the 8139cp driver to the list. That way it shouldn't load it. Sorry, it took so long but this hotplug stuff is still new to me and probably many others as well.
 
Old 03-29-2003, 02:30 AM   #8
Angelo
Member
 
Registered: Mar 2003
Location: Connecticut
Distribution: Slackware, OpenBSD
Posts: 60

Rep: Reputation: 15
Quote:
Originally posted by Schizo265

2) I'm still having problems with reading my drives by a user though. Whaty I want to accomplish is to read some mp3's using xmms. But, since I cannot access /windows/c (hda1) or /windows/d (hdb1) , I cannot read those mp3s. I added the umask=022 to the /etc/fstab, but it still won't read. I feel im gonna go apeshit soon.
I had this same problem and added this to my /etc/fstab

/dev/hda1 /win vfat noauto,ro,umask=022 0 0

However! If I try to mount with "mount /dev/hda1 /win" I still get the problem with the bad permissions. Instead, I just need to do "mount /win" and all is well.

I wish I knew why the umask is needed under 9.0 but wasn't with 8.1.

Hope this helps.
 
Old 03-29-2003, 08:27 AM   #9
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
There does appear to be a difference in the mount command using the umask settings like Angelo described from Slack 8.1. The default umask setting is in /etc/profile. I changed it to 000 and then rebooted the my test box. Then mounted a vfat image, and the default umask was NOT used. And likewise, the original default umask setting was not used either, 022. The mount command is setting the mount point with a umask of 033 if it is not specified otherwise. The man page describes two new settings beside umask, they are dmask and fmask, and they are suppose to default to the current process umask settings as well, but I didn't test these new ones since they did not exist in Slack 8.1. If you enter the command umask without any arguments it returns the current setting and I verified the current setting was 000. When creating a simple file using the "touch" command the umask setting was honored accordingly. So the problem at least appears to be limited to the mount command. But the umask setting of 022 would produce a mount point with permissions set to rwxr-xr-x, but 033 produces rwxr--r--. Notice the loss of the execute bit only for group and world, but it does still allow for read permision. So then if the prior mount settings are required then the umask will have to be specified to allow the execute bit to be set as well.

When using the mount command manually like in the example from Angelo, use the "-o umask=022" option to set it as as desired.

mount -o umask=022 /dev/hda1 /win

When mounting manually and just using the mount point or the device name, the mount information in the /etc/fstab file is used for the values not supplied.
 
Old 03-29-2003, 09:07 AM   #10
Schizo265
Member
 
Registered: Nov 2002
Distribution: Slackware 8.1, 9.0
Posts: 44

Original Poster
Rep: Reputation: 15
wow thanks a lot guys. Everything seems to be working good now. I added the 8139cp to the blacklist and it doesn't load it. I altered the line of fstab to: /dev/hda1 /windows/c vfat auto,ro,umask=022 1 0
and it works perfectly.
the only problem I'm having now is that XMMS cannot play any mp3's as a user, but I can play them as root. In the user xmms says: "Couldnt open audio. Check that you have the proper plugin (yes... libOSS, same one as in root), no other program is blocking the sound card (its not), and that your soundcard is configured properly (well if it works in root i believe the configuration is good)."
so is this a permission problem? which files should I change the permissions for then?
 
Old 03-29-2003, 09:20 AM   #11
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
It sounds like a permission issue. So as root, you might want to

chmod 666 /dev/dsp* /dev/mixer*
 
Old 03-29-2003, 05:13 PM   #12
Fuel
Member
 
Registered: Feb 2002
Location: Sweden, Skeldepth
Distribution: Slackware 10
Posts: 178

Rep: Reputation: 30
-Schizo265 .. What did you exactly write in the /etc/hotplug/blacklist ? .. i have the same error as you..
 
Old 03-29-2003, 05:41 PM   #13
Schizo265
Member
 
Registered: Nov 2002
Distribution: Slackware 8.1, 9.0
Posts: 44

Original Poster
Rep: Reputation: 15
at the end i just wrote the name of the driver, in this case 8139cp. that's it. if in doubt, just look at the syntax of the drivers already included there.
 
Old 03-30-2003, 10:59 AM   #14
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Here's a new one, XMMS won't use it's own Equalizer, but uses Kmix instead, how would one change this?? thx
 
Old 11-06-2007, 12:11 AM   #15
UMG:Chicken_Sop
Member
 
Registered: Nov 2007
Location: Neptune, NJ (exit 100)
Distribution: Slack, Solaris, whatever I have space for
Posts: 32

Rep: Reputation: 16
Quote:
Originally Posted by Excalibur View Post

3) When a FAT16(32) partition type is mounted, the mount command changes the permissions on the directory according to the default umask setting in /etc/profile which is 022. This setting equats to a 755 (rwxr-xr-x). I believe this is because the file system types do not have their own permision settings so it will inherit the mount point permision on all files. If you desire to mount the partitions to allow all users write permission then mount it with the option of umask=000. This will equate to a 777 (rwxrwxrwx). So an fstab entry would look like below;

/dev/hda1 /windows/c vfat umask=000 0 0
/dev/hdb1 /windows/d vfat umask=000 0 0

If your system has some other options then simply add them together using the comma as a separator.
I owe you a beer for this one!

This response is great, but the title on this post is terrible. Given that I've just spent the last 3 hours trying to find this answer (and apparently other users have too) I'm going to post it under a better name.

Sincerely,
Soup
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing slacware with kernel 2.6.x without 2.4.x nemesi Slackware 2 05-06-2005 11:38 AM
Plesk for Slacware 9.1 Dakkar Linux - Software 1 06-08-2004 02:48 PM
CUPS - Slacware Current shepper Slackware 4 09-23-2003 12:03 PM
slacware install CrazyTux Slackware 3 03-25-2003 11:10 PM
Slacware 8 and DSL rayflynn Linux - Software 5 05-02-2002 07:58 PM


All times are GMT -5. The time now is 09:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration