LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-12-2013, 05:23 AM   #1
Clementine Jam
LQ Newbie
 
Registered: Apr 2013
Location: Mogilev, BY
Distribution: Slackware
Posts: 18

Rep: Reputation: Disabled
slackware64-current, xorg-1.14, kernel 3.10.11, bumblebee not working


Slackware64-current, xorg-1.14. kernel 3.10.11 from repos, bumble build according to howtos:hardware:nvidia_optimus
Code:
neko@ASUS-N56VZ-SlackBooK:~$ primusrun glxspheres
primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) Failed to load module "qxl" (module does not exist, 0)

neko@ASUS-N56VZ-SlackBooK:~$ optirun glxspheres
[  834.602296] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "qxl" (module does not exist, 0)

[  834.602360] [ERROR]Aborting because fallback start is disabled.
neko@ASUS-N56VZ-SlackBooK:~$
how to fix it?
 
Old 09-12-2013, 06:36 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
I can be wrong (I don't use bumblebee), but it seems to me that for some reason you have installed the xf86-video-qxl package (the qxl driver for qemu virtual machine displays using spice) and you still have a file /usr/share/X11/xorg.conf.d/05-qxl.conf (or something similar) that looks for the qxl driver laying around in your filesystem.
 
Old 09-12-2013, 07:12 AM   #3
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 226

Rep: Reputation: 54
Couple of things:
1. -current mesa doesn't include glxspheres... hasn't for a while (maybe another update for your box?)
2. I keep a repo updated for -current herehttps://github.com/WhiteWolf1776/Bumblebee-SlackBuilds . The How-To is more to support released versions than -current I believe.

Give that repo a quick look and see if there is any diff with your install.

The most common mistakes for this are forgetting to install the xf86-video-nouveau-blacklist-noarch-1 from /extra and forgetting (or not knowing) to blacklist xf86-video-nouveau in /etc/slackpkg/blacklist (so it just gets re-installed next time you slackpkg upgrade-all)
 
Old 09-12-2013, 07:30 AM   #4
Clementine Jam
LQ Newbie
 
Registered: Apr 2013
Location: Mogilev, BY
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: Disabled
explaining:
i did not install qxl, it is even not compiling in current.
i blacklisted nouveau in modprobe.d
i have both primus and virtualgl installed, so glxspheres is also installed.
/usr/share/X11/xorg.conf.d/ is empty

> https://github.com/WhiteWolf1776/Bumblebee-SlackBuilds
ok, thnx, i'll check
 
Old 09-12-2013, 07:37 AM   #5
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 226

Rep: Reputation: 54
Since you are running bumblebee, the config files for your secondary GPU are in /etc/bumblebee. You shouldn't need to modify them, but if you are hunting down your xorg conf files, they are there.
 
Old 09-13-2013, 09:32 AM   #6
Clementine Jam
LQ Newbie
 
Registered: Apr 2013
Location: Mogilev, BY
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by WhiteWolf1776 View Post
Since you are running bumblebee, the config files for your secondary GPU are in /etc/bumblebee. You shouldn't need to modify them, but if you are hunting down your xorg conf files, they are there.
thanks nor help. removing all the bbsb pkgs, purging /etc/bumblebee and recompiling bbsb again solved the problem.
 
Old 09-13-2013, 10:14 AM   #7
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 226

Rep: Reputation: 54
cool

It seems there is something with order.. or sometimes forgetting that COMPAT32=yes on one package.. is the issue 90%.

Mark as solved please.
 
  


Reply

Tags
optimus, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware64-current w/ xorg-server-1.14 & AMD catalyst lanir Slackware 4 03-17-2013 08:21 AM
Primusrun (bumblebee) not working (Slackware64 14.0) natharran Slackware 1 03-04-2013 06:07 PM
Slackware64-Current + Bumblebee nvidia proprietary driver not found (but exists) TommyC7 Slackware 2 08-16-2012 03:21 AM
[SOLVED] [Xorg-1.7.5 in Slackware64 -current] still no workie.. Xorg bug? GrapefruiTgirl Slackware 94 07-28-2010 08:23 AM
[SOLVED] Latest slackware64-current xorg and kernel update woes veeall Slackware 10 07-19-2009 12:31 AM


All times are GMT -5. The time now is 05:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration