-   Slackware (
-   -   slackware64-current + xfce; icons and terminal issues (

lazardo 02-24-2011 10:27 PM

slackware64-current + xfce; icons and terminal issues
Fresh guest install of current as of changelog dated 16-Feb-2011, in to VirtualBox 4.0.4 (13.1 x86_64 host).

1. About 6 of the icons normally residing in the top half of Settings Manager are missing (names are their and functions work). Selecting 'Appearance -> Icons' and re-selecting the one choice available restores one, the rest remain MIA.

2. Default xfce Terminal launch fails with error <????> Re-selecting the default 'Preferred Applications -> Utilities -> Terminal -> Xfce Terminal' has no effect. 'Properties' shows the usual 'exo-open --launch TerminalEmulator'.

Setting 'Preferred Applications' to 'X Terminal' launches an xterm successfully as expected.

Repeated install on fresh disk (gotta love virtual machines), same failures.


'Terminal' issue was due to missing VTE package. Not sure why this also cleared up the missing icons, but installing it plus a reboot fixed things.


rworkman 02-25-2011 01:30 AM

Unable to reproduce here on multiple machines.
As root, run this:

# Update any existing icon cache files:
if find /usr/share/icons 2> /dev/null | grep -q icon-theme.cache ; then
  for theme_dir in /usr/share/icons/* ; do
    if [ -r ${theme_dir}/icon-theme.cache ]; then
      echo "Updating icon-theme.cache in ${theme_dir}..."
      /usr/bin/gtk-update-icon-cache -t -f ${theme_dir} 1> /dev/null 2> /dev/null &

lazardo 02-25-2011 02:46 AM

Thanks. Not sure how/why but missing vte.

[also updated to 25-Feb-2011 01:10 drop so no worries]

rworkman 02-25-2011 12:39 PM

Rebooting ran that section of code I pasted from rc.M :-)

lazardo 02-26-2011 02:06 AM

Ack. It was easier than cut/paste.


All times are GMT -5. The time now is 06:45 PM.