LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2010, 10:34 PM   #1
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Rep: Reputation: 44
Unhappy Slackware64 -current video problem with ATI HD5570


Hey guys! I just built a machine for a friend and he has a HIS Radeon HD5570. I successfully installed slack64 current (as of today nov. 20) and upon first attempt to enter the desktop, I experienced a problem. Basically, I log in, type startx to start the X server and then I see the KDE loading bar, and boom! black screen, the monitor goes to sleep. It happens with all monitors so far... Should I suspect a hardware problem? Please note I did not install any drivers so far.. Only Slackware...

How can I fix this? What do you need in order to help me?

If useful, I pasted my Xorg.0.log at pastbin

http://pastebin.com/XYfFnx39

Thanks as always!

Last edited by lpallard; 11-20-2010 at 10:36 PM.
 
Old 11-21-2010, 01:13 AM   #2
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
Quote:
[ 33.210] (--) RADEON(0): Chipset: "ATI Radeon HD 5570" (ChipID = 0x68d

#
Fatal server error:
#
[ 36.548] Caught signal 11 (Segmentation fault). Server aborting
Oop, seg. fault, X-server aborted.

Poor thing. Looks like it tried really hard ie loaded then unloaded copius amounts of drivers including vesa BTW I don't think vesa and radeon can coexist.

You need to enable kms. you also need the next file.

Code:
/etc/modprobe.d/radeon.conf
I ran xorgsetup (I think) which gave me an xorg.conf file.

I'm now running 2.6.35.8 and my HD 5450 radeon kms video is even better now than it was with 2.6.35.7

http://www.linuxquestions.org/questi...ml#post4117004

http://www.linuxquestions.org/questi...ml#post4130065

http://www.linuxquestions.org/questi...ml#post4117015

http://www.linuxquestions.org/questi...5/#post4133185

--
Alan.
 
Old 11-21-2010, 01:28 AM   #3
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
http://www.linuxquestions.org/questi...ml#post4117100

Quote:
BTW I been dink with this off and on now for more than a week and a half. I Nearly sledge hammered my hd 5450 and I *very* nearly queried slack forum here for a (like, let's get *real* <grin>) a "Linux friendly pci-E video adapter"
<grin><grin><grin><grin><grin>

Are we having fun yet?

*Yes*!!! Silly late hardware anyways. Go Slackware!!!!

Slackware rocks.

It's Slackware *equals* "Do what you want"

I do what I want ie virtual machines all over the place.

Serving desktop across lan and across internet be next on my agenda in my Slackware travels.

--
Alan.
 
Old 11-21-2010, 02:30 AM   #4
JackHair
Member
 
Registered: Aug 2009
Location: Netherlands
Distribution: OpenSuse 13.1
Posts: 80

Rep: Reputation: 16
I had the same problem with my HD5850. It has to do with the new mesa pkg.

Code:
  If X crashes at start, try disabling compositing.  Create a file named
  /etc/X11/xorg.conf.d/disable-composite.conf with this in it:
    Section "Extensions"
      Option "Composite" "Disable"
    EndSection
After doing this I got to the desktop. But obviously composite doesn't work. I just removed the disable-composite.conf again and installed fglrx. Now it's working fine.
 
Old 11-21-2010, 08:50 AM   #5
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
I just went through a similar experience with an HD4200:

http://www.linuxquestions.org/questi...ml#post4166070

Follow the link to Eric's post and see if the mesa-7.9 to mesa-7.8.2 change helps.
 
Old 11-21-2010, 09:30 AM   #6
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Original Poster
Rep: Reputation: 44
I am sooooooooooooooo confused! reminds me of the days I was trying to install my FireGL card on mandrake.... hahaha the good ol' days!

now with this issue, I started off by trying what JackHair suggested. i.e. adding
Code:
Section "Extensions"
   Option "Composite" "Disable"
EndSection
to /etc/X11/xorg.conf.d/disable-composite.conf

And I could boot to the desktop. Then I continued with Jack's suggestion (removing the disabled-composite.conf file) and install the fglrx driver. To do so, I followed the instructions on the ATI's wiki for slackware64... That means I downloaded the installer.run , converted into 2 tgz packages and installed both of them using installpkg.

I ran aticonfig --initial and so far so good. I verified the content of xorg.conf as suggested on ATI's wiki but noticed a few problems such as the section module should be populated but it is not (empty).

I ran fglrxinfo but got a segmentation fault.

I think this is going to be complicated. Would reverting to the latest stable release of slack64 help? If not, I will need some major step by step assistance because I never really played with drivers and Xorg before....

thanks to all!
 
Old 11-21-2010, 11:09 AM   #7
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
OK, let's try and focus on getting fglrx working, rather than using the mesa drivers.

Can you show us the /var/log/Xorg.0.log file you have while using fglrx?

Adam
 
Old 11-21-2010, 11:57 AM   #8
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Original Poster
Rep: Reputation: 44
thanks adam75k for replying!

just before I got your reply, I took the initiative to uninstall current and install the last stable release of slack64. I noticed that I could log in the desktop withourt problems but I experienced the "monitor going to sleep" upon clicking logout in KDE...

I then installed the fglrx driver following the same procedure as above and now xorg.conf contains:

Code:
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
section module is still empty but fglrxinfo now gives :
Code:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5500 Series
OpenGL version string: 4.0.10317 Compatibility Profile Context
instead of a segmentation fault...

now to the Xorg.0.log as you requested, please look at http://pastebin.com/pfM30R8u

The log contains tons of fglrx lines so I think its good sign?!
 
Old 11-21-2010, 12:03 PM   #9
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Yes, according to everything you just posted, your drivers are working fine now.

Adam
 
Old 11-21-2010, 12:22 PM   #10
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Original Poster
Rep: Reputation: 44
Adam, if you dont mind I would have one more question... I tried to hook up the computer to the LCD tv via HDMI and noticed something funny. The resolution reported by the catalyst driver is 1920x1080 and that correspond to the native resolution of the tv we try to work with. So normally, the bottom of the desktop (the taskbar) and all other edges should be right on the edges of the tv display.... Right now, the image is somehow scaled up (like if the resolution was set higher than the TV can handle, and all 4 edges of the desktop are hidding.

DO you know how to fix this? I tried to play around with the catalist driver but no success.

UPDATE: I just tried to change the settings in the Tv and set the picture to scale to fit instead of 16:9.. Is that normal?

Last edited by lpallard; 11-21-2010 at 12:26 PM.
 
Old 11-21-2010, 12:39 PM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
To me it sounds like the driver is overscanning or underscanning your display. Most new HDMI displays have an option to underscan or overscan. If yours does not, catalyst might, but I've never had to deal with it before so I wouldn't even know where to look.

Adam
 
Old 11-21-2010, 05:05 PM   #12
lpallard
Member
 
Registered: Nov 2008
Location: Milky Way
Distribution: Slackware (various releases)
Posts: 970

Original Poster
Rep: Reputation: 44
Just as good as your guess was, I the overscanning was responsible for the problem... In the catalyst driver applet, I found the option to adjust the overscan and I lowered the slide bar to roughly 90% of what It was and now I have a perect match with the hdtv. We're happy with that!

Now I need to find out why I have no sound. Only KDE sounds (login, logout, and all sound events) work but playing flash videos from the web or even local media wont work. However MP3's work like a charm!

That mean that the sound is carried through HDMI but not for videos...
 
Old 11-22-2010, 01:27 AM   #13
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,264

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by lpallard View Post
That mean that the sound is carried through HDMI but not for videos...
If you have another sound card it is very likely that those applications are trying to use it instead of the HDMI output. For video applications you should be able to specify the device (or set them to use KDE4's sound server instead of ALSA directly), but I really am not sure how to get Flash to behave other than setting your HDMI output as the default sound device (either through ~/.asoundrc or by setting it as card 0 in /etc/modprobe.d/sound.conf).
 
Old 11-22-2010, 04:30 AM   #14
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Quote:
Originally Posted by lpallard View Post
Just as good as your guess was, I the overscanning was responsible for the problem... In the catalyst driver applet, I found the option to adjust the overscan and I lowered the slide bar to roughly 90% of what It was and now I have a perect match with the hdtv. We're happy with that!

Now I need to find out why I have no sound. Only KDE sounds (login, logout, and all sound events) work but playing flash videos from the web or even local media wont work. However MP3's work like a charm!

That mean that the sound is carried through HDMI but not for videos...
Run firefox from a terminal and start up a flash video. See what errors firefox displays.

Adam
 
Old 11-22-2010, 11:07 AM   #15
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Try this out, it should work good

http://www.shcherbyna.com/?p=866
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware64-current and ATi Proprietary Driver ack_iix Slackware 5 03-06-2010 12:09 PM
[SOLVED] Video Problems in VirtualBox on Slackware64-current TSquaredF Slackware 8 10-20-2009 11:44 PM
Slackware64-current ATI, and few more proprietary questions dolphin77 Slackware 15 06-10-2009 09:15 AM
Slackware64-current ATI, and few more proprietary questions dolphin77 Linux - Newbie 1 05-22-2009 06:57 PM


All times are GMT -5. The time now is 06:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration