LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 08-19-2009, 12:34 PM   #1
Ron Parker
LQ Newbie
Registered: Jul 2009
Posts: 5

Rep: Reputation: 1
Slackware64-current Segmentation Fault in cryptsetup

Running "cryptsetup luksAddKey /dev/md2" encounters a segmentation fault after entering the passphrase that I want to add.

So, I grabbed the 1.0.6 source from a/cryptsetup, applied the use_udevadm patch, configured it and built it. Then I cd'd to src and ran ./cryptsetup. Everything worked fine. I did not have the time (at work) to play with the SlackBuild and track down the issue, but hope this helps.
Old 08-19-2009, 01:28 PM   #2
Senior Member
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,670

Rep: Reputation: 148Reputation: 148
Using cryptsetup.dynamic instead of just cryptsetup worked for me. No need to compile anything from source.

Thanks for reporting your successful alternative here, anyway!

Old 08-19-2009, 02:04 PM   #3
Registered: Dec 2006
Distribution: Slackware
Posts: 507

Rep: Reputation: 33
I know the segfault is a known bug. Interesting work-around though. Good find.

Last edited by C-Sniper; 08-19-2009 at 02:06 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] what's that directory (slackware64-current) sycamorex Slackware 3 05-30-2009 09:03 AM
mplayerplug-in with current causes segmentation fault Daedra Slackware 2 03-27-2009 06:22 PM
Running cryptsetup in initramfs with blackbox segmentation fault 3rdtreenz Linux - Kernel 1 01-03-2009 03:11 AM
cryptsetup-segmentation fault on Slackware-12.0 - dlinux Slackware 2 01-30-2008 05:42 AM
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika SUSE / openSUSE 2 12-02-2005 09:34 AM

All times are GMT -5. The time now is 04:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration