LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2013, 08:03 PM   #1
slaka
Member
 
Registered: Oct 2012
Distribution: Slackware 14.0 86x
Posts: 43

Rep: Reputation: Disabled
Slackware64 -current (multilib) -- Wrong GCC version


Hey,

I'm pretty sure this is solved but couldn't find.

So problem is when I try to create Slackware package from virtualbox which I got from slackuilds, I get this error:

Code:
** gcc version 4.8.0 found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<8!
Very self explanatory but I'm not sure what should I do, install older gcc version? Not sure if I should do that since I have multilib installed.
 
Old 05-07-2013, 08:30 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,553

Rep: Reputation: 423Reputation: 423Reputation: 423Reputation: 423Reputation: 423
I think you need to download the updated version of VirtualBox in order to compile it with recent GCC version
 
Old 05-13-2013, 10:39 AM   #3
InFlame
LQ Newbie
 
Registered: Feb 2011
Location: Kygryzstan, Bishkek
Distribution: Slackware-current x64
Posts: 1

Rep: Reputation: 0
Just unpack tarball, change in `configure` file line
'-o \( $cc_maj -eq 4 -a $cc_min -gt 7 \)' to '-o \( $cc_maj -eq 4 -a $cc_min -gt 8 \)' (in VirtualBox-4.2.12 it is in 417 line)
and pack it again. After that run virtualbox.SlackBuild.
I have today this problem too under Slackware-current x64_86 Multilib and after changing value it runs.

p.s. Sorry for my poor english - it isn't my native language.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gcc, multilib and Slackware64 dr.s Slackware 2 05-01-2013 07:26 AM
slackware64-current libtool using path to old version of GCC JazzItSelf Slackware 6 11-21-2011 11:35 PM
upgrading slackware64 13.1 multilib to slackware64 -current multilib Cultist Slackware 4 03-12-2011 09:04 AM
[SOLVED] Slackware64-current multilib: Many improvements, few snags gargamel Slackware 7 11-15-2009 07:23 AM
slackware64-current : pulseaudio compilation fails, wrong version of libtool pokipoki08 Slackware 2 07-31-2009 11:59 PM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration