LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-09-2010, 08:04 PM   #1
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,621

Rep: Reputation: 142Reputation: 142
Slackware64-current Kernel 2.6.32.3: No sound on CLI and in Browsers


Hi everyone,

I just upgraded my Slackware64-current version to the latest kernel 2.6.32.3. Almost everything works just fine, except that I have no sound on the command line and in web browsers, anymore. I don't get any sound out of the command line program play and Flash.

For example, I have a few .wav files, that I can play with Kaffeine and Amarok, but when I try to play them with play on the command line, the program runs and displays that it plays the file, but I don't hear any sound.

The same happens with XMMS, too: It displays the usual graphics showing the dynamics and the progress, but my speakers remain silent.

Also, alsaconf doesn't detect my audio hardware, anymore. I have onboard sound and a Creative X-Fi PCI card. Usually both were "seen" by alsaconf. Now it tells me, that it can't identify any audio cards.

On the other hand, when I go into the multimedia section of the KDE system settings, I can "Test" the audio hardware, and the onboard sound works great and I can hear the KDE welcome sound.

I have already remove all packages withe 'alsa' in their name and re-installed them, including their compat32 peers, and rebooted several times. Up to now to no avail.

Does anyone have a clue, what the problem is caused by? Thanks a lot, best regards

gargamel
 
Old 01-10-2010, 10:42 AM   #2
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,621

Original Poster
Rep: Reputation: 142Reputation: 142
Hi everyone,

this is just a rephrased version of my original post --- no reply received means probably that the question was unclear. Hope, it's better now.

Problem is after applying the recent update for Slackware64-current to kernel version 2.6.32.3 sound isn't working properly anymore.

I have onboard sound plus a Creative X-Fi Platinum (yes, pretty much useless under Linux, but it's there, anyway). After the kernel upgrade I made the suggested changes to /etc/mkinitrd.conf and /etc/lilo.conf and ran mkinitrd -F and lilo, then rebooted. Everything seemed to work fine, with one exception:

There was no sound from Flash in web browsers. I tried Firefox, Seamonkey and Konqueror.

I tried to find out what the problem was caused by, re-installed the whole ALSA stuff (lib, plugins, utils and OSS compatibility things) and ran alsaconf. To my amazement, this is what alsaconf said:

Code:
No supported PnP or PCI card found.
Would you like to probe legacy ISA sound cards/chips?
Then I did

Code:
# kdesu systemsettings
and navigated to the multimedia section. Both hardware sound sources were there, and clicking on the "Test" button gave sound from the Intel HDA onboard sound.

Finally, I tried

Code:
# play postgresql.wav
(a small wave file that tells how to pronounce PostgreSQL).

Result: The file was played, but my speakers remained silent. Same with media players of all kinds: MPlayer, Kaffeine, Xine, Gxine and XMMS.

But now, surprise: Watching TV or movies recorded with Kaffeine before, are played by Kaffeine with excellent sound. Also, Amarok doesn't output sound to my speakers, although it seems to play the files, except internet FM radio. E. g., I can hear Virgin radio, while I am writing these lines.

So online audio streams seem to work fine, while playing audio files fails.

So what can be the reason for this problem, that I get sound for .m2t files and from DVB-T television, and that I can hear online radio, on the one hand, while I don't get sound from audio files that just worked fine before the kernel upgrade?
BTW, I am not sure, if the new kernel has anything to do with it, it may be a conincidence, as the sound stuff wasn't actually changed (no new ALSA version or something, as far as I can tell).

Am I the only one seeing this?

gargamel
 
Old 01-10-2010, 11:22 AM   #3
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
Does "lspci | grep -i Audio" display your card?

I had a sound problem here
http://www.linuxquestions.org/questi...elated-768483/
that no one was able to help me with. It went away when I upgraded from 12.2 to 13.0. I never did figure it out.

Here is another thread that may be useful
http://www.linuxquestions.org/questi...nstall-779083/
 
Old 01-10-2010, 03:12 PM   #4
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,621

Original Poster
Rep: Reputation: 142Reputation: 142
I get:

Code:
# lspci | grep -i Audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
04:08.0 Multimedia audio controller: Creative Labs SB X-Fi
which to me seems correct.I also can change the settings for each device with programs like KMix. These programs 'see' both audio sources, alsaconf none of them. This also works:

Code:
# alsamixer -c 0
Again, everything looks like audio files are being played, but there's just no sound to hear, except for internet radio and tv (DVB-T).

I have also changed priority/sequence using the trick with setting options in /etc/modprobe.d/sound to

Code:
options snd_ctxfi index=-2
Indeed the sequence was changed by that, but it didn't have any noticeable effect on the sound output:

Code:
# cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf3ff8000 irq 22
 1 [XFi            ]: SB-XFi - Creative X-Fi
                      Creative X-Fi 20K1 Unknown
Before I added the options line, XFi came first.

Regarding your links, yes, it seems to be the very same problem you described in your thread:
http://www.linuxquestions.org/questi...elated-768483/

Only difference is, that I didn't have the problem a couple of days ago, before the upgrade to the latest kernel. As I said, I am not sure, if the kernel upgrade is the real cause, or if it is just a conincidence.

Currently I am clueless, and would appreciate any ideas, how to track this down further.

gargamel
 
Old 01-10-2010, 03:36 PM   #5
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,621

Original Poster
Rep: Reputation: 142Reputation: 142
Finally got it, and maybe it helps you, too, Z038!

I did:
Code:
# aconnect -i
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
and

Code:
# aconnect -o
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
So only MIDI port 0 was connected for output. I therefore tried:
Code:
# aconnect -x
And guess what? Everything works like it should, again!

What I still don't understand, however, is why there was sound from DVB-T and internet radio. Probably I simply don't understand how ALSA works. Anyway, for me it's solved now.

@Z038: I'd be interested to hear if this is of any help for you, too!

gargamel
 
Old 01-11-2010, 12:07 PM   #6
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
gargamel, this seems like a promising avenue of attack, but the commands you listed didn't do the trick for me. I will play with this some more this evening.

Here's what I have, and it looks like your output:

Code:
# aconnect -i
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
Code:
# aconnect -o
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
Code:
root@ixian1:/home/s# aconnect -x
From reading the MAN page for aconnect, it seems that the -x should remove all exported connections. An aconnect -i after the -x command doesn't show any change.

aconnect -il shows this:

Code:
# aconnect -il
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
        Connecting To: 15:0
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
I've done all this from a konsole terminal under kde, if that makes any difference. It didn't make any change in my sound.
 
Old 01-11-2010, 02:44 PM   #7
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,621

Original Poster
Rep: Reputation: 142Reputation: 142
Hmmm, as far as I remember, I stopped and restarted the ALSA daemon, but unfortunately I don't recall exactly at which point.

Also, sound is one of the very few areas, where a reboot sometimes seem to be help in Linux, too.

Otherwise I am clueless. As I said, I don't understand ALSA well enough, as it turns out.

gargamel
 
Old 01-11-2010, 11:57 PM   #8
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
gargamel, what alsa daemon are you referring to? I cannot find one. alsa is part of the kernel, no? There is an rc.alsa in /etc/rc.d, but it just loads some drivers and restores settings and so forth. It doesn't support a START, STOP, or RESTART.
 
Old 01-12-2010, 04:21 PM   #9
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,621

Original Poster
Rep: Reputation: 142Reputation: 142
Hmm, you are probably right.

I did:

Code:
# cd /etc/rc.d
# ./rc.alsa stop
and got:

Code:
Loading ALSA mixer settings:  /usr/sbin/alsactl restore
Same with

Code:
# ./rc.alsa start
Hmmm. Then I don't know. Maybe a reboot after

Code:
# aconnect -x
does the trick?

BTW, I did this as root. If not, I am out of ideas. Unfortunately I don't know enough about ALSA to explain why this has cured my system. All I know, is that it did.

Maybe someone else can help, here?

Good luck!

gargamel
 
Old 01-12-2010, 09:12 PM   #10
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
Rebooting does seem to fix it for a little while. But it doesn't stay fixed. I rarely boot this machine, but I'll try it this coming weekend. If you boot frequently you may not see the problem come back either, but you might if you stay up for several weeks at a time. I'd be interested in knowing if your problem re-emerges again, and if you find that rebooting fixes it again for a time.
 
Old 01-13-2010, 02:33 AM   #11
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,621

Original Poster
Rep: Reputation: 142Reputation: 142
Interesting. Usually, I reboot the machine, where I had this problem, several times a week, if not daily. But occasionally it's up longer. However, the problem didn't occur before, here, but immediately after upgrading to kernel 2.6.32.3 --- but as I said, this might be a coincidence. Perhaps I can try, what happens, if I don't reboot the machines for several weeks.

gargamel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 07:50 PM
Slackware64-current missing kernel headers? UpAndUp Slackware 2 08-26-2009 08:08 PM
Slackware64-current : can't have lilo updating the boot loader after kernel upgrade Didier Spaier Slackware 3 07-21-2009 09:00 AM
[SOLVED] Latest slackware64-current xorg and kernel update woes veeall Slackware 10 07-19-2009 01:31 AM
[SOLVED] Problem with kqemu in slackware64-current since 2.6.29.5 kernel niels.horn Slackware 3 06-20-2009 05:27 PM


All times are GMT -5. The time now is 12:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration