LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-31-2013, 06:10 PM   #1
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,646

Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Slackware64-current in VirtualBox: if EFI always KMS, else no KMS. Why?


Using an up to date DVD ISO image of Slackware64-current in VirtualBox, here is something I do not understand:
(1) If I activate EFI in the VM, I have always a framebuffer (cat /proc/fb prints "0 EFI VGA"), regardless of the label used at the boot prompt (huge.s or kms.s, ie with or without "nomodeset" in /proc/cmdline).
(2) If I do not activate EFI in the VM, I have never a framebuffer regardless of the label (cat /proc/fb prints nothing).
But both kernels (/EFI/BOOT/huge.s and /kernels/huge.s/bzImage) and initrds (/EFI/BOOT/initrd.img and /isolinux/initrd.img) are identical, as far as md5sum can tell.

Certainly something obvious escapes me again, nevertheless please some kind soul shed some light in my clouded mind.

Last edited by Didier Spaier; 06-02-2013 at 03:39 PM. Reason: typos
 
Old 06-03-2013, 04:25 AM   #2
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,902

Rep: Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963
EFI provides its own framebuffer device (only available when booting with EFI) and the kernel Pat provides has support for this device enabled. A good thing too, otherwise you would just get a black screen.

Code:
$ grep CONFIG_FB_EFI /boot/config-generic-3.8.13
CONFIG_FB_EFI=y

Last edited by ruario; 06-03-2013 at 04:29 AM. Reason: reworded first sentance for clarity
 
1 members found this post helpful.
Old 06-03-2013, 04:34 AM   #3
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,902

Rep: Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963
Read this earlier post I wrote from before this config option was set:

Quote:
Originally Posted by ruario View Post
Just a guess but perhaps the reason for the black screen is due to the lack of EFI Framebuffer support in the kernel (since Slackware does not have this enabled by default). If this suspicion is correct, you should be able to wait until you think booting has complete and login blind, then (assuming you have X and a window manager installed) type startx. At this point the X driver for your video card should take over from the Framebuffer and you should hopefully see something. Alternatively if that is difficult to do or you don't have X but do have network and sshd configured on startup you could try sshing into the machine from another machine on your network to check that Slackware is actually running.

If this is the problem the simple work around is to have Slackware start in runlevel 4 by customising /etc/inittab. The only downside is that you will miss the boot sequence and won't have access to your virtual terminals. The best solution however would be to recompile the kernel with EFI Framebuffer support (CONFIG_FB_EFI=y).
 
1 members found this post helpful.
Old 06-03-2013, 04:45 AM   #4
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,902

Rep: Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963
You might also find this interesting:

Quote:
Originally Posted by rwebber View Post
It seems that an EFI system does not have normal VGA, or text mode or VESA framebuffer support, but requires the new EFI frame buffer support. It's even worse on VirtualBox because its video mode is not supported by Linux until you load the guest additions from a virtual CD.

Last edited by ruario; 06-03-2013 at 04:48 AM. Reason: cropped the quote to just the most relevant bit.
 
Old 06-03-2013, 05:06 AM   #5
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,646

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Thanks for your answers, RuarÝ. Much appreciated!

Somehow this simplifies editing of elilo.conf and isolinux.cfg in the internationalized installer, as I won't need both KMS and non KMS labels in these files.

Despite what wrote rwebber I can boot Slackware64-current in a VirtualBox VM with EFI activated even without the guest additions. The only issue is that loading the initrd takes ages. Nevertheless I will try with the guest additions, just to see if that changes something.

 
Old 06-03-2013, 01:52 PM   #6
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,902

Rep: Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963Reputation: 963
Quote:
Originally Posted by Didier Spaier View Post
Despite what wrote rwebber I can boot Slackware64-current in a VirtualBox VM with EFI activated even without the guest additions. The only issue is that loading the initrd takes ages. Nevertheless I will try with the guest additions, just to see if that changes something.
rwebber wrote that a long time ago before CONFIG_FB_EFI was switched on in the Slackware kernel (he was referring to 13.37 not the current -current). It was actually my comment about the need for EFI Framebuffer support that drew the notice of the team and hence got switch it on for 14.0 and above (not that they wouldn't have realised themselves at some point anyway! Also rwebber noticed it before I did):

Quote:
Originally Posted by Alien Bob View Post
The kernel packages were rebuilt just before going public with this batch, to add
Code:
CONFIG_FB_EFI=y
(it was off at first but I read a post by ruario yesterday, stating that this was needed to get visible framebuffer text on EFI boot).
Anyway I think what rwebber was highlighting was that with no framebuffer enabled in the kernel and no X driver (which would be provided by guest additions) you basically cannot display anything. A clean, vanilla Slackware 13.37 would in fact run under VirtualBox in EFI-mode run but you just wouldn't be able to see it.

Last edited by ruario; 06-03-2013 at 01:56 PM. Reason: re-worded first paragraph
 
Old 07-04-2013, 03:21 PM   #7
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,646

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Problem occurs only on VirtualBox, Slackware installer is OK.

Launching Slackware-current in a non-UEFI real machine does allow to use KMS, so this is actually a limitation of my version of?) VirtualBox, not Slackware's installer.

I can't edit my initial post because it is too old, but please consider this issue as [SOLVED].

Last edited by Didier Spaier; 07-04-2013 at 03:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tip. Want to install 64-current through VirtualBox with EFI ? Use a 64 bit host. Didier Spaier Slackware 1 05-31-2013 02:27 AM
[SOLVED] how to get X not to use KMS? Peterius Debian 5 10-27-2010 02:30 AM
[SOLVED] i915 and KMS? Pratt Slackware 5 03-04-2010 11:19 AM
Nouveau driver + KMS on Slackware64-13.0: it works! (mostly) Didier Spaier Slackware 8 12-12-2009 04:08 AM
Linux KMS Intel 865G: Hacking KMS to use vesa... or disable hardware acceleration eantoranz Linux - Hardware 1 08-01-2009 01:58 PM


All times are GMT -5. The time now is 02:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration