LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-16-2012, 12:23 AM   #1
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 436

Rep: Reputation: Disabled
Slackware64-Current + Bumblebee nvidia proprietary driver not found (but exists)


Hello everybody,

Unfortunately this is one I cannot solve, and it is stressing the crap out of me. I'm attempting to use a new nVidia 650GT video chip (proprietary drivers) with an intel video chipset (i915 is the module):

I used the SlackBuilds here: https://github.com/jgeboski/Bumblebe...09c4efc904b7cf

I am a part of the bumblebee group as well as video (X starts with the intel driver), and I do have an /etc/rc.d/rc.bumblebeed that I do start with rc.local, but I've also tried it manually. The main problem I'm getting is that for some reason, it can't find the nvidia driver:

Code:
$ optirun glxgears
[   67.392196] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nvidia" (module does not exist, 0)

[   67.392280] [ERROR]Aborting because fallback start is disabled.
I've looked this up on Google, but there's just a bunch of ubuntu stuff about nvidia-current which is apparently their package for the beta nvidia drivers. Either way, the module does exist:

Code:
$ lsmod | grep nvidia
nvidia              11178493  0 
i2c_core               19978  7 i2c_algo_bit,i2c_i801,videodev,drm,drm_kms_helper,i915,nvidia
agpgart                27372  4 intel_gtt,intel_agp,drm,nvidia
However, when checking the /var/log/Xorg.8.log:
Code:
[    74.302] 
X.Org X Server 1.12.3
Release Date: 2012-07-09
[    74.302] X Protocol Version 11, Revision 0
[    74.302] Build Operating System: Slackware 13.37 Slackware Linux Project
[    74.302] Current Operating System: Linux Slacker 3.2.26 #1 SMP Tue Aug 7 12:37:07 CDT 2012 x86_64
[    74.302] Kernel command line: auto BOOT_IMAGE=Slackware ro root=fd05 resume=/dev/Slackware64-VG/swap vt.default_utf8=0
[    74.302] Build Date: 10 July 2012  02:27:37PM
[    74.302]  
[    74.302] Current version of pixman: 0.26.2
[    74.302] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    74.302] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    74.302] (==) Log file: "/var/log/Xorg.8.log", Time: Wed Aug 15 22:09:09 2012
[    74.302] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[    74.302] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    74.302] (==) ServerLayout "Layout0"
[    74.302] (==) No screen section available. Using defaults.
[    74.302] (**) |-->Screen "Default Screen Section" (0)
[    74.302] (**) |   |-->Monitor "<default monitor>"
[    74.303] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    74.303] (**) |   |-->Device "Device1"
[    74.303] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    74.303] (**) Option "AutoAddDevices" "false"
[    74.303] (**) Not automatically adding devices
[    74.303] (==) Automatically enabling devices
[    74.303] (WW) The directory "/usr/share/fonts/local" does not exist.
[    74.303] 	Entry deleted from font path.
[    74.303] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    74.303] 	Entry deleted from font path.
[    74.303] (==) FontPath set to:
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/misc,
	/usr/share/fonts/75dpi/:unscaled,
	/usr/share/fonts/100dpi/:unscaled,
	/usr/share/fonts/75dpi,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/cyrillic
[    74.303] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    74.303] (==) |-->Input Device "<default pointer>"
[    74.303] (==) |-->Input Device "<default keyboard>"
[    74.303] (==) The core pointer device wasn't specified explicitly in the layout.
	Using the default mouse configuration.
[    74.303] (==) The core keyboard device wasn't specified explicitly in the layout.
	Using the default keyboard configuration.
[    74.303] (II) Loader magic: 0x7c48e0
[    74.303] (II) Module ABI versions:
[    74.303] 	X.Org ANSI C Emulation: 0.4
[    74.303] 	X.Org Video Driver: 12.0
[    74.303] 	X.Org XInput driver : 16.0
[    74.303] 	X.Org Server Extension : 6.0
[    74.304] (--) PCI:*(0:1:0:0) 10de:0fd1:103c:181d rev 161, Mem @ 0xd2000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[    74.304] (II) Open ACPI successful (/var/run/acpid.socket)
[    74.304] (II) LoadModule: "extmod"
[    74.304] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[    74.304] (II) Module extmod: vendor="X.Org Foundation"
[    74.304] 	compiled for 1.12.3, module version = 1.0.0
[    74.304] 	Module class: X.Org Server Extension
[    74.304] 	ABI class: X.Org Server Extension, version 6.0
[    74.304] (II) Loading extension MIT-SCREEN-SAVER
[    74.304] (II) Loading extension XFree86-VidModeExtension
[    74.304] (II) Loading extension XFree86-DGA
[    74.304] (II) Loading extension DPMS
[    74.304] (II) Loading extension XVideo
[    74.304] (II) Loading extension XVideo-MotionCompensation
[    74.304] (II) Loading extension X-Resource
[    74.304] (II) LoadModule: "dbe"
[    74.304] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[    74.304] (II) Module dbe: vendor="X.Org Foundation"
[    74.304] 	compiled for 1.12.3, module version = 1.0.0
[    74.304] 	Module class: X.Org Server Extension
[    74.304] 	ABI class: X.Org Server Extension, version 6.0
[    74.304] (II) Loading extension DOUBLE-BUFFER
[    74.304] (II) LoadModule: "glx"
[    74.304] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    74.304] (II) Module glx: vendor="X.Org Foundation"
[    74.304] 	compiled for 1.12.3, module version = 1.0.0
[    74.304] 	ABI class: X.Org Server Extension, version 6.0
[    74.304] (==) AIGLX enabled
[    74.304] (II) Loading extension GLX
[    74.304] (II) LoadModule: "record"
[    74.305] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[    74.305] (II) Module record: vendor="X.Org Foundation"
[    74.305] 	compiled for 1.12.3, module version = 1.13.0
[    74.305] 	Module class: X.Org Server Extension
[    74.305] 	ABI class: X.Org Server Extension, version 6.0
[    74.305] (II) Loading extension RECORD
[    74.305] (II) LoadModule: "dri"
[    74.305] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[    74.305] (II) Module dri: vendor="X.Org Foundation"
[    74.305] 	compiled for 1.12.3, module version = 1.0.0
[    74.305] 	ABI class: X.Org Server Extension, version 6.0
[    74.305] (II) Loading extension XFree86-DRI
[    74.305] (II) LoadModule: "dri2"
[    74.305] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[    74.305] (II) Module dri2: vendor="X.Org Foundation"
[    74.305] 	compiled for 1.12.3, module version = 1.2.0
[    74.305] 	ABI class: X.Org Server Extension, version 6.0
[    74.305] (II) Loading extension DRI2
[    74.305] (II) LoadModule: "nvidia"
[    74.305] (WW) Warning, couldn't open module nvidia
[    74.305] (II) UnloadModule: "nvidia"
[    74.305] (II) Unloading nvidia
[    74.305] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    74.305] (II) LoadModule: "mouse"
[    74.305] (II) Loading /usr/lib64/xorg/modules/input/mouse_drv.so
[    74.305] (II) Module mouse: vendor="X.Org Foundation"
[    74.305] 	compiled for 1.12.1, module version = 1.7.2
[    74.305] 	Module class: X.Org XInput Driver
[    74.305] 	ABI class: X.Org XInput driver, version 16.0
[    74.305] (II) LoadModule: "kbd"
[    74.305] (II) Loading /usr/lib64/xorg/modules/input/kbd_drv.so
[    74.305] (II) Module kbd: vendor="X.Org Foundation"
[    74.305] 	compiled for 1.12.1, module version = 1.6.1
[    74.305] 	Module class: X.Org XInput Driver
[    74.305] 	ABI class: X.Org XInput driver, version 16.0
[    74.305] (EE) No drivers available.
[    74.305] 
Fatal server error:
[    74.305] no screens found
[    74.305] 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    74.305] Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[    74.305]
I see that dri2 and dri load, one of which (I forget which, or if it was both) nvidia doesn't like. I don't know how to prevent them from loading (lsmod doesn't show them). I have tried many things including Google, but none show a good way to make the nvidia module findable by Bumblebee. Any help is appreciated.

Additional information:

1. I'm using a multilib setup (and I did enable COMPAT32 in all the .SlackBuilds)

2. The Xorg.8.log shows that nvidia does get loaded, but then gets unloaded and then it complains about it not existing. :/ I'm very lost on that part.

Last edited by TommyC7; 08-16-2012 at 12:28 AM.
 
Old 08-16-2012, 03:00 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,184

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
I don't think that there is a problem with bumblebee, but there could be a conflict with another driver or an incompatibility between nvidia version and xserver version.

Appending full lsmod's output to your next post could help.

Did you blacklist the nouveau module?

Could you tell us which version of the nvidia driver you installed?

I ask that because I have seen reports that in some cases nvidia drivers couldn't be used with newer xorg-server.

Let me quote nVidia's documentation (Chapter 2. Minimum Software Requirements):
Quote:
Sometimes very recent X server versions are not supported immediately following release, but we aim to support all new versions as soon as possible. Support is not added for new X server versions until after the video driver ABI is frozen, which usually happens at the release candidate stage.

Last edited by Didier Spaier; 08-16-2012 at 03:06 AM.
 
Old 08-16-2012, 03:21 AM   #3
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 436

Original Poster
Rep: Reputation: Disabled
No worries! I got it all fixed. I used the same version that's in the *.info from the repository. I had to add a few modules and change the display device:

Code:
$ diff -u /etc/bumblebee/bumblebee.conf~ /etc/bumblebee/bumblebee.conf 
--- /etc/bumblebee/bumblebee.conf~	2012-08-15 20:36:32.364994214 -0700
+++ /etc/bumblebee/bumblebee.conf	2012-08-16 00:09:00.418768764 -0700
@@ -44,14 +44,14 @@
 ## Section with nvidia driver specific options, only parsed if Driver=nvidia
 [driver-nvidia]
 # Module name to load, defaults to Driver if empty or unset
-KernelDriver=
+KernelDriver=nvidia
 Module=nvidia
 PMMethod=auto
 # colon-separated path to the nvidia libraries
-LibraryPath=
+LibraryPath=/usr/lib64/nvidia-bumblebee:/usr/lib/nvidia-bumblebee:/usr/lib64:/usr/lib
 # comma-separated path of the directory containing nvidia_drv.so and the
 # default Xorg modules path
-XorgModulePath=
+XorgModulePath=/usr/lib64/nvidia-bumblebee/xorg,/usr/lib64/xorg/modules
 XorgConfFile=/etc/bumblebee/xorg.conf.nvidia
Code:
$ diff -u /etc/bumblebee/xorg.conf.nvidia~ /etc/bumblebee/xorg.conf.nvidia
--- /etc/bumblebee/xorg.conf.nvidia~	2012-08-16 00:26:00.218725881 -0700
+++ /etc/bumblebee/xorg.conf.nvidia	2012-08-16 00:29:05.034994064 -0700
@@ -9,6 +9,6 @@
     VendorName "NVIDIA Corporation"
     Option "NoLogo" "true"
     Option "UseEDID" "false"
-    Option "UseDisplayDevice" "DFP"
+    Option "ConnectedMonitor" "CRT-0"
 EndSection
optirun will work, although wine programs aren't working so well. :/
=======================
===================================
======================================================================
^ Scratch this crap ^ (aka an edit)
======================================================================
===================================
=======================
To get the wine programs working, I just had to:
Code:
$ optirun bash
bash-4.2$ wine <program>.exe
So yay! All my problems are fixed. TTFN, Ta Ta For Now!

Last edited by TommyC7; 08-16-2012 at 03:45 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wine (1.4) Programs Crash/Freeze on Slackware64-current w/ Nvidia Proprietary Drivers TommyC7 Slackware 13 05-13-2012 10:31 AM
Nvidia driver not working on my Slackware64 current bdahz Slackware 11 05-09-2011 03:37 AM
Slackware64-current and ATi Proprietary Driver ack_iix Slackware 5 03-06-2010 12:09 PM
latest NVIDIA 64bit driver Slackware64-current mudherm Slackware 4 08-16-2009 03:57 AM
Slackware64-current ATI, and few more proprietary questions dolphin77 Linux - Newbie 1 05-22-2009 06:57 PM


All times are GMT -5. The time now is 09:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration