LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-04-2014, 04:44 PM   #16
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 692

Rep: Reputation: 296Reputation: 296Reputation: 296

Quote:
Originally Posted by granth View Post
<snip> I recommend turning off Legacy BIOS boot support.
Can you please expand on this as to why you think the above is a good practice? or is it just in some circumstances in your opinion?
 
Old 02-04-2014, 05:13 PM   #17
granth
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware64
Posts: 210

Rep: Reputation: 39
I had similar issues after I installed this motherboard. I had two disks, one with MBR/lilo, and the other with GPT/elilo. It would ALWAYS choose to boot the MBR/lilo disk, regardless of the boot order I specified or sata port. I think the UEFI even lets you select which method your prefer (EFI first, Legacy BIOS second), but it didn't seem to make a difference.

I'll have to check my settings when I get home, but I'm pretty sure I had to completely turn off legacy bios boot emulation for it to boot my freshly installed Slackware64 14.1 w/ GPT/elilo.
 
Old 02-04-2014, 10:31 PM   #18
granth
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware64
Posts: 210

Rep: Reputation: 39
Sorry, after checking my system, I was wrong about my CSM settings. However, I have to admit that I removed the MBR drive from my system some time ago, and may have changed these settings post-removal.

Under the Compatibility Support Module, I have both UEFI and Legacy OpRom enabled for storage devices (UEFI first).

irgunII - Please post your UEFI/BIOS boot settings. That will help eliminate some possibilities. You should pay close attention to Boot Options #1-3, the Boot Override settings, and the CSM settings. My system lists the GPT/elilo entry as "Slackware (P1: TOSHIBA ***). If you see something similar, that should indicate that your EFI bootloader (elilo) is recognized as a valid boot device.
 
Old 02-05-2014, 08:47 AM   #19
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 377

Original Poster
Rep: Reputation: 65
@granth - Yes, it (the BIOS) sees it as 'Slackware ...' like yours.

An update to what I've done...

I tried and tried and tried to install up until 3AM this morning, constantly making a change here and a change there in the BIOS CSM (the legacy or uefi boot order stuff). Was finally able to get the 'welcome to grub' screen when installing 14.1 instead of the screen one gets that leads only to a lilo install.

I installed 14.1 and again did some builds, downloads, etc and all was working fine. Logged out to get back to 14.0 so I have an alarm to wake me up in the morning's. Then tried to boot back into 14.1...same problem as my original post - won't boot and acts like it doesn't see 14.1 hdd.

I messed with the legacy/uefi boot parameters and it *still* won't boot into 14.1. I even tried windows 8 only...that gave me a bunch of beeps from my MOBO and then booted into 14.0 also.

In 14.0 I can open krusader and get into the file system of 14.1 just fine *except* for the 100MB /boot that is vfat. When I click on that I get the error in the picture I've uploaded.

I also did a search in / of that hdd and can't find 'elilo.conf' anywhere.

Oh, and I was able to upgrade the BIOS from version 0902 to 2209 (or something like that). Doesn't seem to be helping anything though, heh.
Attached Images
File Type: png 14.1 error.png (18.2 KB, 5 views)
 
Old 02-05-2014, 11:32 AM   #20
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,190

Rep: Reputation: Disabled
I think that the EFI System partition may be corrupt for some reason. Try deleting and recreating it using gdisk or cgdisk.
 
Old 02-05-2014, 12:52 PM   #21
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 377

Original Poster
Rep: Reputation: 65
Okay...somehow or another one of the settings I did in the BIOS with the CSM parameters has allowed me to boot into 14.1 and I'm even posting from it right now.

There seems to possibly be a problem of the settings not *staying*...I'll do some more experimentation.

Now that this just may be solved, how do I go about putting the option of which hdd/Slackware I want to boot in my lilo.conf (since sda is my main hdd and has 14.0 on it)?
 
Old 02-06-2014, 11:40 AM   #22
granth
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware64
Posts: 210

Rep: Reputation: 39
I don't think you can boot your GPT disk from the MBR (lilo) bootloader. You'll have to select which disk you want to boot from the bios prompt by pressing <F8> when you see the Asus logo. Each disk type will have a separate bootloader, lilo and elilo.

Here's how I configured elilo.conf w/ custom kernel and memtest additions:

Code:
grant@snafu:~$ cat /boot/efi/EFI/Slackware/elilo.conf
default=Slackware64-snafu
chooser=simple
delay=50
timeout=50
#
image=vmlinuz
        label=Failsafe
        read-only
        append="root=/dev/sda2 vga=normal ro"
#
image=vmlinuz-generic-3.10.17
        label=Slackware64
        initrd=initrd.gz
        read-only
        append="root=/dev/sda2 vga=normal ro"
#
image=vmlinuz-snafu
        label=Slackware64-snafu
        initrd=initrd-snafu.gz
        read-only
        append="root=/dev/sda2 vga=normal ro"
#
image=mt86p420.bin
        label=Memtest
        read-only
One of the cool thing about elilo is, you just edit elilo.conf and drop the kernel files in the same directory. No need to run/install anything afterwards like you do with lilo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] zoneminder-1.25.0 won't build in slackware64-current buckprivatemil Slackware 3 07-19-2013 08:07 PM
[SOLVED] mpd won't install on Slackware64 14 Kangatux Slackware 2 05-03-2013 10:05 AM
[SOLVED] Slackware64 won't boot? JamesGT Slackware 1 02-20-2011 10:09 AM
My headless Slackware64-13.1 won't boot without video card after new kernel compile rutrow Slackware 2 01-04-2011 04:55 PM
Slackware64 13.1 - won't boot after update - VFS Cannot open root device khinch Slackware 8 11-13-2010 04:25 PM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration