LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-09-2014, 01:02 AM   #1
Plutonium
LQ Newbie
 
Registered: Jan 2006
Location: Sweden
Distribution: Slackware
Posts: 12

Rep: Reputation: 2
Slackware64-14.1 Syslog Disabling IRQ #16


Hey.
I have a very disturbing problem that affecting my network speed significantly, it's very slow.
I got this error after a bit of workingtime with the computer, sometimes right after a boot or a couple of hours.

Setup:
Slackware64-14.1 (UEFI) right out the box with 3.10.17 huge kernel

Log's:
Code:
Message from syslogd@plutonium at Tue Jan  7 18:10:50 2014 ...
plutonium kernel: [ 8982.908169] Disabling IRQ #16



dmesg:
[   84.003324] hda-intel 0000:00:1b.0: Unstable LPIB (130808 >= 8192); disabling LPIB delay counting
[ 8982.908115] irq 16: nobody cared (try booting with the "irqpoll" option)
[ 8982.908118] CPU: 0 PID: 0 Comm: swapper/0 Tainted: P         C O 3.10.17 #2
[ 8982.908119] Hardware name: System manufacturer System Product Name/P8P67 EVO, BIOS 3602 11/01/2012
[ 8982.908120]  ffff880215b21f8c ffff88021ec03e70 ffffffff81b66dc6 ffff88021ec03e98
[ 8982.908122]  ffffffff810d4e52 ffff880215b21f00 0000000000000010 0000000000000000
[ 8982.908123]  ffff88021ec03ed8 ffffffff810d5258 00000010208247db 0000000000000000
[ 8982.908124] Call Trace:
[ 8982.908125]  <IRQ>  [<ffffffff81b66dc6>] dump_stack+0x19/0x1b
[ 8982.908132]  [<ffffffff810d4e52>] __report_bad_irq+0x32/0xd0
[ 8982.908133]  [<ffffffff810d5258>] note_interrupt+0x138/0x1f0
[ 8982.908135]  [<ffffffff810d2d09>] handle_irq_event_percpu+0xe9/0x1d0
[ 8982.908136]  [<ffffffff810d2e26>] handle_irq_event+0x36/0x60
[ 8982.908138]  [<ffffffff810d5d95>] handle_fasteoi_irq+0x55/0xf0
[ 8982.908140]  [<ffffffff810042be>] handle_irq+0x1e/0x30
[ 8982.908141]  [<ffffffff81b711dd>] do_IRQ+0x4d/0xc0
[ 8982.908143]  [<ffffffff81b6edaa>] common_interrupt+0x6a/0x6a
[ 8982.908143]  <EOI>  [<ffffffff81a46f7c>] ? cpuidle_enter_state+0x4c/0xc0
[ 8982.908147]  [<ffffffff81a46f78>] ? cpuidle_enter_state+0x48/0xc0
[ 8982.908148]  [<ffffffff81a470be>] cpuidle_idle_call+0xce/0x200
[ 8982.908150]  [<ffffffff8100b3ae>] arch_cpu_idle+0xe/0x30
[ 8982.908151]  [<ffffffff810a284e>] cpu_startup_entry+0xce/0x270
[ 8982.908153]  [<ffffffff81b4d9e2>] rest_init+0x72/0x80
[ 8982.908155]  [<ffffffff8211de28>] start_kernel+0x3c7/0x3d3
[ 8982.908156]  [<ffffffff8211d86a>] ? repair_env_string+0x5c/0x5c
[ 8982.908158]  [<ffffffff8211d5a3>] x86_64_start_reservations+0x2a/0x2c
[ 8982.908159]  [<ffffffff8211d671>] x86_64_start_kernel+0xcc/0xcf
[ 8982.908160] handlers:
[ 8982.908161] [<ffffffff819d3500>] usb_hcd_irq
[ 8982.908168] [<ffffffffa02870c0>] rtl8169_interrupt [r8169]
[ 8982.908169] Disabling IRQ #16


lspci:
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)

cat /proc/interrupts
16:    2900184          0          0          0          0          0          0          0   IO-APIC-fasteoi   ehci_hcd:usb1, eth0
Any help is appreciated, thanks!

Last edited by Plutonium; 01-09-2014 at 01:03 AM.
 
Old 01-09-2014, 01:08 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,413

Rep: Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857
Quote:
Originally Posted by Plutonium View Post
[ 8982.908115] irq 16: nobody cared (try booting with the "irqpoll" option)
have you tried passing that to the kernel at boot?
 
1 members found this post helpful.
Old 01-09-2014, 02:38 AM   #3
Plutonium
LQ Newbie
 
Registered: Jan 2006
Location: Sweden
Distribution: Slackware
Posts: 12

Original Poster
Rep: Reputation: 2
No I haven't.. How do I do that with elilo? I'm not at all familiar with this uefi stuff.
 
Old 01-09-2014, 04:25 AM   #4
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 803

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
PCI device 00:16.0 doesn't have anything to do with IRQ 16.

Most likely the semi-broken r8169 kernel module is causing the issue. That's why your network speed is bad. Try blacklisting it and replace it with r8168 version 8.037.00 available at

http://www.realtek.com.tw/downloads/...etDown=false#2

RTL 8168/8111 is a very common desktop NIC, but kernel developers don't care for desktops anymore, because in servers you usually find Intel NICs.

Last edited by jtsn; 01-09-2014 at 04:28 AM.
 
1 members found this post helpful.
Old 01-09-2014, 09:24 AM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,413

Rep: Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857
Quote:
Originally Posted by Plutonium View Post
No I haven't.. How do I do that with elilo? I'm not at all familiar with this uefi stuff.
it's just like with lilo.
When you start the computer and get to the elilo screen, press "Tab" on the keyboard to get a list of the available kernel labels: by default you should have a "Linux" label.
Then simply digit the label name and the kernel parameters to apply on the fly, like
Code:
Linux irqpoll
and press enter to boot the kernel.
 
1 members found this post helpful.
Old 01-09-2014, 10:43 AM   #6
metaschima
Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 980

Rep: Reputation: Disabled
I would agree that the r8169 driver module is the cause. You could try a newer kernel in case they fixed it.
 
Old 01-11-2014, 04:31 AM   #7
Plutonium
LQ Newbie
 
Registered: Jan 2006
Location: Sweden
Distribution: Slackware
Posts: 12

Original Poster
Rep: Reputation: 2
Thanks for the support!
Seems that irqpoll option did the trick.
 
1 members found this post helpful.
Old 02-07-2014, 03:34 PM   #8
Plutonium
LQ Newbie
 
Registered: Jan 2006
Location: Sweden
Distribution: Slackware
Posts: 12

Original Poster
Rep: Reputation: 2
Hi again.
Thanks again for the advice last time, irqpoll did the trick

A new question about this option,
how can I add the irqpoll option to elilo.conf so that I doesn't need to manual add the option at boot?
 
Old 02-07-2014, 04:37 PM   #9
metaschima
Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 980

Rep: Reputation: Disabled
Add it to the append option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling irq 16 mathieudutour Linux - Newbie 3 07-17-2013 09:37 AM
Disabling IRQ #16 blue_k Slackware 44 07-30-2011 05:25 AM
Disabling irq #19 mengchun_khor Linux - Newbie 2 08-15-2008 10:10 AM
Disabling IRQ #17 okos Linux - Newbie 4 10-04-2007 07:54 PM
Disabling IRQ #11 keripukki Linux - Hardware 4 09-18-2004 05:54 PM


All times are GMT -5. The time now is 01:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration